Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Команда "выполнить" нету, у внешней,подключаемой обработки. Как на фото.

Команда "выполнить" нету,  у внешней,подключаемой обработки.  Как на фото.
Я
   SkillUp
 
11.07.18 - 10:43
Здр., задание переделать внешнюю обработку под внешнюю подключаемую...
Добавил нужные функции и процедуры в модуль объекта, теперь не могу понять как проверить на работоспособность? Команды "Выполнить" Как на фото - https://yadi.sk/i/zmmkvC_j3Z3nCi, у меня нету. Куда смотреть, что делать?
 
 
   SkillUp
 
1 - 11.07.18 - 10:45
Доп. информация - в обработке, на форме пользователь выбирает даты и при нажатии на кнопку содаются документы...
   Не кассир
 
2 - 11.07.18 - 10:47
(0) Ни чо не понятно.
   DrShad
 
3 - 11.07.18 - 10:49
а куда она должна подключаться?
   SkillUp
 
4 - 11.07.18 - 10:49
Как запусить внешнюю поключаемую обраьотку?! Которую уже добавил в базу?
   Serg_1960
 
5 - 11.07.18 - 10:49
Как раз всё понятно объяснил - на форме нет кнопки "Выполнить" - чего уж тут непонятного? :))
   SkillUp
 
6 - 11.07.18 - 10:50
(5) Вот и пытаюсь выяснить у опытных, как проверить на работоспособность внешн.  поключаемую обработку ?
   Не кассир
 
7 - 11.07.18 - 10:53
(5) На фото, тоже нету.
   Serg_1960
 
8 - 11.07.18 - 10:53
Скорее всего - не верно "прописал" внешнюю обработку в функции СведенияОВнешнейОбработке().
   Не кассир
 
9 - 11.07.18 - 10:54
(6) Так внешн. или "Которую уже добавил в базу"?
   SkillUp
 
10 - 11.07.18 - 10:54
(8) ООООООООООООООООО!!!!! НАконец-то!!!!
 
 Рекламное место пустует
   SkillUp
 
11 - 11.07.18 - 10:55
(9) Которую уже добавил в базу!!! Пардон.
   Не кассир
 
12 - 11.07.18 - 10:55
(10) Что с тобой? Успокойся  и не ори.
   SkillUp
 
13 - 11.07.18 - 10:56
(12) Не ору, просто уже незнаю что делать...
   Не кассир
 
14 - 11.07.18 - 10:56
(11) Короче, каша у тебя в голове.
   SkillUp
 
15 - 11.07.18 - 10:58
(14) ))) конечно каша,не могу понять, что не так делаю!!! Ни разу такого подобного не делал...
   dezss
 
16 - 11.07.18 - 10:58
(0) Размещение задай.
   dezss
 
17 - 11.07.18 - 10:59
(0) и выложи сюда скрин своей подключенной обработки.
   SkillUp
 
18 - 11.07.18 - 11:00
Мой код, может кто-то подскаже что не так...
Функция СведенияОВнешнейОбработке() Экспорт

ДанныеДляРег = Новый Структура();
ДанныеДляРег.Вставить("Наименование", "Обработка создания налоговых накладных");
ДанныеДляРег.Вставить("БезопасныйРежим", Истина);
ДанныеДляРег.Вставить("Версия", "ver.: 1.001");
ДанныеДляРег.Вставить("Информация", "Обработка создания налоговых накладных");
ДанныеДляРег.Вставить("Вид", "ДополнительнаяОбработка");

ТабЗнКоманды = Новый ТаблицаЗначений;
ТабЗнКоманды.Колонки.Добавить("Идентификатор");
ТабЗнКоманды.Колонки.Добавить("Использование");
ТабЗнКоманды.Колонки.Добавить("Представление");

НовСтрока = ТабЗнКоманды.Добавить();
НовСтрока.Идентификатор = "ОткрытьОбработку";
НовСтрока.Использование = "ОткрытиеФормы";
НовСтрока.Представление = "Открыть обработку";
ДанныеДляРег.Вставить("Команды", ТабЗнКоманды);

Возврат ДанныеДляРег;

КонецФункции
   SkillUp
 
19 - 11.07.18 - 11:03
Короче, не знаю что делать...
   dezss
 
20 - 11.07.18 - 11:05
(19) прочитай (16)
   SkillUp
 
21 - 11.07.18 - 11:08
(20) Пож., подскажи за "Размещение задай", то  у меня каша в голове...
   Не кассир
 
22 - 11.07.18 - 11:09
(21) ты еще и пишешь плохо....
   ildary
 
23 - 11.07.18 - 11:11
(21) Попробуйте меньше спамить на форуме, вместо этого активно погуглите как правильно писать СведенияОВнешнейОбработке() - в интернете тонна примеров.
   SkillUp
 
24 - 11.07.18 - 11:14
(23) Ок.
   Serg_1960
 
25 - 11.07.18 - 11:46
Я посмотрел в своей конфигурации (как обычно автор не озвучил свою)- там видимость кнопки "Выполнить" зависит от:

    ЭтоГлобальнаяОбработка = (Объект.Вид = ВидДополнительнаяОбработка ИЛИ Объект.Вид = ВидДополнительныйОтчет);
    КоличествоКоманд = Объект.Команды.Количество();

    Элементы.ВыполнитьКоманду.Видимость = Ложь;
    Если ЭтоГлобальнаяОбработка И КоличествоКоманд > 0 Тогда
        Для Каждого СтрокаТаблицыКоманд Из Объект.Команды Цикл
            Если СтрокаТаблицыКоманд.ВариантЗапуска = ПредопределенноеЗначение("Перечисление.СпособыВызоваДополнительныхОбработок.ОткрытиеФормы")
                Или СтрокаТаблицыКоманд.ВариантЗапуска = ПредопределенноеЗначение("Перечисление.СпособыВызоваДополнительныхОбработок.ВызовКлиентскогоМетода")
                Или СтрокаТаблицыКоманд.ВариантЗапуска = ПредопределенноеЗначение("Перечисление.СпособыВызоваДополнительныхОбработок.ВызовСерверногоМетода")
                Или СтрокаТаблицыКоманд.ВариантЗапуска = ПредопределенноеЗначение("Перечисление.СпособыВызоваДополнительныхОбработок.СценарийВБезопасномРежиме") Тогда
                Элементы.ВыполнитьКоманду.Видимость = Истина;
                Прервать;
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
   Serg_1960
 
26 - 11.07.18 - 11:53
Ничего в голову умного не приходит, кроме как в параметрах регистрации использовать ""ВерсияБСП", ""РежимСовместимостиРазрешений" и указывать, например, не "НовСтрока.Использование = "ОткрытиеФормы", а "НовСтрока.Использование = Перечисления.СпособыВызоваДополнительныхОбработок.ОткрытиеФормы"... как-то типа так.
   Serg_1960
 
27 - 11.07.18 - 12:06
PS: посмотри структуру справочника "ДополнительныеОтчетыИОбработки"; пропиши свою обработку так-же, как в ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке().
   SkillUp
 
28 - 11.07.18 - 13:22
(27) Спасибо.
   ptiz
 
29 - 11.07.18 - 13:33
Только не говорите после этого, что под конфы на УФ программировать легче :)
   K1RSAN
 
30 - 11.07.18 - 13:57
ХЗ, когда я в первый раз делал внешнюю обработку - просто нашел в интернете любую обработку и посмотрел, как заполняется процедура Сведения о внешней обработке. И после пары мелких косяков всё получилось. Минут за 10 наверное решил эту проблему
   K1RSAN
 
31 - 11.07.18 - 13:58
Да даже банально пишешь в гугле "как сделать внешнюю обработку" там можно найти по твоей проблеме ответы
   SkillUp
 
32 - 11.07.18 - 16:00
(30) Блин, та и делаю как ты ииии оболомм, а где ошибка не могу понять!!!
   SkillUp
 
33 - 11.07.18 - 16:00
(31) Поэтому и хотел посоветоватся, ну буду детально разбирать. А что делать?!
 
 
   Вафель
 
34 - 11.07.18 - 16:02
Вот пример отчета
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.2.2.1");
    
    // HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ADODB.Connection
    Разрешение = РаботаВБезопасномРежиме.РазрешениеНаИспользованиеКаталогаВременныхФайлов(Истина, Истина, "Передача файла с данными на сервер");
    ПараметрыРегистрации.Разрешения.Добавить(Разрешение);
    
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительныйОтчет();
    ПараметрыРегистрации.Версия = Метаданные().Комментарий;
    ПараметрыРегистрации.БезопасныйРежим = Истина;
    ПараметрыРегистрации.Информация = Метаданные().Представление();
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = Метаданные().Представление();
    НоваяКоманда.Идентификатор = Метаданные().Имя;
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
    НоваяКоманда.ПоказыватьОповещение = Ложь;
    
    Возврат ПараметрыРегистрации;

   SkillUp
 
35 - 11.07.18 - 16:18
(34) Благодарю...
   Serg_1960
 
36 - 11.07.18 - 16:20
"Найдите все отличия в двух картинках"(цы) :)

ДанныеДляРег.Вставить("Вид", "ДополнительнаяОбработка");
ДанныеДляРег.Вставить("Вид", ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта());
   SkillUp
 
37 - 11.07.18 - 16:55
(36) Та это уже 6-ая или 7-ая моя переаботка, возможно уже напутал там, что черт ногу сломает, буду сегодня внимательно каждый пункт разбирать. Т,О уже самому стыдно...
   SkillUp
 
38 - 11.07.18 - 16:55
(36) Спасибо, гляну...
   SkillUp
 
39 - 11.07.18 - 16:58
(36) Заинтересовало...
   Chameleon1980
 
40 - 11.07.18 - 18:54
гугли Шаблон внешней печатной формы
или Шаблон подключаемой обработки
и еще погугли конструктор внешних печатных форм

не благодари.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует