Вход | Регистрация


Дробные числа из Excel загружаются как целые.

Дробные числа из Excel загружаются как целые.
Я
   LLIaMaH
 
11.07.18 - 06:32
Привет. ЗАгружаем большое количество эксель файлов через ODBC, если файл открыть и начать редактировать ячейки, то там видно что часть данных имеют дробную часть, но при отображении в файле округляются до целых, читаются они тоже как целые. Подкинте идею как с этим справиться.
 
 
   catena
 
1 - 11.07.18 - 06:38
Подкинте идею как с этим справиться - > Не округлять. Загружать значения, а не отображения.
   LLIaMaH
 
2 - 11.07.18 - 06:44
(1) ты имеешь в виду OriginalValue? пробовали не работает, причем копали дальше, можно указывть раныек курсоры и блокировки тоже не работает, НО!!! если файл открыть и читать его паралельно ОДБС драйвером то читает данные правильно.

Пока RecordSet.EOF <> True Цикл
        Нов = лТЗ_Результат.Добавить();
        лИндекс = 0;
        Для Каждого Field Из RecordSet.Fields Цикл
            Если Field.ActualSize >= 0 Тогда
                Если OriginalValue Тогда
                    Нов[лИндекс] = Field.OriginalValue;
                Иначе
                    Нов[лИндекс] = Field.Value;
                КонецЕсли;
            КонецЕсли;
            лИндекс = лИндекс + 1;
        КонецЦикла;    
        RecordSet.MoveNext();
    Конеццикла;
   LLIaMaH
 
3 - 11.07.18 - 10:05
ап

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует