Вход | Регистрация


xcopy не отрабатывает из 1С

xcopy не отрабатывает из 1С
Я
   DTX 4th
 
10.07.18 - 16:53
ВыполнитьКоманду(Ком);//xcopy "c:\tmp\dir" "c:\tmp\dir2\tmp\dir" /Y /I >> "C:\tmp\2018_07_10_16_49_57.txt"

Не работает на одном компе. На остальных всё норм. В логе виднеется "0 files copied". Если эту же строку (Ctrl-C -> Ctrl-V) выполнить в cmd, то всё отработает без проблем. С чем может быть связано?
 
 
   Cool_Profi
 
1 - 10.07.18 - 17:02
права?
   HawkEye
 
2 - 10.07.18 - 17:03
(0) запусти 1С с правами администратора....
   DTX 4th
 
3 - 10.07.18 - 17:46
(2) Не помогло
(1) Пользователь - админ
   hhhh
 
4 - 10.07.18 - 17:47
(3) может на сервере выполняешь ??
   DTX 4th
 
5 - 10.07.18 - 17:48
(4) &НаКлиенте
   Cyberhawk
 
6 - 10.07.18 - 17:49
Права процесса ОС / пользователя ОС
   Вафель
 
7 - 10.07.18 - 18:04
не может такого быть
   hhhh
 
8 - 10.07.18 - 18:11
(5) тогда смотри права на папки эти
   Вафель
 
9 - 10.07.18 - 18:28
может в момент запуска никаких файлов еще нет? случайно не архив разворачиваешь?
   DTX 4th
 
10 - 10.07.18 - 18:39
(7) Как видишь, может.

В общем, проблема была с кодировкой.
ВыполнитьКоманду(Ком)

нормально не отрабатывает. Пришлось извернуться вот так:
Запись = Новый ЗаписьТекста(Батник, КодировкаТекста.OEM);
Запись.ЗаписатьСтроку(Ком);
Запись.Закрыть();
КомандаСистемы(Батник);

И всё заработало. Но это явно косяк. Либо 1С, либо винды.
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует