Вход | Регистрация


Синхронизация данных между УПП и ДО, УПП рисует префиксы базы ДО

Синхронизация данных между УПП и ДО, УПП рисует префиксы базы ДО
Я
   Shur1cIT
 
10.07.18 - 16:21
Обмен настроен по средствам правил конвертации, в УПП префикса нет, в ДО есть собственно он так и называется "ДО" прилител контрагент из ДО с кодом ДО-0000001 всё ок, создаём контрагента у УПП ему назначается код ДО-0000002  собственно вопрос почему? он же должен свой префикс добавлять (пустой), а не тупо номер по порядку ставить, посмотрел процедуру формирование нового номера справочника не обнаружил механизма определения чужого префикса.

Процедура ПриУстановкеНовогоКодаСправочникаПриУстановкеНовогоКода(Источник, СтандартнаяОбработка, Префикс) Экспорт
    ДобавитьПрефиксУзла(Префикс);
КонецПроцедуры


Процедура ДобавитьПрефиксУзла(Префикс) Экспорт
    
        Если ПараметрыСеанса.ИспользованиеРИБ Тогда
            Префикс = ПараметрыСеанса.ПрефиксУзлаРаспределеннойИнформационнойБазы + Префикс;
        КонецЕсли;
    
КонецПроцедуры
 
 
   Джинн
 
1 - 10.07.18 - 16:25
Стыдно с такой длинной полоской не знать элементарных вещей.
   Shur1cIT
 
2 - 10.07.18 - 16:25
вопрос, как работает механизм отсечения чужого префикса и добавление своего?
   Shur1cIT
 
3 - 10.07.18 - 16:26
(1) распределенной базой работал последний раз на 7.7
   Джинн
 
4 - 10.07.18 - 16:31
(2) Вы думаете в УПП свой префикс при настройке обмена зря просят указать?
   Shur1cIT
 
5 - 10.07.18 - 16:34
(4) согласен что причина скорее всего в этом, но как он определяет следующий код относительно своего префикса игнорируя номер переферийной базы?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует