Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

НДС в чеках

НДС в чеках
Я
   НатГолубева777
 
08.07.18 - 13:46
Здравствуйте... не получается убрать ндс с чека... ФР-Викки Принт 57  плюс Ф с ФН, а УТ 10.03. ред. 10.3 (10.3.45.2)… Согласна на оплачиваюмую помощь...или хотябы подсказали как убрать...Уже 4 дня мучаюсь.. не получается...Везде настройку сделала... все равно никак...чрез удаленку подключу к 1с.. SOS  SOS  SOS
 
 
   НатГолубева777
 
1 - 08.07.18 - 13:47
И код написала... Запрос = Новый Запрос;
         Запрос.Текст = 
         "ВЫБРАТЬ
         |    УчетнаяПолитикаНалоговыйУчетСрезПоследних.ОрганизацияНеЯвляетсяПлательщикомНДС
         |ИЗ
         |    РегистрСведений.УчетнаяПолитикаНалоговыйУчет.СрезПоследних КАК УчетнаяПолитикаНалоговыйУчетСрезПоследних
         |ГДЕ
         |    УчетнаяПолитикаНалоговыйУчетСрезПоследних.Организация = &Организация";
         Запрос.УстановитьПараметр("Организация",ЭтотОбъект.Организация);   
         Результат = Запрос.Выполнить();
         ТЗ=Результат.Выгрузить();
                Если ТЗ.Количество() > 0 Тогда
                  СтрокаЧека.СтавкаНДС = "";
                Иначе     
                СтрокаЧека.СтавкаНДС = МенеджерОборудованияКлиентСервер.ПолучитьСтавкуНДСДляФискализацииЧека
            (СтрокаТовара.Номенклатура.СтавкаНДС, ПорядокНалогообложения)// Cтавка НДС в %


            КонецЕсли;
   Alexor
 
2 - 08.07.18 - 14:48
Как удалить?

Ставка НДС обязательна.
Передается из чека. В чеке НДС есть?

Версия торговля какая?
Какой версии драйвер используете?
   Asmody
 
3 - 08.07.18 - 14:48
А с чего вы взяли, что его там не должно быть?
   НатГолубева777
 
4 - 08.07.18 - 15:20
ТОРГОВЛЯ НАХОДИТСЯ НА ЕНВД... В ЧЕКЕ НДС 18 %....НЕ ПОНИМАЮ ОТКУДА ОН ВЗЯЛСЯ,,, ВСЕ НАСТРОЙКИ Я СДЕЛАЛА
УТ 10.3 ред  10.3 (10.3.45.2)
Обработка Dreamkas_VikiPrint_8.2.epf
   НатГолубева777
 
5 - 08.07.18 - 15:21
ФР ВИКИ ПРИНТЕР 57 плюс Ф с ФН
   Красный рассвет
 
6 - 08.07.18 - 15:22
(4) И незачем так орать! (с)
Лучше фоту в профиль добавить и пол там же сменить на правильный... если сейчас он неправильный.
Будет больше надежды.
   Garykom
 
7 - 08.07.18 - 15:27
(4)
//  НДС                            - <Число>
//                                 - Ставка НДС в %
Функция ПечататьСтроку(Объект, Наименование, Количество, Цена, Скидка, Отдел, НДС) Экспорт
    Результат = мНетОшибки;
    ЗначениеСкидки = Окр(Количество * Цена * Скидка * 0.01, 2);
    Сумма = Окр(Количество * Цена - ЗначениеСкидки, 2);
    // Печать строки чека

    Если Не Объект.ОборудованиеОбъект.НапечататьФискСтроку(Объект.ИДУстройства, Наименование, Количество, Цена, Сумма, Отдел, НДС) Тогда
        Результат = мОшибкаНеизвестно;
        Объект.ОборудованиеОбъект.ПолучитьОшибку(Объект.ОписаниеОшибки);
    КонецЕсли;
    Возврат Результат;
КонецФункции// ПечататьСтроку()


Попробуй подставлять разные числа - ставки НДС и опытным путем проверить что будет.

У атол и штрих проблема обновления прошивки ККТ, ставки НДС новые не соответствуют старым. Тут скорее всего та же хрень или обновляй драйвера и обработку
   Garykom
 
8 - 08.07.18 - 15:28
И да для версии Ф обработка другая
https://dreamkas.ru/fiskalnye-registratory/viki-print-57/podderzhka/
   Garykom
 
9 - 08.07.18 - 15:29
(8)+ "Dreamkas_VikiPrint_onlineKKT_8.2.epf"
   НатГолубева777
 
10 - 08.07.18 - 16:48
ВСТАВИЛА НОВУЮ ОБРАБОТКУ..Драйвер такой же
 
 Рекламное место пустует
   НатГолубева777
 
11 - 08.07.18 - 16:53
Garykom, может посмотришь что у нас через подключение на наш раб. стол...По цене думаю договоримся...
   НатГолубева777
 
12 - 08.07.18 - 18:24
Создала обработку в процедуре при нажатии на кнопку...и в результате через отладчик выводит пустую строку ""....Правилно ли это при печатинии чека через Ф.Р.??? И как узнать какая цыфра или какое значение должно попадать в Ф.Р.???  Ниже код...


Запрос = Новый Запрос;
         Запрос.Текст = 
         "ВЫБРАТЬ
         |    УчетнаяПолитикаНалоговыйУчетСрезПоследних.ОрганизацияНеЯвляетсяПлательщикомНДС
         |ИЗ
         |    РегистрСведений.УчетнаяПолитикаНалоговыйУчет.СрезПоследних КАК УчетнаяПолитикаНалоговыйУчетСрезПоследних
         |ГДЕ
         |    УчетнаяПолитикаНалоговыйУчетСрезПоследних.Организация = &Организация";
         Запрос.УстановитьПараметр("Организация",ЭтотОбъект.Организация);   
         Результат = Запрос.Выполнить();
         ТЗ=Результат.Выгрузить();
                Если ТЗ.Количество() > 0 Тогда
                  СтрокаЧека.СтавкаНДС = МенеджерОборудованияКлиентСервер.ПолучитьСтавкуНДСДляФискализацииЧека
            (СтавкаНДС, "ЕНВД");
                Иначе     
                СтрокаЧека.СтавкаНДС = 5            КонецЕсли;
   karpik666
 
13 - 08.07.18 - 20:17
(12) если не получается разобраться, то воспользуйтесь внешней обработкой http://catalog.mista.ru/public/590993/?ref=1050 , не нужно знать ут 10.3, чтобы настроить печать так как вам нужно.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует