Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Автоматическое создание РКО на основании

Автоматическое создание РКО на основании
Я
   sergqwert
 
07.07.18 - 19:33
Имеется заказ поставщику, на форме заказа поставщику есть галочка заказ оплачен. Когда устанавливаю галочку - создается новый документ РКО. При снятии галочки ЗаказОплачен документ должен помечаться на удаление. Не помечается на удаление созданный документ. Конфигурация УТ 10.3.
Привожу пример кода:
Если ЗаказОплачен = Истина Тогда 
НовДок = Документы.РасходныйКассовыйОрдер.СоздатьДокумент(); 
Если Не НовДок.Пустая()Тогда 
Вопрос("Документ не существует!", РежимДиалогаВопрос.ОК, , , "Поиск"); 
КонецЕсли; 
НовДок.Дата = ТекущаяДата(); 
НовДок.УстановитьНовыйНомер(); 
НовДок.Организация = Организация; 
НовДок.Касса = Справочники.Кассы.НайтиПоКоду("000000001"); 
НовДок.ВидОперации = Перечисления.ВидыОперацийРКО.ОплатаПоставщику; 
НовДок.Контрагент = Контрагент; 
НовДок.ДоговорКонтрагента = ДоговорКонтрагента; 
НовДок.СуммаДокумента = СуммаДокумента; 
НовДок.ОтраженоВОперУчете = Истина; 
НовДок.Оплачено = Истина; 
НовДок.Ответственный = ПараметрыСеанса.ТекущийПользователь;
НовДок.ОтражатьВУправленческомУчете = Истина; 
НовДок.ОтражатьВБухгалтерскомУчете = Истина; 
НовДок.ОтражатьВНалоговомУчете = Истина; 
НовДок.ВалютаДокумента = Константы.ВалютаРегламентированногоУчета.Получить(); 
НовДок.Подразделение = Подразделение; 
НовДок.СтатьяДвиженияДенежныхСредств = Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоНаименованию("Оплата поставщику"); 
НоваяСтрока = НовДок.РасшифровкаПлатежа.Добавить(); 
НоваяСтрока.ДоговорКонтрагента = ДоговорКонтрагента; 
НоваяСтрока.СуммаПлатежа = СуммаДокумента; 
НоваяСтрока.СуммаВзаиморасчетов = СуммаДокумента; 
НоваяСтрока.СтавкаНДС = Перечисления.СтавкиНДС.НДС18; 
НоваяСтрока.СуммаНДС = НоваяСтрока.СуммаПлатежа/6; 
НоваяСтрока.КурсВзаиморасчетов = 1; 
НоваяСтрока.КратностьВзаиморасчетов = 1; 
НоваяСтрока.Сделка = Ссылка; 
НоваяСтрока.СтатьяДвиженияДенежныхСредств = Справочники.СтатьиДвиженияДенежныхСредств.НайтиПоНаименованию("Оплата поставщику"); 

НовДок.Записать(РежимЗаписиДокумента.Запись); 
Иначе 
НовДок.ПолучитьОбъект(); 
НовДок.УстановитьПометкуУдаления(Истина); 
КонецЕсли;
 
 
   Aleksey
 
1 - 07.07.18 - 19:55
а если так

Иначе 
НовДок.ПолучитьОбъект().УстановитьПометкуУдаления(Истина); 
КонецЕсли;

ну или 

Иначе 
ДокОбъект = НовДок.ПолучитьОбъект(); 
ДокОбъект.УстановитьПометкуУдаления(Истина); 
КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует