Вход | Регистрация

1С:Предприятие ::

Метки: 

Как заполнить колонку ТЗ датой?

Я
   SkillUp
 
05.07.18 - 19:27
у меня сейчас такое:
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        ТабСотр.Колонки.Добавить(ВыборкаДетальныеЗаписи.поле1, Новый ОписаниеТипов("Дата"));
    КонецЦикла;

Выдает ошибку: {ВнешняяОбработка.ВыборкаЖурнала.Форма.Форма.Форма(128)}: Ошибка при вызове метода контекста (Добавить)
        ТабСотр.Колонки.Добавить(ВыборкаДетальныеЗаписи.поле1, Новый ОписаниеТипов("Дата"));
по причине:
Неверное имя колонки


НЕУЖЕЛИ ИЗ-ЗА ПРОБЛЕА?
 
  Рекламное место пустует
   SkillUp
 
1 - 05.07.18 - 19:30
Хм... Не из-за пробела... А какжеж, колонку именно датой заполнить?
   polosov
 
2 - 05.07.18 - 19:37
Тебе надо чтобы наименование колонки было датой?
   polosov
 
3 - 05.07.18 - 19:39
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        
НоваяСтрока = ТабСотр.Добавить();
ТабСотр.ТвояКолонкаСДатой = ВыборкаДетальныеЗаписи.поле1;
    КонецЦикла;

Это если строки.
   SkillUp
 
4 - 05.07.18 - 19:39
ДА!
   SkillUp
 
5 - 05.07.18 - 19:40
(3) ОГРОМНОЕ СПАСИБО!
   polosov
 
6 - 05.07.18 - 19:40
НоваяСтрока.ТвояКолонкаСДатой = ВыборкаДетальныеЗаписи.поле1;

Вот так только
   SkillUp
 
7 - 05.07.18 - 19:44
(6) ОК!
   SkillUp
 
8 - 05.07.18 - 19:46
(6) И на этом спасибо...
   Chameleon1980
 
9 - 06.07.18 - 05:03
а еще, если имена колонок твоих и псевдонимов запросов будут хоть частично совпадать открой для себя "ЗаполнитьЗначенияСвойтсв"

Пока Выборка.Следующий() Цикл
   НоваяСтрока=ТвояТаблица.Добавить();
   ЗаполнитьЗначенияСвойтсв(НоваяСтрока, Выборка);
КонецЦикла;


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует