Вход | Регистрация

1С:Предприятие ::

Метки: 

Как сохранить таблицу обработки?

Я
   Мисти
 
05.07.18 - 18:36
В таблице хранится некое соответствие - 3-5 строк, как бы ее сохранять между запуском обработки??
 
 
   Мисти
 
1 - 05.07.18 - 18:37
Какой-то метод "встрокувнутрь" еще помню с 7, но у меня нет такого примера в 8.
   Aleksandr N
 
2 - 05.07.18 - 18:40
(0) В свойствах формы поставить сохранять значения, ниже в значениях галочкой отметить эту таблицу.
   Мисти
 
3 - 05.07.18 - 18:41
Там нет галочки. На "шапке" - пожалуйста, а на таб. части - нет.
Это 8.2
   Мисти
 
4 - 05.07.18 - 19:13
&НаСервере
Процедура СохранитьНастройки()

КлючНастроек = "ОтчетВасиПупкина";
Настройки = Новый Соответствие;

Настройки.Вставить("ТЧКоторуюХотетьСохранить", Отчет.ТЧКоторуюХотетьСохранить.Выгрузить());

ОбщегоНазначения.ХранилищеОбщихНастроекСохранить("ОтчетВасиПупкина", КлючНастроек, Настройки);

КонецПроцедуры

&НаСервере
Процедура ВосстановитьНастройки()

КлючНастроек = "ОтчетВасиПупкина";
ЗначениеНастроек = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("ОтчетВасиПупкина", КлючНастроек);
Если ТипЗнч(ЗначениеНастроек) = Тип("Соответствие") Тогда
Отчет.ТЧКоторуюХотетьСохранить.Загрузить(ЗначениеНастроек.Получить("ТЧКоторуюХотетьСохранить"));
КонецЕсли;

КонецПроцедуры
   Мисти
 
5 - 05.07.18 - 19:13
нашла!
   Малыш Джон
 
6 - 05.07.18 - 19:51
можно чуть попроще:

при закрытии:

СохранитьЗначение("ТаблицаИзОтчетаВасиПупкина", НужнаяТЧ.Выгрузить());

при открытии

НужнаяТЗ.Загрузить(ВосстановитьЗначение("ТаблицаИзОтчетаВасиПупкина));


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует