Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка при открытии смены атол30ф

Ошибка при открытии смены атол30ф
Я
   Sanr231
 
05.07.18 - 11:44
Розница 2.2.2.20
Платформа 8.3.10.2667
Подключаю новый ФР Атол 30Ф, с любыми драйверами вываливается в ошибку: 
"При выполнынии операции произошла ошибка. ошибка вызова метода <ОбъектДрайвера.ОткрытьСмену>
{ОбщийМодуль.ПодключаемоеОборудованиеУниверсальныйДрайверКлиентМодуль(490)} Недостаточно фактических параметров.

Первый раз подключаю на обычной рознице, а не на базовой. Что может быть? Куда копать?
 
 
   Rulan87
 
1 - 05.07.18 - 12:24
Обновляйте розницу...
   Sanr231
 
2 - 05.07.18 - 12:53
(1) 2.2.40, та-же ерунда, создал с 0 новую базу, настроил магазин и ккм. Та-же ошибка.
   Sanr231
 
3 - 05.07.18 - 12:57
(2) 2.2.4.30 - последняя, что есть у меня. На ней та-же ошибка
   piter3
 
4 - 05.07.18 - 12:59
(3) тест связи проходит?
   Sanr231
 
5 - 05.07.18 - 13:07
(4) Проходит
   piter3
 
6 - 05.07.18 - 13:08
версия прошивки ккм?
   CepeLLlka
 
7 - 05.07.18 - 13:09
Да обновлять надо, инфа 100%

Даже не стоит голову ломать..
   Sanr231
 
8 - 05.07.18 - 13:11
Версия: 3.0.6059
   Sanr231
 
9 - 05.07.18 - 13:12
Доступа нет к релизам((((
   Kigo_Kigo
 
10 - 05.07.18 - 13:12
Да закомменть эту строку, при первом чеке касса сама откроет смену, кстати версия дров какая?
 
 Рекламное место пустует
   Sanr231
 
11 - 05.07.18 - 13:12
9.11.2.6032
   Kigo_Kigo
 
12 - 05.07.18 - 13:14
driver.Mode = 1;
driver.SetMode();
driver.NewDocument();
driver.AttrNumber = 1021;
driver.AttrValue = "Старший кассир Иванов И.И.";
driver.WriteAttribute();
driver.OpenSession();
   Sanr231
 
13 - 05.07.18 - 13:15
(12) Это что с  этим нужно делать?
   piter3
 
14 - 05.07.18 - 13:15
пробей чек если ничего не изменилось то смена откроется сама
   Sanr231
 
15 - 05.07.18 - 13:16
Из драйвера смена открывается  и закрывается. В 1с нет.
   Kigo_Kigo
 
16 - 05.07.18 - 13:16
(13) Это порядок команд для открытия смены драйвера атол
   Sanr231
 
17 - 05.07.18 - 13:27
(16)  И что с ними делать:
   Rulan87
 
18 - 05.07.18 - 13:32
Обновляйте розницу...   Новые драйвера имеют новую ревизию интерфейса.
Ваша розница даже если и заработает то будет не корректно передавать данные, или будут ошибки со скидками, НДС.

В рознице релиза 2.2.7.32:

В модуле ПодключаемоеОборудованиеУниверсальныйДрайверКлиент
В процедуре открыть смену следующий код:

Если ПараметрыПодключения.РевизияИнтерфейса > 2001 Тогда// Версия стандарта 2.2 (ОФД 1.0.5/1.1)

    Результат = ОбъектДрайвера.ОткрытьСмену(ПараметрыПодключения.ИДУстройства, ПараметрыОперации, ПараметрыСостояния, НомерСмены, НомерДокумента);
Иначе
    Результат = ОбъектДрайвера.ОткрытьСмену(ПараметрыПодключения.ИДУстройства, Кассир, НомерСмены, НомерДокумента);
КонецЕсли;

Проверьте что там есть у вас
   Sanr231
 
19 - 05.07.18 - 13:58
Если ПараметрыПодключения.Свойство("РевизияИнтерфейса") И ПараметрыПодключения.РевизияИнтерфейса > 1004 Тогда
        Попытка
            Ответ = ОбъектДрайвера.ОткрытьСмену(ПараметрыПодключения.ИДУстройства);
            Если НЕ Ответ Тогда
                Результат = Ложь;
                ВыходныеПараметры.Очистить();
                ВыходныеПараметры.Добавить(999);
                ВыходныеПараметры.Добавить("");
                ОбъектДрайвера.ПолучитьОшибку(ВыходныеПараметры[1]);
        КонецЕсли
        Исключение
            Результат = Ложь;
            ВыходныеПараметры.Очистить();
            ВыходныеПараметры.Добавить(999);
            ВыходныеПараметры.Добавить(НСтр("ru='Ошибка вызова метода <ОбъектДрайвера.ОткрытьСмену>.'") + Символы.ПС + ОписаниеОшибки());
        КонецПопытки;
    КонецЕсли;
    
    Возврат Результат;
    
КонецФункции
   Sanr231
 
20 - 05.07.18 - 13:58
Вот это там сейчас
   Sanr231
 
21 - 05.07.18 - 14:06
(18)
   Андрюха
 
22 - 05.07.18 - 14:27
(0) Очисти кеш


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует