Вход | Регистрация

1С:Предприятие ::

Метки: 

Создание обработки заполнения табличной части со своей формой

Я
   Чайник1983
 
05.07.18 - 04:46
Форумчане доброго времени суток впервые решил создать обработку заполнения ТЧ и вот если параметры обработки задавать в модуле то работает, а как сделать что бы открывалась форма обработки туда задавались параметры и ТЧ заполнялась на основании заданных параметров.
 
 
   shadow_sw
 
1 - 05.07.18 - 04:49
что мешает сделать на форме поля?
   Чайник1983
 
2 - 05.07.18 - 04:49
Конфу не написал : ЗУП 2.5
   shadow_sw
 
3 - 05.07.18 - 04:50
да причем тут писал, не писал..обычные формы - выводишь поля на форму, их передаешь как параметры
   Чайник1983
 
4 - 05.07.18 - 04:50
(1) это все сделанно но форма обработки не понимает для какого объекта идет заполнения.
   Чайник1983
 
5 - 05.07.18 - 04:51
(3) Сейчас скриншоты приложу
   shadow_sw
 
6 - 05.07.18 - 04:51
гугулить - передача параметров между формами..сто раз обсуждлось
   Чайник1983
 
7 - 05.07.18 - 04:55
Скрин: https://yadi.sk/i/nYsJE8Sa3YnPrq
Процедура заполнения уже на форме.
   mehfk
 
8 - 05.07.18 - 04:59
А что не так?
   Чайник1983
 
9 - 05.07.18 - 04:59
(8) не заполняется ТЧ
   mehfk
 
10 - 05.07.18 - 05:01
А где код?
 
 
   shadow_sw
 
11 - 05.07.18 - 05:04
(9) чего ты там заполняешь? там даже обращения нет к форме документа
   Чайник1983
 
12 - 05.07.18 - 05:05
Процедура Заполнить()
    
           НачалоПериода = День(ДатаНачала);
    КонецПериода = День(ДатаОкончания);
    Выгрузка = Запрос(Объект).Выгрузить();
    ВидВремени = ЭтотОбъект.ПолучитьФорму("Форма").ЭлементыФормы.ВидВремени.Значение;
    //Исполнители = Объект.Исполнители;

    //Выборка = Запрос().Выбрать();

    
    Если КонецПериода = 31 Тогда
        КонецПериода = КонецПериода-1;
    КонецЕсли;
     
    Для Сч = НачалоПериода - 1 по КонецПериода Цикл
        
            Для Каждого Стр из Выгрузка Цикл
        
                Стр[Сч] = Часов;
                Стр[Сч + 31] = ВидВремени;
                
                    Для Каждого Строка из Исполнители Цикл
                          ЗаполнитьЗначенияСвойств(Строка, Стр);
                    КонецЦикла;
        
        
            КонецЦикла;
    
        КонецЦикла;
        
    //Попытка

    //    Объект.Записать();

    //Исключение

    //    Сообщить(ОписаниеОшибки());

    //КонецПопытки;


КонецПроцедуры
   Чайник1983
 
13 - 05.07.18 - 05:06
(12) процедура при нажании на кнопку "Выполнить" на форме
   Chameleon1980
 
14 - 05.07.18 - 05:22
допустим делаешь для документа.
Реквизит обрабокти сделай типа ДокументОбъект.
для интереса вынеси его на форму.
подключи свою обработку к документу.
вызови ее из документа
посмотри что заполнится в вынесенный тобой реквизит.
   Chameleon1980
 
15 - 05.07.18 - 05:24
дальше додумаешься, наверное.
   Chameleon1980
 
16 - 05.07.18 - 05:26
Ну можно еще

Процедура Инициализировать (_ДокументОбъект, ИмяТабЧасти, ТабличноеПоле) Экспорт
    
    ДокументОбъект=_ДокументОбъект;
    
    ПолучитьФорму("Форма").ОткрытьМодально();
   Чайник1983
 
17 - 06.07.18 - 06:02
(16) Спасибо это помогло)


Список тем форума
Рекламное место пустует   Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует