Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Получение данных ВСД через веб интерфейс Меркурий

Получение данных ВСД через веб интерфейс Меркурий
Я
   Ц_У
 
04.07.18 - 19:56
Понадобился внутренний номер ВСД, решил получить так:    
HTTPЗапрос = Новый HTTPЗапрос("/pub/operatorui?_action=findVetDocumentFormByUuid&uuid="+ГуидВСД);
    HTTPСоединение = Новый HTTPСоединение("mercury.vetrf.ru",,,,,,Новый ЗащищенноеСоединениеOpenSSL);
    HTTPОтвет = HTTPСоединение.Получить(HTTPЗапрос);
    ЧтениеHTML = Новый ЧтениеHTML;
    ЧтениеHTML.УстановитьСтроку(HTTPОтвет.ПолучитьТелоКакСтроку());
    ПостроительDOM = Новый ПостроительDOM;
    ШаблонDOM = ПостроительDOM.Прочитать(ЧтениеHTML);
    ВсеДИВЫ = ШаблонDOM.ПолучитьЭлементыПоИмени("div");
    СтруктураДанных = Новый Структура("div0,div1,div2,div3");
    Сч = 0;
    Для Каждого ДИВ из ВсеДИВЫ Цикл 
        Если ДИВ.ИмяКласса = "profile-user-info profile-user-info-striped" Тогда
            СубДИВЫ = ДИВ.ПолучитьЭлементыПоИмени("div");
            Для Каждого СубДИВ ИЗ СубДИВЫ Цикл
                Если СубДИВ.ИмяКласса = "profile-info-value" Тогда
                    СтруктураДанных.Вставить("div"+Сч,Сокрлп(СубДИВ.ТекстовоеСодержимое)); 
                    Сч = Сч+1;
                КонецЕсли;            
            КонецЦикла;    
        КонецЕсли;
    КонецЦикла;
    Возврат Новый Структура("Статус,Номер,Дата,Вид",СтруктураДанных.div0, СтруктураДанных.div1,СтруктураДанных.div2,СтруктураДанных.div3);
 
 
   Tahallus
 
1 - 04.07.18 - 21:14
что хотел этим сказать?
   birkoFFFF
 
2 - 05.07.18 - 06:20
Жалуешься или хвастаешься?
   spectre1978
 
3 - 05.07.18 - 06:45
Кому-то может пригодиться. Номер ВСД не возвращается через API.
   birkoFFFF
 
4 - 05.07.18 - 07:42
Сейчас вообще нифига не работает через API.
Ошибками сыпет на каждом этапе.
Через Web фигачим братские могилы и отправляем так.
Зато у Власова все работает, а мы все дураки.
Да здравствует Меркурий! Даже с ЕГАИСом такого не было, хотя и там не все гладко было, но тут просто заговор веганов какой-то.
   spectre1978
 
5 - 05.07.18 - 08:26
(0) Большинство само захотело этот дивный новый мир, где все решают чиновники вроде Власова. Игнорируя какой-либо здравый смысл. Чего ж теперь плакать...
   spectre1978
 
6 - 05.07.18 - 08:29
предыдущее к (4)
   d4rkmesa
 
7 - 05.07.18 - 08:32
Власов что-то говорил про то, что пасинг web-версии - некошерно, и злоупотребляющих будут банить. )
   d4rkmesa
 
8 - 05.07.18 - 08:32
*парсинг
   spectre1978
 
9 - 05.07.18 - 08:35
(7) покуда есть дубиноголовые, которым нужен человекочитаемый номер - иного выхода нет. АПИ его не возвращает.
   spectre1978
 
10 - 05.07.18 - 08:37
вот зачем было так делать? Не хотите, не можете вы этот номер возвращать - так не делайте его от слова совсем! Есть гуид и хорошо. Нет, нужно было ввернуть эту дебильную двусмысленность и заставить людей греть голову как получать номер. В этом вся рассейская "автоматизация"... :(((
 
 Рекламное место пустует
   birkoFFFF
 
11 - 05.07.18 - 10:03
Обожаю новости россельхоза

http://www.vetrf.ru/vetrf/news/27188.html


"Система Меркурий работает штатно, включая ее web-интерфейс, замедлений в работе не зафиксировано. В интеграционном шлюзе остается ограничение для выравнивания нагрузки в виде ответов с кодом APLM0012."

Т.е. код ответа APLM0012 это норма ребята )
   Ц_У
 
12 - 05.07.18 - 11:27
(1) Хотел показать (2) нет, жест доброй воли для будущих поколений

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует