Вход | Регистрация


Получить значение из списка выбора.

Получить значение из списка выбора.
Я
   nAPACEHAK
 
04.07.18 - 16:38
Доброго

Подскажите, плз, как заменить ОткрытьМодально ()? 
Интернеты читал, но так и не поучилось разобраться (((

Как получить выбранное значение из формы выбора?

    Иначе
        
        ДополнительныеПараметры = Новый Структура("СуществующиеСсылки", СуществующиеСсылки); 
        Оповещение = Новый ОписаниеОповещения ("ВыбратьКонтрагента", ЭтаФорма, ДополнительныеПараметры);
        Результат = "";
        ВыполнитьОбработкуОповещения(Оповещение, Результат);
    КонецЕсли; 
    ////////////////

    //ЗагрузитьНаСервере();

КонецПроцедуры

&НаКлиенте 
Процедура ОткрытьФормуФрагмент(Знач Оповещение)
    

КонецПроцедуры
 

&НаКлиенте 
Процедура ВыбратьКонтрагента(Результат, ДополнительныеПараметры)  Экспорт
    
    Форма = ПолучитьФорму("Справочник.Контрагенты.ФормаВыбора");
    ЭлементОтбора = Форма.Список.Отбор.Элементы.Добавить (Тип ("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных ("Ссылка");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.ВСписке;
    ЭлементОтбора.Использование = Истина;
    ЭлементОтбора.ПравоеЗначение = ДополнительныеПараметры.СуществующиеСсылки;
    //Ссылка = Форма.ОткрытьМодально ();

    Форма.Открыть ();
    
КонецПроцедуры



Как правильно получить выбранное значение справочника без использования модальности?

Спасибо
 
 
   Tonik992
 
1 - 04.07.18 - 16:43
Ого :-) Вы с какой конфигурации прибыли?
   Alexandr_U1982
 
2 - 04.07.18 - 16:44
Может быть поможет: http://its.1c.ru/docs/v8nonmodal/#3
   Малыш Джон
 
3 - 04.07.18 - 16:44
>>Интернеты читал, но так и не поучилось разобраться (((

поэтому полез в интернет?

читай руководство разработчика, там все доступно
   Aleksandr N
 
4 - 04.07.18 - 16:48
(0) ОткрытьФорму(<ИмяФормы>, <Параметры>, <Владелец>, <Уникальность>, <Окно>, <НавигационнаяСсылка>, <ОписаниеОповещенияОЗакрытии>, <РежимОткрытияОкна>) 


<ОписаниеОповещенияОЗакрытии> (необязательный)

Тип: ОписаниеОповещения.
Содержит описание процедуры, которая будет вызвана при закрытии формы со следующими параметрами:
<РезультатЗакрытия> - значение, переданное при вызове метода Закрыть открываемой формы,
<ДополнительныеПараметры> - значение, которое было указано при создании объекта ОписаниеОповещения.
Если параметр не указан, то по завершению никакая процедура вызвана не будет.
Используется только в управляемом приложении.
   nAPACEHAK
 
5 - 04.07.18 - 17:01
(4) Спасибо, получилось
(2) Спасибо
(1) )))) Рарус. Альфа. там всё на обычных

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует