Вход | Регистрация

1С:Предприятие ::

Метки: 

Как программно определить Проведение документа

Я
   IgraStoitSvech
 
04.07.18 - 10:53
Доброе время суток!
Задача такая, нужно при нажатии кнопки проверялось проведен документ или нет, выбор документа происходит на поле ввода. Так как я только начал изучать 1с, то получился вот такой код, понимаю что он не верен, подскажите пожалуйста где. Не прошу делать за меня, прошу подсказать что нужно исправить.


&НаСервере
Процедура Ответ(Поступление)
Отбор = Новый Структура ("Ссылка",Поступление);

НайдДок = Объект.Поступление.ПолучитьОбъект();

Если  НайдДок.Проведен Тогда
    Сообщить ("Документ проведён!");
Иначе 
    Сообщить ("Документ НЕ проведён!");
    КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура Ответить(Команда)
    
Поступление = Объект.Поступление;

КонецПроцедуры
 
 
   alexshape
 
1 - 04.07.18 - 10:56
(0) что за кнопка "проверялось"?
   Mankubus
 
2 - 04.07.18 - 10:56
(0)
1. Зачем эта строка "Отбор = Новый Структура ("Ссылка",Поступление);"?
2. Получать объект не нужно "НайдДок = Объект.Поступление.ПолучитьОбъект();"
3. Если  НайдДок.Проведен Тогда -- это сделай запросом
   1Сергей
 
3 - 04.07.18 - 11:01
(2) 3. Зачем?
   catena
 
4 - 04.07.18 - 11:02
(2)Зачем запросом?
   catena
 
5 - 04.07.18 - 11:03
(0)А где вызов-то этой волшебной процедуры?
   иубиповец
 
6 - 04.07.18 - 11:03
НайдДок = Объект.Поступление.ПолучитьОбъект(); 
Если вы получаете объект вы получаете все его свойства, в тч и избыточные.
2. В функцию вы передаете поступление, а обращаетесь объект.поступление. Зачем тогда че то передавать в функцию?:)
3.Также я бы проверял что бы в поступлении была ссылка на док, а не какое нить неопределено.
4. лучше получать запросом.
   lodger
 
7 - 04.07.18 - 11:04
между строками кода нет логической связи.
   1Сергей
 
8 - 04.07.18 - 11:14
(7) Вывод: ТС бот


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует