Вход | Регистрация

1С:Предприятие ::

Метки: 

Как обычно реализуют оповещение с сервера на клиента о состоянии операции?

Я
   Бешеный заяц
 
04.07.18 - 10:44
Например, простой, код клиент вызывает процедуру сервера, та выполняет длительную операцию, клиенту необходимо для отображения отправлять текущий статус, как обычно это реализуют?
вот например в этом коде для примера
&НаКлиенте
Процедура Пометить(Команда)
    ПометитьНаУдаление();
КонецПроцедуры
&НаСервере
Процедура ПометитьНаУдаление();
    СпрКонтр = Справочники.Контрагенты.Выбрать();
    Пока СпрКонтр.Следующий() Цикл
        СпрОб =    СпрКонтр.ПолучитьОбъект();
        //СпрОб.ПометкаУдаления = ИСТИНА;

        СпрОб.Записать();    
    КонецЦикла;
КонецПроцедуры
 
 
   alexshape
 
1 - 04.07.18 - 10:49
у фоновых заданий есть метод "ПолучитьСообщенияПользователю", капай в эту сторону
   DrShad
 
2 - 04.07.18 - 10:49
если делать кошерно, то оборачивают в фоновое задание и через менеджер фоновых заданий опрашивают его о ходе выполнения
   lodger
 
3 - 04.07.18 - 10:50
через подсистему ДлительныеОперации, посмотри одноименный модуль в конфе, ну или в БСП.
   alexshape
 
4 - 04.07.18 - 10:50
(0) если без фоновых заданий, то никак не получишь состояние выполнения на клиенте пока выполняется цикл
   Бешеный заяц
 
5 - 04.07.18 - 10:51
ок спасибо
   mmmarat
 
6 - 04.07.18 - 10:52
(3) +1. СообщитьПрогресс.. ПрочитатьПрогресс(..
   Малыш Джон
 
7 - 04.07.18 - 11:07
(0) будь мужиком - освой систему взаимодействия!

https://wonderland.v8.1c.ru/blog/peredacha-informatsii-s-servera/


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует