Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Ошибка при добавлении в журнал расчета результата.

v7: Ошибка при добавлении в журнал расчета результата.
Я
   roalang
 
04.07.18 - 06:04
Доброе утро.
Не могу понять в чем ошибка, в журнале расчетов по этому вида платежа, ставиться нормально "Тариф" и "КолПроп", а в графу результат нет.

Процедура глРассчитатьЛицСчетТКО(ЛицСчет) Экспорт
    Перем Сальдо, ВидСчетчика;
    ЖрнКв = СоздатьОбъект("ЖурналРасчетов.КвартплатаТКО");
    ЖрнКв.ВыбратьЗаписиПоОбъекту(ЛицСчет.ТекущийЭлемент(),глНачПериода,глКонПериода);
    Сальдо = глРассчитатьСальдоТКО(ЛицСчет);           
    
    Пока ЖрнКв.ПолучитьЗапись()=1 Цикл
        Если ЖрнКв.Документ.Вид() = "РасчетКвартплатыТКО" Тогда  
ЖрнКв.ВидРасч.ВходитВГруппу(ГруппаРасчетов.Начисления) = 1 Тогда    
            
Если ЖрнКв.ВидРасч = ВидРасчета.ПоКоличеству Тогда       
        //сообщить("По Количеству");

Тариф = ЖрнКв.ВидТарифа.Тариф.Получить(глНачПериода);
КолПроп = ЛицСчет.КолПроп.Получить(глНачПериода); 
                
сообщить("Тариф " + Тариф + " КолПроп " + КолПроп);    
Результат = КолПроп*Тариф;    
сообщить(Результат);
                    
                    ЖрнКв.УстановитьРеквизит("Тариф",Тариф);
                    ЖрнКв.УстановитьРеквизит("Количество",КолПроп);
                    ЖрнКв.УстановитьРеквизит("Результат",Результат);
                    ЖрнКв.УстановитьРеквизит("Рассчитана",1);
                    ЖрнКв.Записать(); 
                КонецЕсли;    
            КонецЕсли;    
            Если ЖрнКв.ВидРасч.ВходитВГруппу(ГруппаРасчетов.Сальдо) = 1 Тогда
                Стр="";Кол="";
                Сальдо.НайтиЗначение(ЖрнКв.ВидТарифа,Стр,Кол);
                Если Стр = 0 Тогда 
                    ЖрнКв.УстановитьРеквизит("Результат",0);
                    ЖрнКв.УстановитьРеквизит("Рассчитана",1);
                    ЖрнКв.Записать(); 
                Иначе    
                    Сальдо.ПолучитьСтрокуПоНомеру(Стр);
                    ЖрнКв.УстановитьРеквизит("Результат",Сальдо.СальдоК);
                    ЖрнКв.УстановитьРеквизит("Рассчитана",1);
                    ЖрнКв.Записать(); 
                Конецесли;
            КонецЕсли;    
        КонецЕсли;    
    КонецЦикла;    

 КонецПроцедуры
 
 
   AliAksA
 
1 - 04.07.18 - 12:41
(0) по ходу это глобальная процедура, проверь модуль документа и модуль расчета - по-ходу Результат там переопределяется
   Масянька
 
2 - 04.07.18 - 12:43
(0) сообщить(Результат); - пусто?
   roalang
 
3 - 05.07.18 - 04:14
Нет, считает правильно.
   AliAksA
 
4 - 05.07.18 - 08:10
(3) модули проверил? там нет переопрепределения Результата после вызова этой функции?
   AliAksA
 
5 - 05.07.18 - 08:11
+(4) *процедуры
   AliAksA
 
6 - 05.07.18 - 08:24
(3) короче, в этой процедуре - все норм;
если не найдешь косяк - тогда модули проведения документа и вида расчета "ПоКоличеству " в студию;
если не справишься с этим - пригласи программиста

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует