Вход | Регистрация

Информационные технологии ::

Метки: 

Замена USB-провода сканера ШК Orbit 7120 на провод с COM-портом

Я
   san4ez1008
 
03.07.18 - 11:18
Я не знаю, куда данную тему определить, так что оставлю тут.. собственно, в чем проблема. Есть несколько машин, чипсеты все разные (H41, H61, так же имеется мать GA-8VM800M-775). Блоки питания все тоже разные. На последней матери отключена вся периферия,ничего лишнего (т.е. ни видеокарты,ни COM-портов, ни доп.сетевых планок, ни DVD-приводов). Подключил сканер ШК по USB-порту, после отключения света сканер пока не вытащишь и не вставишь не определяется системой, ни на Win 7, ни на Win XP. Блок питания либо 500,либо 600 Вт, т.е. питания достаточно. На H110 матери все пошло ровно, но нет возможности протестировать на Win XP. Собственно, вопрос, что-то сделано неправильно? Так же было решено попробовать заменить провод на COM-овский, но даже после сброса на дефолтные настройки сканер не реагирует ни на один ШК кроме служебных (для программирования сканера). Удалял драйвер Honeywell-тоже бесполезно. Сканер изначально был запрограммирован на эмуляцию COM-порта при подключении к компьютеру. При включении в тестировании драйвера сканера ШК определяется COM-порт и сообщение #0, более ничего не происходит. Ну и еще вопрос, в чем может быть причина того, что USB-сканер отваливается после включения компа?
 
 
   Kigo_Kigo
 
1 - 03.07.18 - 11:31
Сканер- скорее всего находиться в режиме программирования, считайте код программирование, и скорее всего он сейчас работает в режиме клавиатуры, откройте текстовый док и считаете что нить сканером, для перевода в режим эмуляции компорта, да считать системные ШК, которые его переведут в режим эмуляции, а вот с отвалом, тут скорее не сканер виноват, а мать не дает нужной напруги по УСБИ
   san4ez1008
 
2 - 04.07.18 - 03:49
(1) сбросил настройки на дефолтные,считал через USB-провод ШК в блокнот-все норм. поменял провод,перепрограммировал сканер в режим эмуляции COM-порта - на ШК не реагирует. Обратил внимание на количество и цвет проводов в коннекторе (или как это называется),в USB естественно всего 4,в COM-10,расположение одинаковых проводов различается. Может, в этом и проблема, что сканер не реагирует на стандартный ШК? (EAN-13)
   big
 
3 - 04.07.18 - 07:16
(1) напряжение тут не при чем, потребление сканера, даже такого как Орбит, весьма небольшое

(0)(2) надо пробовать менять режимы работы usb-портов. В современных матерях есть "умные" режимы работы портов. Некоторое оборудование с такими режимами не работает. Сталкивались с USB-модемами - пока режим работы не переключили в стандартный.

На ШК должен реагировать независимо от настроек интерфейса, а тем более от расположения и цвета проводов ;-)
   san4ez1008
 
4 - 04.07.18 - 07:28
(3) ну на материнке GA-8VM800M-775 точно нет "умного" режима работы портов,тем более, что БП 600 Вт,поэтому скорее всего проблема кроется именно в материнке,ибо на 110 чипсете все пошло нормально с этим же БП. Кстати, на 61 и 81 чипсете на Win XP USB-сканер прекрасно работает. А по поводу ШК я даже и не знаю,что сказать. Сканер явно был не в режиме программирования находился, т.к. после перевода сканера в режим эмуляции он потух,определился как COM-порт,поменял провод-завелся,но почему не воспринимал ШК EAN-13 понять не могу, пока обратно провод не поменял-вообще никак не реагировал.
   san4ez1008
 
5 - 04.07.18 - 10:48
ап


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует