Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

В списке выбора должно показываться 3 элемента, а показывается только 2

В списке выбора должно показываться 3 элемента, а показывается только 2
Я
   Косяк
 
03.07.18 - 11:14
Конфигурация 1С:ERP Управление предприятием 2 (2.4.5.33) типовая
Платформа: (8.3.11.2954)

Есть перечисление: ТипыСделокСКлиентами, там 3 элемента:ПрочиеНепроцессныеСделки, СделкиСРучнымПереходомПоЭтапам, ТиповаяПродажа.


#Область ОбработчикиСобытийФормы


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

    Если Параметры.Свойство("АвтоТест") Тогда// Возврат при получении формы для анализа.

        Возврат;
    КонецЕсли;

    ОбновлениеИнформационнойБазы.ПроверитьОбъектОбработан(Объект, ЭтотОбъект);

    УправлениеДоступностью();
    
    // Обработчик подсистемы запрета редактирования реквизитов объектов

    ЗапретРедактированияРеквизитовОбъектов.ЗаблокироватьРеквизиты(ЭтаФорма);
    
    Для Каждого ЗначениеПеречисления Из Перечисления.ТипыСделокСКлиентами.ПрочиеНепроцессныеСделки.Метаданные().ЗначенияПеречисления Цикл
        
        ТипСделки = Перечисления.ТипыСделокСКлиентами[ЗначениеПеречисления.Имя];
        
        Если НЕ  Перечисления.ТипыСделокСКлиентами.ТипСделкиДоступенПоФункциональнымОпциям(ТипСделки) Тогда
            Продолжить;
        КонецЕсли;
        
        Элементы.ТипСделки.СписокВыбора.Добавить(ТипСделки)
        
    КонецЦикла;
    
    СобытияФорм.ПриСозданииНаСервере(ЭтаФорма, Отказ, СтандартнаяОбработка);
    
КонецПроцедуры


В списке выбора должны показываться 3 элемента, а показываются только 2, т.е. элемент ТиповаяПродажа - не показывается. Почему?
 
 
   Косяк
 
1 - 03.07.18 - 11:27
Делаю так, - все равно 2 элемента вместо 3-х

    Для Каждого ЗначениеПеречисления Из Метаданные.Перечисления.ТипыСделокСКлиентами.ЗначенияПеречисления Цикл
        
        ТипСделки = Перечисления.ТипыСделокСКлиентами[ЗначениеПеречисления.Имя];
        
        Если НЕ  Перечисления.ТипыСделокСКлиентами.ТипСделкиДоступенПоФункциональнымОпциям(ТипСделки) Тогда
            Продолжить;
        КонецЕсли;
        
        Элементы.ТипСделки.СписокВыбора.Добавить(ТипСделки)
        
    КонецЦикла;
   Косяк
 
2 - 03.07.18 - 11:30
Всё, разобрался, это из за этого кода

   Если НЕ  Перечисления.ТипыСделокСКлиентами.ТипСделкиДоступенПоФункциональнымОпциям(ТипСделки) Тогда
            Продолжить;
        КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует