Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Необходимо свернуть Таблицу Значений

Необходимо свернуть Таблицу Значений
Я
   ХорошийОтвет
 
02.07.18 - 21:54
Имеется следующая таблица
Контрагент  Контактное лицо
ИП 1        Смирнов
ИП 1        Григорьев
ИП 1        Иванов
ИП 2        Андропов
ИП 2        Бегунов


Вот что необходимо получить на выходе
Контрагент  Контактное лицо
ИП 1        Смирнов
ИП 2        Андропов

Как её свернуть по контрагенту?
 
 
   runoff_runoff
 
1 - 02.07.18 - 22:21
без цикла не обойтись
   runoff_runoff
 
2 - 02.07.18 - 22:21
если 7.7
   МихаилМ
 
3 - 02.07.18 - 22:21
необходимая табла =  следующая таблица.СкопироватьКолонки();  
текКонтент = неопределено
для каждого стр из следующая таблица цикл
если стр.Контрагент  <> текКонтент тогда
  ЗаполнитьЗначенияСвойств(необходимая табла.Добавить,Стр); 

  текКонтент = стр.Контрагент
конецесли;
конеццикла;
   ssh2006
 
4 - 02.07.18 - 22:24
Т2 = Т1.Свернуть("Контрагент");
Для Каждого ТекСтрока Из Т2 Цикл

    НайденныеСтроки = Т1.НайтиСтроки(Новый Структура("Контрагент", ТекСтрока.Контрагент));
    Для Индекс = 1 По НайденныеСтроки.ВГраница() Цикл
        Т1.УдалитьСтроку(НайденныеСтроки[Индекс]);
    КонецЦикла 

КонецЦикла;
   ssh2006
 
5 - 02.07.18 - 22:26
**
Т2 = Т1.Скопировать(,"Контрагент");
Т2.Свернуть("Контрагент");
   Сияющий в темноте
 
6 - 02.07.18 - 22:42
Хороша свертка,взяли первый,а остальные пушистому домашнему животному под хвост?
   ShAV
 
7 - 03.07.18 - 00:07
(6) о том же мысль промелькнула
   PR
 
8 - 03.07.18 - 00:10
(0) Не свернуть, а обрезать
   ХорошийОтвет
 
9 - 03.07.18 - 00:32
(4) Спасибо, помогло.
   Chameleon1980
 
10 - 03.07.18 - 02:54
а запросом не пойдет чель?
 
 Рекламное место пустует
   Chameleon1980
 
11 - 03.07.18 - 02:54
ИМХО эелегантнее
   Chameleon1980
 
12 - 03.07.18 - 02:56
хотя тоже обход. ну и  4 пойдет
   mistеr
 
13 - 03.07.18 - 08:37
(11) Что элегантного в напряжении сети и скуля почем зря?
   Мандалай
 
14 - 03.07.18 - 08:50
Напрягать скуль кошернее клиента
   mistеr
 
15 - 03.07.18 - 09:05
(14) Это надо было делать, пока данные были там. А теперь цже поздно.
   Малыш Джон
 
16 - 03.07.18 - 09:07
(15) кстати, да, это самый элегантный способ - получать таблицу сразу в нужном виде)
   novichok79
 
17 - 03.07.18 - 09:12
(0) если запросом, то выбрать из таблицы контактных лиц контрагентов минимум ссылки и сгруппировать это дело по владельцу, но не гарантируется очередность, т. к. будет взято самое древнее КЛ, вне зависимости от ФИО. если ТЗ, то (3)
   СвинТуз
 
18 - 03.07.18 - 09:19
мКоличество=тз.Количество()+1;
Контра=Неопределено; Пред=Неопределено;
Для ии=0 По мКоличество Цикл

    Инд=мКоличество-ии;
    Если тз[Инд].Контрагент<>Контра Тогда
        Контра=тз[Инд].Контрагент;
        Пред=инд;
    Иначе
        Если Пред<>Неопределено Тогда
            тз.Удалить(Пред);
        КонецЕсли;
    КонецЕсли;
КонецЦикла;
   Eiffil123
 
19 - 03.07.18 - 09:56
(14) уже 2018 год. Весь код работы с таблицами значений на сервере давно крутится.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует