Вход | Регистрация

1С:Предприятие ::

Метки: 

Выбор каталога в web-клиенте

Я
   Buckbister
 
02.07.18 - 00:33
Всем день!

Задача тривиальная, примеры не могу найти. Всего-то надо - выбрать каталог, куда потом сохранить файл.

Нарыл функцию
НачатьПолучениеКаталогаДокументов, но она почему-то не работает и окно выбора файла не открывает:

&НаКлиенте
Процедура ИмяФайлаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    СтандартнаяОбработка    = Ложь;
    Описание    = Новый ОписаниеОповещения("ЗакончитьПолучениеКаталогаДокументов", ЭтотОбъект);
    НачатьПолучениеКаталогаДокументов(Описание);

КонецПроцедуры

&НаКлиенте
Процедура ЗакончитьПолучениеКаталогаДокументов(Результат, Параметры) Экспорт 
    
    Если Результат <> "" Тогда 
        Объект.КаталогВыгрузки = Результат;
        //Объект.АдресХранения    = Адрес;

        //Объект.ТаблицаВыписки.Очистить();

        //Объект.ЗагруженныеОперации.Очистить();

    КонецЕсли;
    
КонецПроцедуры

Вместо открытия диалогового окна просто возвращает значение каталога пользователя.

Поможите, други! В какую сторону рыть? Киньте примером плз.
 
  Рекламное место пустует
   runoff_runoff
 
1 - 02.07.18 - 00:46
ДиалогВыбораФайла
   PR
 
2 - 02.07.18 - 00:48
(0) Не можешь найти примеров в БСП?
   Buckbister
 
3 - 02.07.18 - 01:21
(1) Для диалога выбора файлов надо устанавливать на клиенте специальную компоненту. Хочется этого избежать.

(2) - нет :(

пс:
Насчет кода что привел в сообщении - понял что сам дурак. У этой команды другая логика. Однако задача остается открытой - ответ пока не нарыл :(
   Buckbister
 
4 - 08.07.18 - 22:58
Поднимаю.
Есть ли простое решение у такого простого вопроса?
   mistеr
 
5 - 09.07.18 - 08:33
(3) Без компоненты браузер этого делать не позволит. Это нарушение модели безопасности современных браузеров.
   butterbean
 
6 - 09.07.18 - 08:45
(5) это криворукие программисты платформы 1С
   butterbean
 
7 - 09.07.18 - 08:49
(0) кури НачатьПомещениеФайла()
   butterbean
 
8 - 09.07.18 - 08:49
(7)+ или НачатьКопированиеФайла(), смотря что нужно в итоге
   butterbean
 
9 - 09.07.18 - 08:59
(7)* это для получения файла с лок. диска, а для сохранения на диск ПолучитьФайл(...)
   mistеr
 
10 - 09.07.18 - 09:07
(9) Получить/сохранить файл и получить имя каталога — разницу понимаешь? Так вот получать структуру файловой системы клиента — низзя.
 
 
   butterbean
 
11 - 09.07.18 - 09:20
(10) какую структуру? нужно всего лишь дать пользователю выбор пути для сохранения файла и положить его туда
   mistеr
 
12 - 09.07.18 - 09:53
(11) ТС ставит вопрос по-другому: получить путь заранее, а сохранить потом.


Список тем форума
Рекламное место пустует  
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует