Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Вывести значение реквизита на печатную форму

Вывести значение реквизита на печатную форму
Я
   oqjawa
 
28.06.18 - 07:52
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ПриемНаРаботу.Ссылка КАК Ссылка,
        |    ПриемНаРаботу.ВерсияДанных КАК ВерсияДанных,
        |    ПриемНаРаботу.ПометкаУдаления КАК ПометкаУдаления,
        |    ПриемНаРаботу.Номер КАК Номер,
        |    ПриемНаРаботу.Дата КАК Дата,
        |    ПриемНаРаботу.Проведен КАК Проведен,
        |    ПриемНаРаботу.Организация КАК Организация,
        |    ПриемНаРаботу.Подразделение КАК Подразделение,
        |    ПриемНаРаботу.Сотрудник КАК Сотрудник,
        |    ПриемНаРаботу.ФизическоеЛицо КАК ФизическоеЛицо,
        |    ПриемНаРаботу.Должность КАК Должность,
        |    ПриемНаРаботу.ДолжностьПоШтатномуРасписанию КАК ДолжностьПоШтатномуРасписанию,
        |    ПриемНаРаботу.ДатаПриема КАК ДатаПриема,
        |    ПриемНаРаботу.КоличествоСтавок КАК КоличествоСтавок,
        |    ПриемНаРаботу.ВидЗанятости КАК ВидЗанятости,
        |    ПриемНаРаботу.ДлительностьИспытательногоСрока КАК ДлительностьИспытательногоСрока,
        |    ПриемНаРаботу.ГрафикРаботы КАК ГрафикРаботы,
        |    ПриемНаРаботу.СпособРасчетаАванса КАК СпособРасчетаАванса,
        |    ПриемНаРаботу.Аванс КАК Аванс,
        |    ПриемНаРаботу.УсловияПриема КАК УсловияПриема,
        |    ПриемНаРаботу.Руководитель КАК Руководитель,
        |    ПриемНаРаботу.ДолжностьРуководителя КАК ДолжностьРуководителя,
        |    ПриемНаРаботу.НачисленияУтверждены КАК НачисленияУтверждены,
        |    ПриемНаРаботу.УправленческиеНачисленияУтверждены КАК УправленческиеНачисленияУтверждены,
        |    ПриемНаРаботу.СпособОтраженияЗарплатыВБухучете КАК СпособОтраженияЗарплатыВБухучете,
        |    ПриемНаРаботу.ОтношениеКЕНВД КАК ОтношениеКЕНВД,
        |    ПриемНаРаботу.СтатьяФинансирования КАК СтатьяФинансирования,
        |    ПриемНаРаботу.ИсправленныйДокумент КАК ИсправленныйДокумент,
        |    ПриемНаРаботу.ПорядокРасчетаСтоимостиЕдиницыВремени КАК ПорядокРасчетаСтоимостиЕдиницыВремени,
        |    ПриемНаРаботу.СовокупнаяТарифнаяСтавка КАК СовокупнаяТарифнаяСтавка,
        |    ПриемНаРаботу.ВидТарифнойСтавки КАК ВидТарифнойСтавки,
        |    ПриемНаРаботу.РазрядКатегория КАК РазрядКатегория,
        |    ПриемНаРаботу.ВидДоговора КАК ВидДоговора,
        |    ПриемНаРаботу.ТрудовойДоговорНомер КАК ТрудовойДоговорНомер,
        |    ПриемНаРаботу.ТрудовойДоговорДата КАК ТрудовойДоговорДата,
        |    ПриемНаРаботу.СрочныйДоговор КАК СрочныйДоговор,
        |    ПриемНаРаботу.СезонныйДоговор КАК СезонныйДоговор,
        |    ПриемНаРаботу.ДатаЗавершенияТрудовогоДоговора КАК ДатаЗавершенияТрудовогоДоговора,
        |    ПриемНаРаботу.ОснованиеСрочногоДоговора КАК ОснованиеСрочногоДоговора,
        |    ПриемНаРаботу.СрокЗаключенияДоговора КАК СрокЗаключенияДоговора,
        |    ПриемНаРаботу.ОснованиеПредставителяНанимателя КАК ОснованиеПредставителяНанимателя,
        |    ПриемНаРаботу.СпособПоступленияНаСлужбу КАК СпособПоступленияНаСлужбу,
        |    ПриемНаРаботу.ПоступлениеНаСлужбуВпервые КАК ПоступлениеНаСлужбуВпервые,
        |    ПриемНаРаботу.ВидАктаГосоргана КАК ВидАктаГосоргана,
        |    ПриемНаРаботу.ОборудованиеРабочегоМеста КАК ОборудованиеРабочегоМеста,
        |    ПриемНаРаботу.ИныеУсловияДоговора КАК ИныеУсловияДоговора,
        |    ПриемНаРаботу.Грейд КАК Грейд,
        |    ПриемНаРаботу.Территория КАК Территория,
        |    ПриемНаРаботу.БронированиеПозиции КАК БронированиеПозиции,
        |    ПриемНаРаботу.РазрешениеНаРаботу КАК РазрешениеНаРаботу,
        |    ПриемНаРаботу.РазрешениеНаПроживание КАК РазрешениеНаПроживание,
        |    ПриемНаРаботу.УсловияОказанияМедпомощи КАК УсловияОказанияМедпомощи,
        |    ПриемНаРаботу.ДатаПрисвоения КАК ДатаПрисвоения,
        |    ПриемНаРаботу.КлассныйЧинРанг КАК КлассныйЧинРанг,
        |    ПриемНаРаботу.ПКУ КАК ПКУ,
        |    ПриемНаРаботу.Решение КАК Решение,
        |    ПриемНаРаботу.Ответственный КАК Ответственный,
        |    ПриемНаРаботу.Комментарий КАК Комментарий,
        |    ПриемНаРаботу.ИТ_Визы КАК ИТ_Визы,
        |    ПриемНаРаботу.ИТ_Основание КАК ИТ_Основание,
        |    ПриемНаРаботу.ИТ_ПериодИспытательногоСрока КАК ИТ_ПериодИспытательногоСрока,
        |    ПриемНаРаботу.ИТ_УсловияПриема КАК ИТ_УсловияПриема,
        |    ПриемНаРаботу.ИТ_ВСоответсвииСОбязанностями КАК ИТ_ВСоответсвииСОбязанностями,
        |    ПриемНаРаботу.ИТ_Основание_Трудового_Договора КАК ИТ_Основание_Трудового_Договора,
        |ИЗ
        |    Документ.ПриемНаРаботу КАК ПриемНаРаботу";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        
        ПараметрыТрудовогоДоговора.Физлицо =ВыборкаДетальныеЗаписи.Сотрудник; 
    КонецЦикла;
 
 
   oqjawa
 
1 - 28.06.18 - 07:53
Выводит не того кто в документе указан...
   oqjawa
 
2 - 28.06.18 - 07:54
подскажите пожалуйста , что не так?
я вообще хотел паспортные данные его вывести, указывал как ссылку на сотрудника,но он так же выводит не те данные а первые попавшиеся
   НаборДанных
 
3 - 28.06.18 - 07:57
Тебя не смущает, что ты не задаешь параметры запроса, не обрабатываешь по условиям после запроса, вот это вот всё? Что ты ждешь от запроса этого?
   Не кассир
 
4 - 28.06.18 - 07:58
(1) В каком документе?
   Не кассир
 
5 - 28.06.18 - 07:58
(3) Таких людей, ничего не смущает)
   oqjawa
 
6 - 28.06.18 - 08:03
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ПриемНаРаботу.Сотрудник КАК Сотрудник,
        |ИЗ
        |    Документ.ПриемНаРаботу КАК ПриемНаРаботу";

    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        
        Макет.Параметры.Физлицо =ВыборкаДетальныеЗаписи.Сотрудник;
        СотрудникСсылка =ВыборкаДетальныеЗаписи.Сотрудник; 
    КонецЦикла;
    
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ДокументыФизическихЛиц.Период КАК Период,
        |    ДокументыФизическихЛиц.Физлицо КАК Физлицо,
        |    ДокументыФизическихЛиц.ВидДокумента КАК ВидДокумента,
        |    ДокументыФизическихЛиц.Серия КАК Серия,
        |    ДокументыФизическихЛиц.Номер КАК Номер,
        |    ДокументыФизическихЛиц.ДатаВыдачи КАК ДатаВыдачи,
        |    ДокументыФизическихЛиц.СрокДействия КАК СрокДействия,
        |    ДокументыФизическихЛиц.КемВыдан КАК КемВыдан,
        |    ДокументыФизическихЛиц.КодПодразделения КАК КодПодразделения,
        |    ДокументыФизическихЛиц.ЯвляетсяДокументомУдостоверяющимЛичность КАК ЯвляетсяДокументомУдостоверяющимЛичность,
        |    ДокументыФизическихЛиц.Представление КАК Представление,
        |    ДокументыФизическихЛиц.УдалитьВидДокумента КАК УдалитьВидДокумента
        |ИЗ
        |    РегистрСведений.ДокументыФизическихЛиц КАК ДокументыФизическихЛиц";
        |ГДЕ
        |   Физлицо = &СотрудникСсылка";
  
 
    Запрос.УстановитьПараметр("СотрудникСсылка",СотрудникСсылка);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        Макет.Параметры.Серия = ВыборкаДетальныеЗаписи.Серия;
        Макет.Параметры.Номер = ВыборкаДетальныеЗаписи.Номер;
        Макет.Параметры.КемВыдан = ВыборкаДетальныеЗаписи.КемВыдан;
    КонецЦикла;
   oqjawa
 
7 - 28.06.18 - 08:03
я думал так должно работать?
   oqjawa
 
8 - 28.06.18 - 08:04
но в первом запросе уже не того сотрудника выводит в параметр, не понимаю почему
   НаборДанных
 
9 - 28.06.18 - 08:10
А какого сотрудника ты ждешь?
   ПегийЛунь
 
10 - 28.06.18 - 08:11
(9) Не мучай персонаж. Напиши уже ему, что и в первом запросе должен быть параметр.
 
 Рекламное место пустует
   oqjawa
 
11 - 28.06.18 - 08:12
который в документе Приём на работу указан в реквизите Сотрудник
   НаборДанных
 
12 - 28.06.18 - 08:12
В каком именно документе? Программа у нас пока без ИИ поставляется.
   Dvoe4nik
 
13 - 28.06.18 - 08:17
(11) допиши перед выполнением запроса: Запрос.Установить параметр("документССылка",СсылкадокументаПрием);
а в запросе допиши :
"ГДЕ ПриемНаРаботу.Ссылка =&документССылка"
   oqjawa
 
14 - 28.06.18 - 08:24
а переменная  - СсылкадокументаПрием  будет равняться чему??
   Dvoe4nik
 
15 - 28.06.18 - 08:29
(14) ну ежели ПФ у тебя в Объекте тогда Объект.ссылка. А так вообще ссылка Документа ПРиемНаРаботу, откуда тебе сотрудник нужен
   ПегийЛунь
 
16 - 28.06.18 - 08:29
(14) Вашему документу.
Например
Запрос.УстановитьПараметр("документССылка",Ссылка);
или
Запрос.УстановитьПараметр("документССылка",ЭтотОбъект.Ссылка);
или
Запрос.УстановитьПараметр("документССылка",Объект.Ссылка);

Нам отсюда не видно в какой конфигурации вы работаете.
   Не кассир
 
17 - 28.06.18 - 08:31
(14) Ну, ссылке на документ например)
   Dvoe4nik
 
18 - 28.06.18 - 08:51
(14) если У Тебя ВПФ то передавай в нее ссылку на документ
Да и вообще так то сперва запрос лучше в консоли запросов проверять тогда и с параметрами все просто будет
   oqjawa
 
19 - 28.06.18 - 14:32
у меня внешняя печатная форма, не получается, не могу понять как она работать должна, как эту ссылку передать..
помогите пожалуйста, может есть какой-то конкретный пример

если так.. 
|ГДЕ ПриемНаРаботу.Ссылка = &Ссылка";
    
      Запрос.УстановитьПараметр("Ссылка",    ссылка);

то - Переменная не определена (ссылка)
      Запрос.УстановитьПараметр("Ссылка"....


если так..
|ГДЕ ПриемНаРаботу.Ссылка = &Ссылка";
    
      Запрос.УстановитьПараметр("Ссылка",    Объект.Ссылка);

то - Переменная не определена (Объект)
      Запрос.УстановитьПараметр("Ссылка"

если так..

|ГДЕ ПриемНаРаботу.Ссылка = &Ссылка";
    
      Запрос.УстановитьПараметр("Ссылка",    ЭтотОбъект.Ссылка);

то - Синтаксических ошибок не обнаружено!

НО, при печати выдаёт ошибку : Поле объекта не обнаружено (Ссылка)
   Mankubus
 
20 - 28.06.18 - 15:25
20 постов и до сих пор не ясно УФ или ОФ
   oqjawa
 
21 - 28.06.18 - 15:29
уф
   oqjawa
 
22 - 28.06.18 - 15:37
удалось, вытащить Сотрудника из первого запроса и присвоить значение из выборки в "СотрудникСсылка".. а как это значение подвязать к другому запросу? вот так ничего не происходит
 Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    ДокументыФизическихЛиц.Период КАК Период,
        |    ДокументыФизическихЛиц.Физлицо КАК Физлицо,
        |    ДокументыФизическихЛиц.ВидДокумента КАК ВидДокумента,
        |    ДокументыФизическихЛиц.Серия КАК Серия,
        |    ДокументыФизическихЛиц.Номер КАК Номер,
        |    ДокументыФизическихЛиц.ДатаВыдачи КАК ДатаВыдачи,
        |    ДокументыФизическихЛиц.СрокДействия КАК СрокДействия,
        |    ДокументыФизическихЛиц.КемВыдан КАК КемВыдан,
        |    ДокументыФизическихЛиц.КодПодразделения КАК КодПодразделения,
        |    ДокументыФизическихЛиц.ЯвляетсяДокументомУдостоверяющимЛичность КАК ЯвляетсяДокументомУдостоверяющимЛичность,
        |    ДокументыФизическихЛиц.Представление КАК Представление,
        |    ДокументыФизическихЛиц.УдалитьВидДокумента КАК УдалитьВидДокумента
        |ИЗ
        |    РегистрСведений.ДокументыФизическихЛиц КАК ДокументыФизическихЛиц";
        |ГДЕ
        |   Физлицо = &СотрудникСсылка";
  
 
    Запрос.УстановитьПараметр("СотрудникСсылка",СотрудникСсылка);
   hhhh
 
23 - 28.06.18 - 15:37
(19) ну в процедуре ПЕчать у тебя какие параметры? Должен быть параметр типа МассивОбъектов. Это массив твоих ссылок.
   oqjawa
 
24 - 28.06.18 - 15:47
блин, у меня получилось..
вы правы, я через массивОбъектов и сделал первый запрос..

|ИЗ
        |    Документ.ПриемНаРаботу КАК ПриемНаРаботу
        |ГДЕ ПриемНаРаботу.Ссылка В(&МассивОбъектов)";
    
    

        Запрос.Параметры.Вставить("МассивОбъектов", МассивОбъектов);


и заработало, потом установил ссылку во второй запрос

  СотрудникСсылка =  ВыборкаДетальныеЗаписи.ФизическоеЛицо;


   |ГДЕ
        |   Физлицо = &СотрудникСсылка";
  
 
    Запрос.УстановитьПараметр("СотрудникСсылка",СотрудникСсылка);


и тоже заработало, жаль что всё это методом тыка, не уверен что разобрался до конца, нужен опыт а для начала хорошая, статья видео, пока что я понял что МассивОбъектов это то что мне было нужно))
спасибо)


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует