Вход | Регистрация

1С:Предприятие ::

Метки: 

Нумерация счет фактур выданных

Я
   serg_buz
 
28.06.18 - 07:46
Доброго времени, Уважаемые коллеги!

Комплексная автоматизация 2.1 (обычные формы).

Или я схожу с ума, или что то идет не так ) Слетела нумерация счет фактур выданных на реализацию (авансовые СФ идут правильно). Префикс организации ТС, длина номера 12 знаков. Со вчерашнего дня новые СФ на реализацию стали формироваться не в формате ТС000000587, а в формате ТСО0000541, т.е. добавилась буква "О" к префиксу и стал короче номер.
Путем ручного исправления последних номеров СФ, исправить ситуацию не получилось.
Поймать в отладке где присвается номер я не могу, и если я не ошибаюсь, номер платформа сама присваивает.
Путем общего журнала проверил все номера всех документов - префикса ТСО нет ни где.
Путем настройки стратегии редактирования номеров тоже не получилось
Путем востановления префиксов через универсальный подбор и обработку объектов - тоже не получилось...
Может кто то сталкивался с таким, как это можно исправить?
 
 
   Mankubus
 
1 - 28.06.18 - 07:49
(0) префикс узла? ищи подписку на событие ПриУстановкеНовогоНомера
   serg_buz
 
2 - 28.06.18 - 07:53
Префиксов узла нет, при установке нового номера - префикс корректный, в подписке этот документ не участвует, т.к. у него бывают разные превиксы - может добавится "А" - Авансовая, или "И" - исправления
   d4rkmesa
 
3 - 28.06.18 - 08:39
(0) Общий журнал - это же вроде отчет? Нифига там не увидишь. Может, есть новая организация с префиксом ТСО ?
   serg_buz
 
4 - 28.06.18 - 09:37
(3) Вроде отчет, но выводит туда все документы. Нет такого префикса ( Вообще не понимаю где собака зарылась (
   CHerypga
 
5 - 28.06.18 - 09:42
ОбновитьНумерациюОбъектов(<Метаданные>) пробовали?
   hhhh
 
6 - 28.06.18 - 09:42
(2) кто-то из пользователей вручную внес документ с номером начинающимся с ТСО
   serg_buz
 
7 - 28.06.18 - 09:50
(5) Пробовал - не помогло
   serg_buz
 
8 - 28.06.18 - 09:51
(6) Вроде все проверил, нет такого документа
   _Дайвер_
 
9 - 28.06.18 - 09:58
(8) Еще раз смотри, полюбому так и есть
   serg_buz
 
10 - 28.06.18 - 10:29
(9) Тоже в этом был уверен, решил обработкой по всем документам пройтись, и результат = 0
Для каждого Документ Из Метаданные.Документы Цикл
        Попытка
            Запрос = Новый Запрос;
            Запрос.Текст = "ВЫБРАТЬ
                           |    Ссылка
                           |ИЗ
                           |    Документ." + Документ.Имя + "
                           |ГДЕ
                           |    Номер ПОДОБНО ""%ИК%""";
            //Запрос.УстановитьПараметр("Номер", "ТСО");

            
            Выборка = Запрос.Выполнить().Выгрузить();
            
            Для Каждого Стр Из Выборка Цикл
                ОбластьШапка.Параметры.Заполнить(Стр);
                ТабДок.Вывести(ОбластьШапка);
                
            КонецЦикла;
        Исключение
        КонецПопытки;
        
    КонецЦикла;
 
  Рекламное место пустует
   serg_buz
 
11 - 28.06.18 - 10:29
Пардон...
Для каждого Документ Из Метаданные.Документы Цикл
        Попытка
            Запрос = Новый Запрос;
            Запрос.Текст = "ВЫБРАТЬ
                           |    Ссылка
                           |ИЗ
                           |    Документ." + Документ.Имя + "
                           |ГДЕ
                           |    Номер ПОДОБНО ""%ТСО%""";
            //Запрос.УстановитьПараметр("Номер", "ТСО");


            
            Выборка = Запрос.Выполнить().Выгрузить();
            
            Для Каждого Стр Из Выборка Цикл
                ОбластьШапка.Параметры.Заполнить(Стр);
                ТабДок.Вывести(ОбластьШапка);
                
            КонецЦикла;
        Исключение
        КонецПопытки;
        
    КонецЦикла;
   1sanekmaloi1
 
12 - 28.06.18 - 10:45
выбери все доки и сортани по номеру и покажи максимальный
   serg_buz
 
13 - 28.06.18 - 10:56
(12) Ну нет таких документов ( Уже вообще не понимаю в чем может быть дело (
   Aleksandr N
 
14 - 28.06.18 - 11:02
(0) Правильно писать нумерация счетов-фактур.
   d4rkmesa
 
15 - 28.06.18 - 12:13
(11) Там может О - латинское?
   serg_buz
 
16 - 28.06.18 - 12:15
(15) Тоже пробовал уже, все возможные расклады русский + английский )


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует