Вход | Регистрация

1С:Предприятие ::

Метки: 

Структура элементов на управляемой форме. Как найти нужный элемент без перебора элементов?

Я
   Dunstan
 
27.06.18 - 10:52
Нужно найти табличное поле на управляемой форме. Делаю это перебором всех элементов формы. Может быть есть какой-то иной способ найти нужный элемент управляемой формы?
Пример поиска перебором:
//*****

ФлНашлиТабличнуюЧасть = Ложь;
        Для Каждого Эл  Из _ЭтаФорма.Элементы Цикл
            Если ТипЗнч(Эл) <>  Тип("ТаблицаФормы")  Тогда
                Продолжить;
            КонецЕсли;    
            Если Эл.ПутьКДанным = "Объект." + _ИмяТабличнойЧасти Тогда
                ФлНашлиТабличнуюЧасть = Истина;
                Прервать;
            КонецЕсли;    
        КонецЦикла;

//*****
 
 
   Darych
 
1 - 27.06.18 - 10:54
[]
   lodger
 
2 - 27.06.18 - 10:54
ЭлементыФормы.Получить(Индекс), если знаешь индекс и он неизменяемый.
ЭлементыФормы.Найти(Имя), если знаешь имя.
   VladZ
 
3 - 27.06.18 - 10:56
Не понял суть проблемы.

Элементы["ИмяЭлемента"].
   1Сергей
 
4 - 27.06.18 - 10:58
(3) +1
   Dunstan
 
5 - 27.06.18 - 10:59
А по ПутьКДанным можно как-то быстро найти?
   lodger
 
6 - 27.06.18 - 11:00
(5) нет.
   1Сергей
 
7 - 27.06.18 - 11:04
(5) можно. Выкинь "Объект." из ПутьКДанным
   Dunstan
 
8 - 27.06.18 - 11:09
(5) Не понял мысль. Поясни пжл!?
   Darych
 
9 - 27.06.18 - 11:34
Эл.ПутьКДанным = _ИмяТабличнойЧасти
   Mort
 
10 - 27.06.18 - 11:38
На один реквизит формы может ссылаться несколько элементов формы. Поэтому тока перебором.
 
 
   hhhh
 
11 - 27.06.18 - 11:57
(10) чем поможет перебор, если несколько элементов?
   Mort
 
12 - 27.06.18 - 11:59
(11) Я к тому, что однозначной привязки реквизита к элементу быть не может. Поэтому поиск, можно найти все, например. Встроенного поиска элементов платформа не предлагает, поэтому ручками.
   Fish
 
13 - 27.06.18 - 12:02
(10) Я так понял, что автору нужен первый попавшийся элемент формы, который ссылается на нужный реквизит.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует