Вход | Регистрация


1С:Предприятие ::

Метки: 

вылетает отчет из 1С 7.7

Я
   cyberandr
 
26.06.18 - 16:08
Всем привет! Такая беда есть 1с 7.7 +sql. И некий здоровый по месячный накопительный с начала года (управленческий балланс) отчет. Когда делаю на определенном месяце вылетает на строке Ит=0; коменчу строку, вылетает дальше на похожей  фигне. Что с ней не понятно. Самое интересное что вылетает на конкретном месяце- мае, и  если сделать за июнь то он работает включая и май. Не подскажите что вообще можно сделать, так как в самом отладчике все вроде ок пока не вылетит, а причину найти надо.
 
 
   Мандалай
 
1 - 26.06.18 - 16:11
Самый дубовый способ, сформировать отчет по подпериодам - неделя/день/час...
   Darych
 
2 - 26.06.18 - 16:12
базу "лечил" - ТИИ там?
   Diman_Kr
 
3 - 26.06.18 - 16:13
В БД БАГА однако.
   cyberandr
 
4 - 26.06.18 - 16:16
базу лечил реиндексацией пересчетом служебных данных и пересчетом итогов.
   Darych
 
5 - 26.06.18 - 16:20
карачун ей похоже(
   Somebody
 
6 - 26.06.18 - 16:26
(4) вроде выгрузка-загрузка помогает иногда
   Builder
 
7 - 26.06.18 - 16:36
(0) Внешние компоненты есть?
Я так понимаю вылетает не на запросе, а дальше? Или при обходе  запроса?
Скуль какой версии?
   cyberandr
 
8 - 26.06.18 - 16:42
sql 2005. Вылетает вообще на фигне 
    Ит = "";
    Если Реж = 0 Тогда
        Т.ТолькоПросмотр(1);
        Т.Опции(0, 0, 5, 2,"Баланс","Баланс"); 
        Право=4;
        Если Измен=1 Тогда
            Право=Право+2;
        КонецЕсли;    
        Т.ОбластьПечати(2,,,Право);
        Т.Показать("Баланс ("+ПериодСтр(НачГода(Дата2), Дата2)+")", "");  
    КонецЕсли;
    СохранитьЗначение("Коды1Б",Коды1);
    СохранитьЗначение("Коды2Б",Коды2);
    СохранитьЗначение("Коды3Б",Коды3);
        
КонецПроцедуры
   cyberandr
 
9 - 26.06.18 - 16:45
там ко всему еще беда что не можем народ на сервер загнать, работают со своих компов, на которых у кого Win 10, у кого 7-ка... Хотя раньше вроде ничего вроде было.
   Builder
 
10 - 26.06.18 - 16:47
(9) Ну если скуль, какая разница?
Такая ошибка только на одном компе? Просто сталкивался с похожими вылетами, вылечилось созданием нового профиля пользователя винды.
 
  Рекламное место пустует
   Darych
 
11 - 26.06.18 - 16:49
"у кого Win 10, у кого 7-ка" это-то причем? хз но пахнет загибом
   cyberandr
 
12 - 26.06.18 - 16:51
подключаются по сетке к каталогу
   Builder
 
13 - 26.06.18 - 16:52
(12) Ну и правильно, а как еще ?
   cyberandr
 
14 - 26.06.18 - 16:53
(10) нет. сейчас обнаружил что на разных компах разные ошибки - поэтому задумался. Май все равно нигде не работает, но вот когда июнь работает с одного компа и не работают с другого -странно. Права в 1с понятно одинаковые...
   Somebody
 
15 - 26.06.18 - 16:59
(13) через терминальнй сервер, видимо.
   Builder
 
16 - 26.06.18 - 17:01
(15) А там не к каталогу подключаешься? Придумали новый способ? Какая разница где каталог - в сетке или на локальной машине.
   NikVars
 
17 - 26.06.18 - 17:01
(0) Если отчет большой, то все данные гонятся на клиента в дбфный темп, а его размер максимум 2Гб. Глянь как размер свободного места гуляет и все станет ясно.
   NikVars
 
18 - 26.06.18 - 17:02
Я когда-то такой момент обходил оптимизацией запросного отчета.
   Darych
 
19 - 26.06.18 - 17:06
(17) " все данные гонятся на клиента в дбфный темп" кстати да.. но ошибка не отсюда
   Карст
 
20 - 26.06.18 - 17:08
еще пути к темпам с правами + квотирование ...
   cyberandr
 
21 - 26.06.18 - 17:12
тут все упирается в вопрос - за июнь проходит - то есть размер ДБФ конкретно тут роли не играет
   NikVars
 
22 - 26.06.18 - 17:15
(21) Может есть пустой или кривой док в июне?
   Darych
 
23 - 26.06.18 - 17:21
имхо бито у тебя в таблицах
   Мандалай
 
24 - 26.06.18 - 17:25
Не увидел где в (8) Ит=0;
   Darych
 
25 - 26.06.18 - 17:27
(24) а там Ит вообще дальше нет)
   Builder
 
26 - 26.06.18 - 17:35
Да, кстати, каким способом подключена 7.7 к 2005 скулю?
Всегда ставил "секретный релиз" + скуль 2008, проблем не было.
   cyberandr
 
27 - 26.06.18 - 17:38
(24) Это я на всякий переделал Ит=""; ничего не значащий код.
на счет секретного релиза - боязно его использовать тем более с 2008 скулем.
   NikVars
 
28 - 26.06.18 - 17:42
(27) Если Ит = "", то как Ит + 1?
   cyberandr
 
29 - 26.06.18 - 17:43
там такого нет
   NikVars
 
30 - 26.06.18 - 17:45
(29) Какой размер 1cv7.mlg?
   NikVars
 
31 - 26.06.18 - 17:46
Заверши работу в проге 1с. Почисти каталог пользователя и пробуй снова.
   NikVars
 
32 - 26.06.18 - 17:47
Прошу прощения! 1Cv7.CFG!
   NikVars
 
33 - 26.06.18 - 17:47
А млг, убери в строну.
 
 
   NikVars
 
34 - 26.06.18 - 17:52
И вообще, как на клиенте с местом, чисткой темпов, что с антивирусом, дефрагментацией. Проведи банальное обслуживание компа. Вдруг там есть глюки и в других прогах.
   cyberandr
 
35 - 26.06.18 - 17:58
(34) Этим админы занимаются поэтому думаю все ок
   NikVars
 
36 - 26.06.18 - 18:01
(35) Проверь. Обычно вылет семерки без вопросов. Это или нехватка памяти, или ошибка во внешней компоненте, которая вызывается через ОЛЕ или что-то в этом роде.
   cyberandr
 
37 - 26.06.18 - 18:10
проверю спасибо



Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует