Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Данные из обработки

Данные из обработки
Я
   13spartak13
 
26.06.18 - 16:02
Задача такого плана, диспетчер работает с обработкой, на форме обработки есть поле ДАТА и МОНТАЖНИК, как она сделала свои дела, нажимает на форме обработки на кнопку "ПЕРЕЙТИ К НАРЯДУ", Открывается документ, как в этот документ передать дату и монтажника из формы обработки? Спасибо!
 
 
   Darych
 
1 - 26.06.18 - 16:06
параметром
   13spartak13
 
2 - 26.06.18 - 16:07
ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("Монтажник",Объект.Монтажник);
    ПараметрыФормы.Вставить("ДатаР",Объект.ДатаРаботы);
    ОткрытьФорму("Документ.НарядНаРаботы.Форма.ФормаДокумента",ПараметрыФормы);
 
Это я сделал! А что и где дальше писать? (1)
   Darych
 
3 - 26.06.18 - 16:09
(2) в присоздании читаешь
   13spartak13
 
4 - 26.06.18 - 16:14
(3) Можно с кодом? И документ может создаваться и без участия обработки?
   13spartak13
 
5 - 26.06.18 - 16:15
Второе предложение - это утверждение а не вопрос. (4)
   Darych
 
6 - 26.06.18 - 16:19
(5) может - обработка, отчет, да хоть справочник.
(4) посмотри в любой ст конфе как ловятся параметры)
   xXeNoNx
 
7 - 26.06.18 - 16:34
А заполнить объект и через параметр "ключ" открыть его форму?
   xXeNoNx
 
8 - 26.06.18 - 16:37
   13spartak13
 
9 - 26.06.18 - 16:45
(7) Немного не понимаю как... (6) Да с других доков как-то понятно и то не совсем а тут обработка... Ничего не получается, интересует именно кот ОбработкиЗаполнения
   13spartak13
 
10 - 26.06.18 - 16:47
(9) Забыл добавить у меня УФ
 
 Рекламное место пустует
   Darych
 
11 - 26.06.18 - 16:52
(9) форма открывается и у нее параметры)
   xXeNoNx
 
12 - 26.06.18 - 16:52
(9)
ДокументОбъект.<Имя документа> (DocumentObject.<Имя документа>)
ОбработкаЗаполнения (Filling)
....
Возникает при вводе документа на основании, а также при выполнении метода Заполнить, при вводе на основании, а также при интерактивном вводе нового. В процедуре-обработчике этого события должен быть описан сам алгоритм заполнения реквизитов документа на основании переданного значения.


ДокументОбъект.<Имя документа> (DocumentObject.<Имя документа>)
Заполнить (Fill)
Синтаксис:

Заполнить(<ДанныеЗаполнения>)
Параметры:

<ДанныеЗаполнения> (обязательный)

Тип: Произвольный.
Значение, на основании которого выполняется заполнение документа.
Описание:

Заполняет данные документа данными из другого объекта. Инициирует событие ОбработкаЗаполнения и вызов его процедуры-обработчика в модуле документа. В ней может размещаться алгоритм, заполняющий данные документа из переданного значения.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
Примечание:

Для заполнения может использоваться значение любого типа.
Пример:

РасходнаяНакладная.Заполнить(ВыбКонтрагент);
   xXeNoNx
 
13 - 26.06.18 - 16:53
(11) Ему надо ловить в "ОбработкаЗаполнения"
   Somebody
 
14 - 26.06.18 - 16:55
код, который создает из Обработки документ Реализация, рабочий.

&НаКлиенте
Процедура ВыполнитьНажатие(Команда)
    Форма = ПолучитьФорму("Документ.РеализацияТоваровУслуг.Форма.ФормаДокументаОбщая");
    ДанныеФормы = Форма.Объект;
    ЗаполнитьНаСервере(ДанныеФормы, Объект.ОтчетПроизводства,Объект.ТипЦен,Объект.НекоеСубконто);
    КопироватьДанныеФормы(ДанныеФормы, Форма.Объект);
    Форма.Открыть();
 
КонецПроцедуры
 
&НаСервере
Процедура ЗаполнитьНаСервере(ДокОбъект , ОтчетПроизводства, ТипЦен, НекоеСубконто)
        ДокОбъект.ВидОперации                 = Перечисления.ВидыОперацийРеализацияТоваров.ПродажаКомиссия;
        ДокОбъект.СпособЗачетаАвансов         = Перечисления.СпособыЗачетаАвансов.НеЗачитывать;
        ДокОбъект.Организация                 = ОтчетПроизводства.Организация;
        ДокОбъект.Склад                       = ОтчетПроизводства.Склад;
        ДокОбъект.ТипЦен                      = ТипЦен;
        //ДокОбъект.УчитыватьНДС                 = false;

    
        для каждого стр из ОтчетПроизводства.Продукция цикл
    
            СтрТовары                          = ДокОбъект.товары.добавить();
            СтрТовары.номенклатура             = стр.Номенклатура;
            СтрТовары.количество               = стр.Количество;
            СтрТовары.Цена                     = стр.ПлановаяСтоимость;
            СтрТовары.сумма                    = стр.СуммаПлановая;
            СтрТовары.СтавкаНДС                = стр.Номенклатура.СтавкаНДС;
            СтрТовары.суммаНДС                 = 0;
            СтрТовары.СчетУчета                = ПланыСчетов.Хозрасчетный.НайтиПоКоду("43");
            СтрТовары.СчетДоходов              = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
            СтрТовары.СчетРасходов             = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
            СтрТовары.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.03");
            
            СтрТовары.Субконто                 = НекоеСубконто;
    конеццикла;
         
КонецПроцедуры
   13spartak13
 
15 - 26.06.18 - 17:00
(12) Вопрос решен Всем спасибо! Все просто!

Вот код:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Параметры.Свойство("Монтажник") Тогда
        Объект.Монтажник = Параметры.Монтажник;
        КонецЕсли;
КонецПроцедуры
   Darych
 
16 - 26.06.18 - 17:17
гы)
   Chameleon1980
 
17 - 26.06.18 - 20:52
(15) тебе уже в (3) давно и ответили блин.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Компьютеры — прекрасное средство для решения проблем, которых до их появления не было.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует