Вход | Регистрация

1С:Предприятие ::

Метки: 

Конвертация данных 7.7 - 8. Выгрузка только номенклатуры у которой есть остаток

Я
   Wefast
 
26.06.18 - 15:14
Собственно в этом и вопрос. Как сделать это чтобы не поломать правила которые у меня уже созданы.

Мне нужно запросом получить те же поля что в правилах?
Что при этом будет Источником в этих правилах?
Т.е. код надо переписывать?

Не делать же проверку перед выгрузкой запросом в регистр
 
  Рекламное место пустует
   Aleksey
 
1 - 26.06.18 - 15:22
ПВД выгрузка остатков
далее запрос и выгрузка по правилу
   Wefast
 
2 - 26.06.18 - 15:27
(1) я понял. Но запросом вытягивать все поля что и имена пкс в ПКО?
   vtolga
 
3 - 26.06.18 - 15:29
Заполни какой- нибудь документ (например, инвентаризацию) и перетащи только его. Номенклатура поедет по ссылкам.
   Diman_Kr
 
4 - 26.06.18 - 15:33
Создай Новое правило Где "получить из входящих" и адресуй в те что есть.
   Diman_Kr
 
5 - 26.06.18 - 15:35
Что-то типа:
    ТекстЗапроса = глПериодЗапроса(НачГода(РабочаяДата()),КонГода(РабочаяДата()))+";
        |Склад = Регистр.Товары.Склад;
        |Товар = Регистр.Товары.Товар;
        |_Количество    = Регистр.Товары.Остаток;
        |Функция Колво1    = НачОст(_Количество);
        |Функция Колво    = КонОст(_Количество);
        |Функция Приход    = Приход(_Количество);
        |Функция Расход    = Расход(_Количество);
        |";
        ТекстЗапроса1 = ТекстЗапроса + "
        |Группировка Склад без групп;
        |Группировка Товар без групп;
        |";
    Запрос = СоздатьОбъект("Запрос");
    Если Запрос.Выполнить(ТекстЗапроса1)=0 Тогда
        Возврат 0;
    КонецЕсли;
    
    Пока Запрос.Группировка(1)=1 цикл
            ВыгрузитьПоПравилу(Запрос.Склад,,,,"Склады");
        Пока Запрос.Группировка(2)=1 цикл
            ВыгрузитьПоПравилу(Запрос.Товар,,,,"Номенклатура");
        КонецЦикла;    
    КонецЦикла;
   Kigo_Kigo
 
6 - 26.06.18 - 15:38
А что от куда и куда тащим то собственно?
   Wefast
 
7 - 26.06.18 - 15:43
Номенклатуру из какой то переписанной семерки под названием Сеть магазинов в Розницу 2.2 от Раруса
   Kigo_Kigo
 
8 - 26.06.18 - 15:46
(7) Ну вам уже правильно подсказали, создать документ - Инвентраризация, или любой другой, приход например, который сейчас перегружаеться, заполнить его остатками, и сделать обмен с восьмеркой
   Wefast
 
9 - 26.06.18 - 15:46
(3) (5) классные варианты, так и попробую.

(5) А убирать в ПВД источник и способ выборки Произвольный алгоритм?
   Diman_Kr
 
10 - 26.06.18 - 16:04
Зачем Источник убирать?
Да
способ выборки Произвольный алгоритм
 
 
   Diman_Kr
 
11 - 26.06.18 - 16:07
(5) Красивее чем (3)
   nicxxx
 
12 - 26.06.18 - 18:13
(0) надеюсь, поможет http://catalog.mista.ru/public/81147/
   hhhh
 
13 - 26.06.18 - 19:30
(2) выгружай типовым переносом. Только там не все галки при выгрузке ставь. Галку переносить остатки товара поставь. А галку переносить справочник Номенклатура не ставь.


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует