Вход | Регистрация

1С:Предприятие ::

Метки: 

v7: ТиС и Атол, подскажите с какой dll -кой работать, чтобы была 9-я версия

Я
   Kigo_Kigo
 
26.06.18 - 14:35
Я так понял 8-я заканчиваеться на ФФД 1.0, далее 9-я версия, какую длл закинуть в базу и какой Аддин, для её вызова из ТиС 7.7?
Скачал ДТО 9, там FPrnM1C.dll уже нет, то что в ТиС 997 - там 8.15, а типами оплаты там беда
 
  Рекламное место пустует
   Somebody
 
1 - 26.06.18 - 14:38
с ФФД 1.05 8-ой драйвер еще вполне работает.
   Kigo_Kigo
 
2 - 26.06.18 - 14:42
Если Док.Получено <> 0 Тогда
            Объект.TypeClose = 0;
            Объект.Summ = Док.Получено;
            Объект.Payment();
        КонецЕсли;
        Если Док.ПоБанку <> 0 Тогда 
            Объект.TypeClose = 1;
            Объект.Summ = Док.ПоБанку;
            Объект.Payment();
        КонецЕсли;
        СписокТоваров.ПолучитьСтрокуПоНомеру(1);

            
            Если Док.Предоплата <> 0 Тогда 
                Объект.TypeClose = 2;
                Объект.Summ=Док.Предоплата;
                Объект.Payment();
            КонецЕсли;  

Вот это не работает
   Somebody
 
3 - 26.06.18 - 14:46
а Это - это что? в чем конкретно проблема?
   Kigo_Kigo
 
4 - 26.06.18 - 14:47
(3) Несколько типов оплаты в одном чеке
это наличка + банк+ предоплата, машика(ККТ) все наличными выдает
   Somebody
 
5 - 26.06.18 - 14:49
такого не пробовал. у моих не бывает несколько типов оплаты в одном чеке, к сожалению.
   Kigo_Kigo
 
6 - 26.06.18 - 14:51
(5) Да там магазин мебели, работают по предоплате, соотвественно надо выбить чек на предоплату, потом при расчете, показать в чеке что была предоплата и передать это в ОФД, иначе идет необоснованое увеличение оборота на сумму - сумм предоплат, если все бить наликом или электронно
   Alex33
 
7 - 26.06.18 - 14:58
Как раз в настоящее время доделываю такое для Атола - на версии драйвера 8.16 все работает: Объект.TypeClose = 1; и Объект.TypeClose = 2;
   Alex33
 
8 - 26.06.18 - 15:00
(7) - использую FprnM1C.dll, AddIn.FprnM45
   Kigo_Kigo
 
9 - 26.06.18 - 15:01
(7) Тест драйвера ККМ:                   8.16.1.8701

Сведения о драйвере:
Вариант:                             Бесплатный
Драйвер:                             8.16.1.8701
Сервисный модуль:                    8.16.1.8701

Не пашет, странно
   Somebody
 
10 - 26.06.18 - 15:02
(9) 8.16.3 вышел, кстати.
 
  Рекламное место пустует
   Alex33
 
11 - 26.06.18 - 15:03
(7) - использую именно эту версию, сейчас ККм стоит у меня на столе - всё работает. Может дело в кассе? (сам аппарат)
   Kigo_Kigo
 
12 - 26.06.18 - 15:05
(11) Атол 30Ф, смотрю таблицы, предоплаты расписаны
   Alex33
 
13 - 26.06.18 - 15:07
(12) - У меня тоже 30Ф, работает
   Kigo_Kigo
 
14 - 26.06.18 - 15:10
Смущает надпись перед итогом чека - ПОЛНЫЙ РАСЧЕТ, тут что то не то?, перепиливаю обработку от 1с-ки
   Alex33
 
15 - 26.06.18 - 15:13
(14) - ПОЛНЫЙ РАСЧЕТ - это надпись по каждой строке товара. Устанавливается Объект.PaymentMode=4; Я ещё использую "АВАНС" Объект.PaymentMode=3;
   Kigo_Kigo
 
16 - 26.06.18 - 15:20
О чудо, закрыл смену, открыл, стало работать
   Garykom
 
17 - 26.06.18 - 15:38
смена макс 24 часа...
   Garykom
 
18 - 26.06.18 - 15:39
еще обычно сразу после открытия смены нельзя сделать возврат наличными, прикинь... потому что денег нет в кассе...
   Kigo_Kigo
 
19 - 26.06.18 - 15:39
(17) Я аппарат тока в руки из ЦТО сегодня взял, открыл смену - драйвером, закрыл и открыл из 1С и все взлетело, видимо какие то предустановки просто были, я хз
   Kigo_Kigo
 
20 - 26.06.18 - 15:41
(18) Если не ставить автообнуление наличности, то деньги есть в кассе, так же еще можно сделать внесение, но это уже не те дебри, нам оно пока не нать


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует