Вход | Регистрация

1С:Предприятие ::

Метки: 

Активизация строки.

Я
   antihacker
 
26.06.18 - 12:03
Всем привет !Тут у меня происходит что то не понятное.
Вот процедуры и функции.

&НаКлиенте
Процедура ФТЧФКРПриАктивизацииСтроки(Элемент)
    
    Если Элемент.ТекущиеДанные = НеОпределено Тогда
         Возврат;    
    Иначе        
         СтарыйФКР             = Элемент.ТекущиеДанные.ФКР;
         Объект.ИтогВПодвалеПР = Элементы.ФТЧФКР.ТекущиеДанные.ФКР;
         СписокЭКР(Ложь);
        //СуммаВПодвалеНаКлиенте();

    КонецЕсли;
        
КонецПроцедуры


&НаКлиенте
Процедура СброситьФильтр(Команда)
    
    //Вставить содержимое обработчика.

    Объект.ИтогВПодвалеПР  = "";
    Объект.Организация     = "";
    СписокЭКР(Истина);
КонецПроцедуры

&НаКлиенте
Процедура СписокЭКР(вхФильтрСброшен)
    
         Отбор = Новый Структура;

    
    Если НЕ вхФильтрСброшен Тогда
         Если ЗначениеЗаполнено(Объект.ИтогВПодвалеПР) Тогда
              Отбор.Вставить("ФКР", Объект.ИтогВПодвалеПР);
         КонецЕсли;      
    //КонецЕсли;

     
    Если ЗначениеЗаполнено(Объект.Организация) Тогда
         Отбор.Вставить("Организация", Объект.Организация);
    КонецЕсли;
    КонецЕсли;
 
    //-----ФТЧРасходыПоОбязательствам--

    Элементы.ФТЧРасходыПоОбязательствам.ОтборСтрок = Новый ФиксированнаяСтруктура(Отбор); 
    
    //-----ФТЧРасходыПоПлатежам--------

    Элементы.ФТЧРасходыПоПлатежам.ОтборСтрок = Новый ФиксированнаяСтруктура(Отбор); 
    
    СуммаВПодвалеНаКлиенте();
 
КонецПроцедуры

&НаКлиенте
Процедура СуммаВПодвалеНаКлиенте()
    
    //ИтоговыеДанныеСКА = Новый Структура;

    ИтоговыеДанныеСКА = СуммаВПодвале();

    Если ИтоговыеДанныеСКА <> НеОпределено Тогда
        
         Элементы.Утв_ЯнварьРП.ТекстПодвала      = ИтоговыеДанныеСКА.УтвЯнварь;
         Элементы.ЯнварьРП.ТекстПодвала          = ИтоговыеДанныеСКА.Январь;
         Элементы.Итог_ЯнварьРП.ТекстПодвала     = ИтоговыеДанныеСКА.ИтогЯнварь;
         Элементы.Утв_ФевральРП.ТекстПодвала     = ИтоговыеДанныеСКА.УтвФевраль;
         Элементы.ФевральРП.ТекстПодвала         = ИтоговыеДанныеСКА.Февраль;
         Элементы.Итог_ФевральРП.ТекстПодвала    = ИтоговыеДанныеСКА.ИтогФевраль;
         Элементы.Утв_МартРП.ТекстПодвала        = ИтоговыеДанныеСКА.УтвМарт;         
         Элементы.МартРП.ТекстПодвала            = ИтоговыеДанныеСКА.Март;
         Элементы.Итог_МартРП.ТекстПодвала       = ИтоговыеДанныеСКА.ИтогМарт;
         Элементы.Утв_АпрельРП.ТекстПодвала      = ИтоговыеДанныеСКА.УтвАпрель;
         Элементы.АпрельРП.ТекстПодвала          = ИтоговыеДанныеСКА.Апрель;
         Элементы.Итог_АпрельРП.ТекстПодвала     = ИтоговыеДанныеСКА.ИтогАпрель;
         Элементы.Утв_МайРП.ТекстПодвала         = ИтоговыеДанныеСКА.УтвМай;
         Элементы.МайРП.ТекстПодвала             = ИтоговыеДанныеСКА.Май;
         Элементы.Итог_МайРП.ТекстПодвала        = ИтоговыеДанныеСКА.ИтогМай;
         Элементы.Утв_ИюньРП.ТекстПодвала        = ИтоговыеДанныеСКА.УтвИюнь;
         Элементы.ИюньРП.ТекстПодвала            = ИтоговыеДанныеСКА.Июнь;
         Элементы.Итог_ИюньРП.ТекстПодвала       = ИтоговыеДанныеСКА.ИтогИюнь;
         Элементы.Утв_ИюльРП.ТекстПодвала        = ИтоговыеДанныеСКА.УтвИюль;
         Элементы.ИюльРП.ТекстПодвала            = ИтоговыеДанныеСКА.Июль;
         Элементы.Итог_ИюльРП.ТекстПодвала       = ИтоговыеДанныеСКА.ИтогИюль;
         Элементы.Утв_АвгустьРП.ТекстПодвала     = ИтоговыеДанныеСКА.УтвАвгуст;
         Элементы.АвгустРП.ТекстПодвала          = ИтоговыеДанныеСКА.Август;
         Элементы.Итог_АвгустьРП.ТекстПодвала    = ИтоговыеДанныеСКА.ИтогАвгуст;
         Элементы.Утв_СентябрьРП.ТекстПодвала    = ИтоговыеДанныеСКА.УтвСентябрь;
         Элементы.СентябрьРП.ТекстПодвала        = ИтоговыеДанныеСКА.Сентябрь;         
         Элементы.Итог_СентябрьРП.ТекстПодвала   = ИтоговыеДанныеСКА.ИтогСентябрь;             
         Элементы.Утв_ОктябрьРП.ТекстПодвала     = ИтоговыеДанныеСКА.УтвОктябрь;
         Элементы.ОктябрьРП.ТекстПодвала         = ИтоговыеДанныеСКА.Октябрь;
         Элементы.Итог_ОктябрьРП.ТекстПодвала    = ИтоговыеДанныеСКА.ИтогОктябрь;
         Элементы.Утв_НоябрьРП.ТекстПодвала      = ИтоговыеДанныеСКА.УтвНоябрь;
         Элементы.НоябрьРП.ТекстПодвала          = ИтоговыеДанныеСКА.Ноябрь;
         Элементы.Итог_НоябрьРП.ТекстПодвала     = ИтоговыеДанныеСКА.ИтогНоябрь;
         Элементы.Утв_ДекабрьРП.ТекстПодвала     = ИтоговыеДанныеСКА.УтвДекабрь;
         Элементы.ДекабрьРП.ТекстПодвала         = ИтоговыеДанныеСКА.Декабрь;         
         Элементы.ИтогДекабрьРП.ТекстПодвала     = ИтоговыеДанныеСКА.ИтогДекабрь;
         Элементы.Утв_СуммаГодРП.ТекстПодвала    = ИтоговыеДанныеСКА.УтвСуммаГод;
         Элементы.СуммаГодРП.ТекстПодвала        = ИтоговыеДанныеСКА.СуммаГод;
         Элементы.Итог_СуммаГодРП.ТекстПодвала   = ИтоговыеДанныеСКА.ИтогСуммаГод;
         
    КонецЕсли;        
    
КонецПроцедуры

&НаСервере 
Функция СуммаВПодвале()
    
    ДанныеВсехФКРТЗ = Объект.ТЧРасходыПоПлатежам.Выгрузить();
    

    Если ЭтотОбъект.Объект.Организация = Справочники.Организации.ПустаяСсылка() И  Объект.ИтогВПодвалеПР = Справочники.ФКР.ПустаяСсылка() Тогда         
         
        ПолеФКР = "АБП";
    ИначеЕсли ЭтотОбъект.Объект.Организация <> Справочники.Организации.ПустаяСсылка() И  Объект.ИтогВПодвалеПР <> Справочники.ФКР.ПустаяСсылка() Тогда
        
         Отбор = Новый Структура;
         Отбор.Вставить("Организация" ,Объект.Организация );         
         Отбор.Вставить("ФКР"         ,Объект.ИтогВПодвалеПР);
              
    ИначеЕсли ЭтотОбъект.Объект.Организация = Справочники.Организации.ПустаяСсылка() И  Объект.ИтогВПодвалеПР <> Справочники.ФКР.ПустаяСсылка()  Тогда
        
         Отбор = Новый Структура;     
         Отбор.Вставить("ФКР"         ,Объект.ИтогВПодвалеПР);    

    ИначеЕсли ЭтотОбъект.Объект.Организация <> Справочники.Организации.ПустаяСсылка() И  Объект.ИтогВПодвалеПР = Справочники.ФКР.ПустаяСсылка()  Тогда
                
         Отбор = Новый Структура;     
         Отбор.Вставить("Организация"         ,Объект.Организация );    

    КонецЕсли;
    
    Если ПолеФКР = "АБП" Тогда
         ДанныеТекФКРТЗ  = ДанныеВсехФКРТЗ.Скопировать();
         ДанныеТекФКРТЗ.Колонки.Добавить("АБП");
            ДанныеТекФКРТЗ.Свернуть("АБП","УтвЯнварь,Январь,ИтогЯнварь,УтвФевраль,Февраль,ИтогФевраль,УтвМарт,Март,ИтогМарт,УтвАпрель,Апрель,ИтогАпрель,УтвМай,Май,ИтогМай,УтвИюнь,Июнь,ИтогИюнь,УтвИюль,Июль,ИтогИюль" +
                               ",УтвАвгуст,Август,ИтогАвгуст,УтвСентябрь,Сентябрь,ИтогСентябрь,УтвОктябрь,Октябрь,ИтогОктябрь,УтвНоябрь,Ноябрь,ИтогНоябрь,УтвДекабрь,Декабрь,ИтогДекабрь,УтвСуммаГод,СуммаГод,ИтогСуммаГод");    
    Иначе
         ДанныеТекФКРТЗ  = ДанныеВсехФКРТЗ.Скопировать(Отбор);         
         ДанныеТекФКРТЗ.Свернуть("ФКР","УтвЯнварь,Январь,ИтогЯнварь,УтвФевраль,Февраль,ИтогФевраль,УтвМарт,Март,ИтогМарт,УтвАпрель,Апрель,ИтогАпрель,УтвМай,Май,ИтогМай,УтвИюнь,Июнь,ИтогИюнь,УтвИюль,Июль,ИтогИюль" +
                                 ",УтвАвгуст,Август,ИтогАвгуст,УтвСентябрь,Сентябрь,ИтогСентябрь,УтвОктябрь,Октябрь,ИтогОктябрь,УтвНоябрь,Ноябрь,ИтогНоябрь,УтвДекабрь,Декабрь,ИтогДекабрь,УтвСуммаГод,СуммаГод,ИтогСуммаГод");    
    КонецЕсли;     
      
         Если ДанныеТекФКРТЗ.Количество() > 0 Тогда
        
               ИтоговыеДанныеСКА = Новый Структура;
               ИтоговыеДанныеСКА.Вставить("УтвЯнварь"     ,ДанныеТекФКРТЗ[0].УтвЯнварь);
               ИтоговыеДанныеСКА.Вставить("Январь"         ,ДанныеТекФКРТЗ[0].Январь);
               ИтоговыеДанныеСКА.Вставить("ИтогЯнварь"     ,ДанныеТекФКРТЗ[0].ИтогЯнварь);
               ИтоговыеДанныеСКА.Вставить("УтвФевраль"     ,ДанныеТекФКРТЗ[0].УтвФевраль);
               ИтоговыеДанныеСКА.Вставить("Февраль"        ,ДанныеТекФКРТЗ[0].Февраль);
               ИтоговыеДанныеСКА.Вставить("ИтогФевраль"    ,ДанныеТекФКРТЗ[0].ИтогФевраль);
               ИтоговыеДанныеСКА.Вставить("УтвМарт"        ,ДанныеТекФКРТЗ[0].УтвМарт);
               ИтоговыеДанныеСКА.Вставить("Март"           ,ДанныеТекФКРТЗ[0].Март);
               ИтоговыеДанныеСКА.Вставить("ИтогМарт"       ,ДанныеТекФКРТЗ[0].ИтогМарт);
               ИтоговыеДанныеСКА.Вставить("УтвАпрель"      ,ДанныеТекФКРТЗ[0].УтвАпрель);
               ИтоговыеДанныеСКА.Вставить("Апрель"         ,ДанныеТекФКРТЗ[0].Апрель);
               ИтоговыеДанныеСКА.Вставить("ИтогАпрель"    ,ДанныеТекФКРТЗ[0].ИтогАпрель);
               ИтоговыеДанныеСКА.Вставить("УтвМай"         ,ДанныеТекФКРТЗ[0].УтвМай);
               ИтоговыеДанныеСКА.Вставить("Май"            ,ДанныеТекФКРТЗ[0].Май);
               ИтоговыеДанныеСКА.Вставить("ИтогМай"        ,ДанныеТекФКРТЗ[0].ИтогМай);
               ИтоговыеДанныеСКА.Вставить("УтвИюнь"        ,ДанныеТекФКРТЗ[0].УтвИюнь);
               ИтоговыеДанныеСКА.Вставить("Июнь"           ,ДанныеТекФКРТЗ[0].Июнь);
               ИтоговыеДанныеСКА.Вставить("ИтогИюнь"       ,ДанныеТекФКРТЗ[0].ИтогИюнь);
               ИтоговыеДанныеСКА.Вставить("УтвИюль"        ,ДанныеТекФКРТЗ[0].УтвИюль);         
               ИтоговыеДанныеСКА.Вставить("Июль"             ,ДанныеТекФКРТЗ[0].Июль);
              ИтоговыеДанныеСКА.Вставить("ИтогИюль"        ,ДанныеТекФКРТЗ[0].ИтогИюль);
               ИтоговыеДанныеСКА.Вставить("УтвАвгуст"         ,ДанныеТекФКРТЗ[0].УтвАвгуст);
               ИтоговыеДанныеСКА.Вставить("Август"         ,ДанныеТекФКРТЗ[0].Август);
               ИтоговыеДанныеСКА.Вставить("ИтогАвгуст"     ,ДанныеТекФКРТЗ[0].ИтогАвгуст);
               ИтоговыеДанныеСКА.Вставить("УтвСентябрь"   ,ДанныеТекФКРТЗ[0].УтвСентябрь);
               ИтоговыеДанныеСКА.Вставить("Сентябрь"      ,ДанныеТекФКРТЗ[0].Сентябрь);         
               ИтоговыеДанныеСКА.Вставить("ИтогСентябрь"  ,ДанныеТекФКРТЗ[0].ИтогСентябрь);
               ИтоговыеДанныеСКА.Вставить("УтвОктябрь"    ,ДанныеТекФКРТЗ[0].УтвОктябрь);
               ИтоговыеДанныеСКА.Вставить("Октябрь"        ,ДанныеТекФКРТЗ[0].Октябрь);
               ИтоговыеДанныеСКА.Вставить("ИтогОктябрь"   ,ДанныеТекФКРТЗ[0].ИтогОктябрь);
               ИтоговыеДанныеСКА.Вставить("УтвНоябрь"     ,ДанныеТекФКРТЗ[0].УтвНоябрь);
               ИтоговыеДанныеСКА.Вставить("Ноябрь"        ,ДанныеТекФКРТЗ[0].Ноябрь);
               ИтоговыеДанныеСКА.Вставить("ИтогНоябрь"    ,ДанныеТекФКРТЗ[0].ИтогНоябрь);
               ИтоговыеДанныеСКА.Вставить("УтвДекабрь"    ,ДанныеТекФКРТЗ[0].УтвДекабрь);
               ИтоговыеДанныеСКА.Вставить("Декабрь"       ,ДанныеТекФКРТЗ[0].Декабрь);
               ИтоговыеДанныеСКА.Вставить("ИтогДекабрь"   ,ДанныеТекФКРТЗ[0].ИтогДекабрь);
               ИтоговыеДанныеСКА.Вставить("УтвСуммаГод"   ,ДанныеТекФКРТЗ[0].УтвСуммаГод);         
               ИтоговыеДанныеСКА.Вставить("СуммаГод"      ,ДанныеТекФКРТЗ[0].СуммаГод);         
               ИтоговыеДанныеСКА.Вставить("ИтогСуммаГод"  ,ДанныеТекФКРТЗ[0].ИтогСуммаГод);         
         
          КонецЕсли;
     

    Возврат ИтоговыеДанныеСКА;
    
КонецФункции


Когда Нажимаю на кнопку. то срабатывает процедура СброситьФильтр(Команда).

Все срабатывает нормально. И дает желаемый результат. Но почему то в конце само по себе срабатывает &НаКлиенте
Процедура ФТЧФКРПриАктивизацииСтроки(Элемент) и портит всю малину. Почему ? Вроде как я не ссылаюсь туда. Но все равно срабатывает.
 
  Рекламное место пустует
   Darych
 
1 - 26.06.18 - 12:06
баян... в поисковик
   antihacker
 
2 - 26.06.18 - 12:12
Что значит поисковик
   Darych
 
3 - 26.06.18 - 12:13
для меня чаще всего яндекс
   antihacker
 
4 - 26.06.18 - 12:15
Ив гугле был.
   PR
 
5 - 26.06.18 - 12:17
(4) Но умер
   Darych
 
6 - 26.06.18 - 12:18
(5) ну блин при отображении формы снова срабатывает
   Nikoss
 
7 - 26.06.18 - 12:18
.....................
        Элементы.Утв_ЯнварьРП.ТекстПодвала      = ИтоговыеДанныеСКА.УтвЯнварь;
         Элементы.ЯнварьРП.ТекстПодвала          = ИтоговыеДанныеСКА.Январь;
         Элементы.Итог_ЯнварьРП.ТекстПодвала     = ИтоговыеДанныеСКА.ИтогЯнварь;
         Элементы.Утв_ФевральРП.ТекстПодвала     = ИтоговыеДанныеСКА.УтвФевраль;
         Элементы.ФевральРП.ТекстПодвала         = ИтоговыеДанныеСКА.Февраль;
         Элементы.Итог_ФевральРП.ТекстПодвала    = ИтоговыеДанныеСКА.ИтогФевраль;
.....................

и не лень же было столько копипастить
   antihacker
 
8 - 26.06.18 - 12:19
Я так из за этого вызывается обновление формы ?
   antihacker
 
9 - 26.06.18 - 12:27
Да точно. Из за обновление формы.

Запихнул сюда
   antihacker
 
10 - 26.06.18 - 12:27
&НаКлиенте
Процедура ФТЧФКРВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
            //        Если Элемент.ТекущиеДанные = НеОпределено Тогда

    //     Возврат;    

    //Иначе        

         СтарыйФКР             = Элементы.ФТЧФКР.ТекущиеДанные.ФКР;
         Объект.ИтогВПодвалеПР = Элементы.ФТЧФКР.ТекущиеДанные.ФКР;
         СписокЭКР(Ложь);
        //СуммаВПодвалеНаКлиенте();

    //КонецЕсли;


КонецПроцедуры
 
  Рекламное место пустует


Список тем форума
Рекламное место пустует   Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует