Вход | Регистрация



Подключить ккм к старой конфигурации УТ

Подключить ккм к старой конфигурации УТ
Я
   АлехандроЛопес
 
24.06.18 - 22:29
Всем привет.
Чет я запутался совсем. Где почитать, что делать? Пока смог вот так.

    ПрогИД = "AddIn.ATOL_KKM_1C82_54FZ";
    Подключено = ПодключитьВнешнююКомпоненту(ПрогИД);
    Если Подключено = ложь тогда 
        возврат Результат = "Не удалось загрузить внешнюю компоненту";
    КонецЕсли;

Где указать порт и скорость, не осилили. Как пробить чек тоже :(
Может где есть пример или рыба?
 
 
   VKS
 
1 - 24.06.18 - 22:34
Зачем изобретать велосипед, все есть в типовых, посмотрите там 

Если речь про онлайн кассу для УТ 10.3, то есть статья https://its.1c.ru/db/metod8dev#content:5923:hdoc
   АлехандроЛопес
 
2 - 24.06.18 - 22:39
(1) У меня УТ 10.2
   АлехандроЛопес
 
3 - 24.06.18 - 22:41
(1) Не хочу ничего встраивать, сегодня весь день пытался из 10.3 перекинуть в итоге запутался.

Хочу прям в Глобальном модуле прописать ПодключитьВнешнююКомпоненту, в Чек ккм, функцию пробитьЧек
   VKS
 
4 - 24.06.18 - 22:47
Тогда посмотрите ATOLFiscalPrinters_v2.epf из папки TradeWareEpf
   VKS
 
5 - 24.06.18 - 22:50
Помнится вот так можно было снять X-отчет



Функция ПодключитьВоВремяПробития(Драйвер) Экспорт

    Попытка
        ПрогИД = "AddIn.FprnM45";
        ПодключитьВнешнююКомпоненту(ПрогИД);
        Драйвер = Новый (ПрогИД);
    Исключение
        Сообщить( "Невозможно подключить внешнюю компоненту.
        | Проверьте, что внешняя корректно установлена и имеет ту же версию, 
        | что и обработка обслуживания.");
    КонецПопытки;
        
    Драйвер.УстройствоВключено = 1;
    
    Возврат Истина;
КонецФункции// Подключить()


Процедура СнятьОтчет()
    
    Драйвер=Неопределено;
    ПодключитьВоВремяПробития(Драйвер);
        
    Драйвер.Пароль = 30;
    Драйвер.УстановитьПароль();

    Драйвер.Режим = 2;
    Драйвер.УстановитьРежим();

    Ответ = Драйвер.Результат;
    Если      Ответ = 0 Тогда
        Драйвер.ТипОтчета = 2;
        Драйвер.Отчет();
        Если Драйвер.Результат = 0 Тогда
            Драйвер.ПолучитьСостояние();
            Если Драйвер.Результат = 0 Тогда
            Иначе
                Состояние("Ошибка");    
            КонецЕсли;
        КонецЕсли;
    ИначеЕсли Ответ = -19 Тогда
        Состояние("ошибка");
    КонецЕсли;

    Драйвер.ВыходИзРежима();
    Драйвер.УстройствоВключено = 0;
    
КонецПроцедуры
   АлехандроЛопес
 
6 - 24.06.18 - 22:52
(5) ПрогИД = "AddIn.FprnM45"; 
Разве будет работать с Атол 30ф?
   Garykom
 
7 - 24.06.18 - 22:53
Любая конфа которая работает через 8-е дрова атол требует минимальных допилок для 54-ФЗ.

Там всего то вставить передачу СНО и ставки НДС, причем если ЕНВД или УСН/ПСН без НДС то и этого не нуна.
Изучать
   Garykom
 
8 - 24.06.18 - 22:54
(7)+ Изучать мануал из комплекта поставки драйверов
   Garykom
 
9 - 24.06.18 - 22:55
(6) Да будет, это осталось для совместимости.

Просто в старый драйвер (ком-объект) добавили новых методов и все. Большинство старых по прежнему работают.
   Garykom
 
10 - 24.06.18 - 22:57
(7)+ А еще виды оплат поправить (под ФФД 1.05 поменялись) и имена/инн кассиров как передавать.
Но кассиров можно задать через драйвер и просто как раньше номер кассира передавать (30 - сис.администратор, 1-28 кассиры)
 
 Рекламное место пустует
   Garykom
 
11 - 24.06.18 - 22:59
Кстати 8-е дрова атол сделаны на основе 6-х драйверов (а те на основе 4.5).
Короче успешно допиливал (под 54-ФЗ) древние конфы на 77 которые еще через 6-е дрова работали.
   АлехандроЛопес
 
12 - 24.06.18 - 23:07
(7) Сейчас попробовал, выходит
Ошибка при подключении фискального регистратора "POSPrint FP410K": Не удалось загрузить внешнюю компоненту "FprnM1C.dll".

regsvr32 FprnM1C.dll делал, дрова последние 8.16.3.9007
   АлехандроЛопес
 
13 - 24.06.18 - 23:20
Ехохохо. Пробило!
(11) Спасибо!
   Garykom
 
14 - 24.06.18 - 23:24
(12) Никаких regsvr32 не надо!
Инсталлятор дров при установке сам это делает, просто путь правильно указать при подключении вк.

И даже ком порт и скорость не надо указывать, через драйвер просто настроить по умолчанию логическое устройство и все.
   АлехандроЛопес
 
15 - 24.06.18 - 23:31
(14) Я заменил ЗагрузитьВнешнююКомпоненту(Модель.ВнешняяКомпонента); 
на ПодключитьВнешнююКомпоненту("AddIn." + Модель.ПрограммныйИдентификатор);
И все заработала

Чек пробивается, но потом аннулируется. Буду разбираться
   АлехандроЛопес
 
16 - 24.06.18 - 23:31
Пробилось, не хотело пробиваться из-за скидки
   Garykom
 
17 - 24.06.18 - 23:33
Я чтобы меньше проблем было все упоминания о скидках и прочих лишних типа сдачи и т.д. убираю из чеков нафик.
   Garykom
 
18 - 24.06.18 - 23:34
Если очень хочется их можно строками через ECR.PrintString() выводить а не спец командами
   АлехандроЛопес
 
19 - 24.06.18 - 23:47
Если я напишу Цена=Сумма/Количество Это же не правильно будет.
   АлехандроЛопес
 
20 - 24.06.18 - 23:56
(19) Я сделал округление при расчете скидки, должно стать норм. А как спрашивать смс или адрес электронной почты?
   Garykom
 
21 - 25.06.18 - 00:09
(20) Формочку показывай отдельную или добавь куда то в форму чека реквизит
   Garykom
 
22 - 25.06.18 - 00:11
(19) Это правильно!
Я в некоторых случаях делаю Количество = Сумма/Цена ))
   Масянька
 
23 - 25.06.18 - 08:39
(0) В обработках см. Торговое оборудование. Там много форм - ищи свою.


Список тем форума
Рекламное место пустует  Рекламное место пустует
Выдавать глобальные идеи — это удовольствие; искать сволочные маленькие ошибки - вот настоящая работа.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует