Вход | Регистрация

1С:Предприятие ::

Метки: 

v7: 1с 7.7 и несколько касс Штрих

Я
   knopik777
 
24.06.18 - 01:48
Друзья, помогите.
Есть сервер с установленной 1с 7.7, к нему по RDP подключаются пользователи. Есть 2 ккм Штрих онлайн подключенные к разным компам.
Подключение идет через RNDIS по USB шнурку. Прокинуты порты 7778.
В 1с настроено подключение торгового оборудования через штатный драйвер штриха DrvFR.dll и обработку печати чеков fr_elves.ert
Но проблема в том что в параметрах в 1с могу прописать ip адрес одной машины,
как заставить запоминать разные ip для разных пользователей?
Извините если сумбурно выразил свою мысль.
 
 
   LienXo
 
1 - 24.06.18 - 02:34
Для каждой кассы сделать свою обработку, в которой жестко прописать установку IP кассы.
   big
 
2 - 24.06.18 - 10:37
В параметрах пользователя в специальном реквизите прописать заводские номера ККМ, на которые они могут (должны) печатать чеки. В обработке fr_elves.ert перебираешь логические устройства, ищешь нужную ККТ с нужным номером и на неё уже печатаешь. Реально работающий вариант
   big
 
3 - 24.06.18 - 10:43
(2) + примерно вот так
        Объект.ПолучитьКоличествоЛУ();
        Для а=0 По Объект.КоличествоЛУ-1 Цикл
            Объект.ИндексЛУ = а;
            Объект.ПеречислитьЛУ();
            
            Если Объект.Результат <> 0 Тогда
                ОписаниеРезультата = "Неудачная попытка доступа к устройству с индексом "+а+".";
                Возврат 0;
            КонецЕсли;
            
            Объект.УстановитьАктивноеЛУ();
            Объект.Password=Пароль;
            Объект.Connect();

            Если Объект.Результат <> 0 Тогда
                ОписаниеРезультата = "ККМ с номером "+НомерФР+". "+ПолучитьОписаниеРезультата(Объект);
                Возврат 0;
            КонецЕсли;
            
            Объект.GetECRStatus();
            НомерККМ = СокрЛП(Объект.ЗаводскойНомер);
            Если Найти(НомерФР,НомерККМ)<>0 Тогда
                ФлагНашли = 1;
                Прервать;
            КонецЕсли;
        КонецЦикла;
   knopik777
 
4 - 25.06.18 - 09:57
(1) Спасибо, а примерчика нет случаем?
(3) Спасибо, думаю может IP прописывать, проще будет. Вот только где взять пример :)


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует