Вход | Регистрация

1С:Предприятие ::

Метки: 

Приходный ордер на товары "Перемещение"

Я
   frcjocker
 
23.06.18 - 17:21
Создаю приходный ордер на товары. Операции. Перемещение. Выбираю перемещение, склад, дату позже расходного ордера.
Кнопка "Заполнить" выдает варианты "... по заказу поставщика" "... по счету поставщика"
Где это исправить?
 
 
   shuhard
 
1 - 23.06.18 - 17:26
(0)[Где это исправить?]
кроме конфигуратора ни где
   frcjocker
 
2 - 23.06.18 - 17:31
(1) ммм, окей. Вы имеете ввиду эту часть кода?

Процедура ОбработкаЗаполнения(Основание)

    Если ТипЗнч(Основание) = Тип("ДокументСсылка.ЗаказПоставщику")
     ИЛИ ТипЗнч(Основание) = Тип("ДокументСсылка.СчетНаОплатуПоставщика")Тогда

        // Заполним реквизиты из стандартного набора.

        ЗаполнениеДокументов.ЗаполнитьШапкуДокументаПоОснованию(ЭтотОбъект, Основание);

        ВидОперации = Перечисления.ВидыОперацийПриходныйОрдер.ОтПоставщика;

        // Заполним табличную часть "Товары" по заказу или счету поставщика, скопировав состав.

        ЗаполнитьТоварыПоОснованию(Основание);
        ЗаполнитьВозвратнуюТаруПоОснованию(Основание);

    ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
    
        // Заполним реквизиты из стандартного набора.

        ЗаполнениеДокументов.ЗаполнитьШапкуДокументаПоОснованию(ЭтотОбъект, Основание);

        ВидОперации = Перечисления.ВидыОперацийПриходныйОрдер.ОтПокупателя;

        // Заполним табличную часть "Товары" по реализации, скопировав состав.

        ЗаполнитьТоварыПоОснованию(Основание);
        ЗаполнитьВозвратнуюТаруПоОснованию(Основание);

    ИначеЕсли ТипЗнч(Основание) = Тип("ДокументСсылка.ПеремещениеТоваров") Тогда
    
        // Заполним реквизиты из стандартного набора.

        ЗаполнениеДокументов.ЗаполнитьШапкуДокументаПоОснованию(ЭтотОбъект, Основание);

        ВидОперации         = Перечисления.ВидыОперацийПриходныйОрдер.Перемещение;
        Склад               = Основание.СкладПолучатель;
        ДокументПеремещения = Основание.Ссылка;

        // Заполним табличную часть "Товары" по реализации, скопировав состав.

        ЗаполнитьТоварыПоОснованию(Основание);
        ЗаполнитьВозвратнуюТаруПоОснованию(Основание);

    КонецЕсли;

КонецПроцедуры// ОбработкаЗаполнения()
   frcjocker
 
3 - 23.06.18 - 17:44
(1) Нашел процедуру заполнения кнопки "Заполнить"
Процедура УстановитьКнопкиПодменюЗаполненияТЧ()
    
    мКнопкиЗаполненияТЧ = УниверсальныеМеханизмы.ПолучитьДеревоКнопокЗаполненияТабличныхЧастей(Ссылка, Новый Действие("НажатиеНаДополнительнуюКнопкуЗаполненияТЧ"));

    СоответствиеТЧ = Новый Соответствие;
    СоответствиеТЧ.Вставить(ЭлементыФормы.Товары, ЭлементыФормы.КоманднаяПанельТовары.Кнопки.ПодменюЗаполнить);
    СоответствиеТЧ.Вставить(ЭлементыФормы.ВозвратнаяТара, ЭлементыФормы.КоманднаяПанельВозвратнаяТара.Кнопки.ПодменюЗаполнить);
    
    УниверсальныеМеханизмы.СформироватьПодменюЗаполненияТЧ(мКнопкиЗаполненияТЧ, СоответствиеТЧ);
    
КонецПроцедуры
   frcjocker
 
4 - 23.06.18 - 18:23
процедура ПодменюЗаполнить не срабатывает после нажатия "Операции" и вообще никак не обновляется, даже при начальном типе документа "перемещение".

Есть такая процедура 

Процедура НажатиеНаДополнительнуюКнопкуЗаполненияТЧ(Кнопка)
    
    УниверсальныеМеханизмы.ОбработатьНажатиеНаДополнительнуюКнопкуЗаполненияТЧ(мКнопкиЗаполненияТЧ.Строки.Найти(Кнопка.Имя,"Имя",Истина),ЭтотОбъект);
    
КонецПроцедуры
   frcjocker
 
5 - 23.06.18 - 18:40
внешние обработки заполнения табличных частей - нет ни одной
   frcjocker
 
6 - 24.06.18 - 14:35
ап, как решить?
   Галахад
 
7 - 24.06.18 - 14:38
Что-то не понял. А в "Перемещении" ввод на основании не работает?
   frcjocker
 
8 - 25.06.18 - 04:10
(7) Спасибо!) Таким образом сработало)


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует