Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Печатный документ для Управляемого приложения

Печатный документ для Управляемого приложения
Я
   yliya_1C
 
22.06.18 - 14:22
Добрый день!
Нужно чтобы по кнопке Печать в журнале документов формировалась печатная форма. И фокус был на последней строке табличного документа.
Не получается с этим фокусом. подскажите, пожалуйста..
Если обычной внешней обработкой пробовать, то работает.
А когда встраиваю через сервис внешних обработок, то не работает(((
Вот код

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ВедомостиНаВыплатуЗарплаты", "Список ведомостей в банк", СформироватьПечатнуюФорму(ОбъектыПечати));

КонецПроцедуры// Печать()


Функция СформироватьПечатнуюФорму(ОбъектыПечати)

    ТабДок = Новый ТабличныйДокумент;    

    Макет = ПолучитьМакет("Макет");    
    
    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("Шапка");
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");
    
    ТабДок.Очистить();

    
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    
    
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    СУММА(ВедомостьНаВыплатуЗарплатыВБанкНДФЛ.Сумма) КАК Сумма,
                   |    ВедомостьНаВыплатуЗарплатыВБанкНДФЛ.Ссылка КАК Ссылка
                   |ПОМЕСТИТЬ ВТ
                   |ИЗ
                   |    Документ.ВедомостьНаВыплатуЗарплатыВБанк.НДФЛ КАК ВедомостьНаВыплатуЗарплатыВБанкНДФЛ
                   |
                   |СГРУППИРОВАТЬ ПО
                   |    ВедомостьНаВыплатуЗарплатыВБанкНДФЛ.Ссылка
                   |;
                   |
                   ////////////////////////////////////////////////////////////////////////////////

                   |ВЫБРАТЬ
                   |    ВТ.Сумма КАК НДФЛ,
                   |    ВедомостьНаВыплатуЗарплатыВБанк.Ссылка КАК Документ,
                   |    ВедомостьНаВыплатуЗарплатыВБанк.Номер КАК Номер,
                   |    ВедомостьНаВыплатуЗарплатыВБанк.Дата КАК Дата,
                   |    ВедомостьНаВыплатуЗарплатыВБанк.Подразделение КАК Подразделение,
                   |    ВедомостьНаВыплатуЗарплатыВБанк.ПериодРегистрации КАК ПериодРегистрации,
                   |    ВедомостьНаВыплатуЗарплатыВБанк.Ответственный КАК Ответственный,
                   |    ВедомостьНаВыплатуЗарплатыВБанк.СуммаПоДокументу КАК Сумма,
                   |    ВедомостьНаВыплатуЗарплатыВБанк.СпособВыплаты КАК Выплата
                   |ИЗ
                   |    Документ.ВедомостьНаВыплатуЗарплатыВБанк КАК ВедомостьНаВыплатуЗарплатыВБанк
                   |        ЛЕВОЕ СОЕДИНЕНИЕ ВТ КАК ВТ
                   |        ПО (ВТ.Ссылка = ВедомостьНаВыплатуЗарплатыВБанк.Ссылка)
                   |
                   |УПОРЯДОЧИТЬ ПО
                   |    Дата";    
        
    
    Выборка = Запрос.Выполнить().Выбрать();

    Пока Выборка.Следующий() Цикл
        ОбластьДетальныхЗаписей.Параметры.Заполнить(Выборка);
        ОбластьТекущейСтроки = ТабДок.Вывести(ОбластьДетальныхЗаписей);
    КонецЦикла;    
    
    Горизонталь=ОбластьТекущейСтроки.Верх;
    ТабДок.Область(Горизонталь,2,Горизонталь,3);
    ТабДок.ТекущаяОбласть = ТабДок.Область(Горизонталь,2,Горизонталь,3);;
    
    Возврат ТабДок;

КонецФункции
 
 
   Cyberhawk
 
1 - 22.06.18 - 14:24
Фокус-покус?
   yliya_1C
 
2 - 22.06.18 - 14:33
(1) переместиться на нужную ячейку.., активизировать нужную  ячейку, встать на нужную строку.
Не знаю как правильно написать чтобы было понятно
   Cyberhawk
 
3 - 22.06.18 - 14:37
Так печатная форма-то (табдок) открывается пади в БСПшной форме

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует