Вход | Регистрация

1С:Предприятие ::

Метки: 

Цикл не удаляет строки, в чем проблема?

Я
   SkillUp
 
21.06.18 - 18:33
Код:

        ТЧ = ДокЗакрЗаявки.ЗаявкиНаРасходованиеСредств;
        Сумма =  Источник.СуммаДокумента;
        ПроверкаЧисло = 1;
        Для Каждого СтрТЧ ИЗ ТЧ Цикл
            Если ПроверкаЧисло <= 0 ТОгда
                ТЧ.Удалить(СтрТЧ);
            Иначе 
                Если Сумма < СтрТЧ.ОстатокЗаявка Тогда
                    СуммаСписания = Сумма;
                КонецЕсли;    
                Сумма = Сумма - СтрТЧ.ОстатокЗаявка;
                ПроверкаЧисло = Сумма;
                Если Сумма = 0 Тогда
                    ПроверкаЧисло = 0;                
                ИначеЕсли Сумма < 0 тогда
                    СтрТЧ.ОстатокЗаявка   = СуммаСписания;
                    ПроверочноеЧисло      = Сумма; 
                КонецЕсли;
            КонецЕсли;    
        КонецЦикла;
 
  Рекламное место пустует
   SkillUp
 
1 - 21.06.18 - 18:34
ТЧ.Удалить(СтрТЧ);  Почему не срабатывает?
   Aleksandr N
 
2 - 21.06.18 - 18:38
(0) Это нужно не сюда выкладывать, а сюда: http://govnokod.ru/
   lubitelxml
 
3 - 21.06.18 - 18:40
погугли как удалить строки из ТЧ, все поймешь
   lodger
 
4 - 21.06.18 - 18:43
(0) надо ПроверкаЧисло и ПроверочноеЧисло назвать одинаково.
   SkillUp
 
5 - 21.06.18 - 18:44
(4)ТОчно!
   SkillUp
 
6 - 21.06.18 - 18:44
(3) Погуглил понял, понял в чем проблема. Пардон за беспокойство...
   Tankur
 
7 - 21.06.18 - 19:47
в гугл отпрпавлять это хорошо, но пока не научится синтакспомощником пользоватся - не будет нормального спеца.


Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует