Вход | Регистрация

1С:Предприятие ::

Метки: 

Сдельный наряд и Дата Запрета

↓ [Serg_1960, 21.06.18 - 13:46]
Я
   MAPATNK2
 
21.06.18 - 12:30
Добрый день. Установлена дата запрета 19.06.18 пытаюсь на основании зааза на производство от 15.05.2018 создать сдельный наряд 21.06.2018. Т.е. по факту дата создающегося документа за пределами даты запрета, все нормально, при проведении, выдает ошибку: #Редактирование данных этого периода запрещено. Изменения не могут быть записаны...#.
Залез в подписку на событие и отключил Сдельный наряд и заказ на производство из проверки на дату запрета. Теперь при проведении выдает то же самое "Редактирование данных этого периода запрещено. Изменения не могут быть записаны..." но с новой ошибкой "Не удалось записать: "Фактическая выработка сотрудников"" не нашел такого регистра или документа или справочника, вообще в конфе такого нет, есть похожие, но они не участвуют в проверке даты. Черт, подскажите что делать? Вроде ничего криминального не делаю, пытаюсь сегодняшним числом создать сдельный наряд и ничего не выходит. (Конфа не тронута, установлена только дата запрета) 1С Управление производственным предприятием, редакция 1.3 (1.3.99.1)
 
  Рекламное место пустует
   hhhh
 
1 - 21.06.18 - 12:40
(0) всегда был такой регистр "Фактическая выработка сотрудников", непонятно как вы смотрите, может взгляд замутненный.
   MAPATNK2
 
2 - 21.06.18 - 12:44
ФактическаяВыработкаРаботников есть, ФактическаяВыработкаРаботниковОрганизаций есть, а "Фактическая выработка сотрудников" НЕТ!. Первые два вообще не участвуют в проверке на дату запрета.
   Гипервизор
 
3 - 21.06.18 - 12:46
(2) "Фактическая выработка сотрудников" это синоним у регистра ФактическаяВыработкаРаботников ))
   Serg_1960
 
4 - 21.06.18 - 12:46
Имя: "ФактическаяВыработкаРаботников", синоним: "Фактическая выработка сотрудников"

Это даже как-то не смешно.
   MAPATNK2
 
5 - 21.06.18 - 12:48
(4) (3) Они не участвуют в проверке
   Гипервизор
 
6 - 21.06.18 - 12:51
(4) А после регистра РаботникиОрганизаций с шикарным синонимом "Кадровая история сотрудников (по юрлицам)" уже ничего не смешно))
(5) Это другое дело, я лишь указал почему вы не смогли найти.
   Serg_1960
 
7 - 21.06.18 - 13:03
(5) "Залез в подписку на событие и отключил Сдельный наряд и заказ на производство из проверки на дату запрета." - для документов и их движений  - автономные и независимые друг от друга проверки. Смотри в ПодпискаНаСобытие.ПередЗаписьюРегистраНакопленияДатаЗапретаРедактирования.Источник
   Serg_1960
 
8 - 21.06.18 - 13:07
Контрольный :)

Процедура ПередЗаписьюРегистраНакопленийПроверкаДоступностиПериода(Источник, Отказ, Замещение) Экспорт
    
    Если Отказ ИЛИ Источник.ОбменДанными.Загрузка Тогда
        Возврат;
    КонецЕсли;
    
    ПроверкаПериодаЗаписейРегистров(Источник, Отказ, "РегистрНакопления");    
    #Если НЕ ВнешнееСоединение Тогда

        Если Отказ Тогда
            Сообщить("Редактирование данных этого периода запрещено. Изменения не могут быть записаны...", СтатусСообщения.Важное);
        КонецЕсли;
    #КонецЕсли

КонецПроцедуры// ПередЗаписьюРегистраНакопленийПроверкаДоступностиПериода
   MAPATNK2
 
9 - 21.06.18 - 13:16
(7) (8) все это не то. Нужно было во время записи регистра в модуле документа проставить ОбменДанными.Загрузка = истина;

РЕГИСТРЫ ЭТИ НЕ УЧАСТВУЮТ В ПРОВЕРКЕ НА ДАТУ УЖЕ ВЫШЕ ПИСАЛ)) ВСЕМ СПАСИБО.
   Buster007
 
10 - 21.06.18 - 13:19
(9) "Нужно было во время записи регистра в модуле документа проставить ОбменДанными.Загрузка = истина; "
Гений! Продолжай в том же духе!
 
  Рекламное место пустует
   Serg_1960
 
11 - 21.06.18 - 13:20
(9) Отнять клавиатуру, работу с конфигурацией и назад, в школу, срочно!
   hhhh
 
12 - 21.06.18 - 13:21
(9) да, ты вообще выключил запись в регистры. Чудесишь.
   Serg_1960
 
13 - 21.06.18 - 13:25
(12) Конфигурация УПП, к сожалению, такое безобразие допускает. Провести документ - нельзя, а записать регистры движения - да без проблем. Недосмотр методистов.
   Гипервизор
 
14 - 21.06.18 - 13:37
(9) В типовой УПП участвуют. Вы писали, что у вас типовая. Так что путаетесь в показаниях.
ОбменДанными - чотко! Жаль в 1С нет sudo.
   Serg_1960
 
15 - 21.06.18 - 13:45
(14) Она была типовая, пока не попала в его руки. Не мешайте - автор идёт своим путём :)

Я автору даже место показал, где его сообщение формируется - а в ответ "Не верю!"(Фома неверующий)


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует