Вход | Регистрация


1С:Предприятие ::

Метки: 

Заполнить поле Характеристика при Номенклатуре, не использующей ее.

Я
   Ru125
 
20.06.18 - 22:56
Есть Розница 2.2 делаю обработки для загрузки номенклатуры (нужно прикрутить справочник номенклатуры поставщика).
После попадания в таблицу не понимаю как сделать, чтобы для номенклатуры, не использующей характеристик, не подчеркивалось пустое поле или лучше была надпись как в стандартных документах <характеристики не используются>. Контроль заполнения для номенклатуры содержащей характеристики нужен.
 
  Рекламное место пустует
   breezee
 
1 - 21.06.18 - 03:13
Там же есть галка "использоватьХарактиеристики" или какая-то подобноая гллка в номенклатуре
   Chameleon1980
 
2 - 21.06.18 - 04:45
(1) блин. он жеж и пишет, что как сделать если галка не стоит.
а вообще не понятно.
обработка твоя?
ну сними у реквизита обязательность заполнения или я чего не понял.
   Chameleon1980
 
3 - 21.06.18 - 04:46
галку для реквизита уберай и проверяй программно для только для номенклатуры имеющей признак использования хар-к
   Ru125
 
4 - 21.06.18 - 10:47
Да моя обработка. Вся суть проблемы, что я не понимаю как вписать в поле с типом характеристка номенклатуры что-то не являющееся этим типом. Попытался отследить как это делается в стандартных документах - не понял.  А подчеркивание нужно оставит или если бы хотя бы можно было изменить форматирование конкретной ячейки (цвет шрифта) - меня бы это устроило.
   Ru125
 
5 - 21.06.18 - 12:10
я не знаю как проверять (аналогично штатному) программно
   Гипервизор
 
6 - 21.06.18 - 12:26
(0) Не знаю как реализовано в Рознице, но у поля формы есть такое свойство ПодсказкаВвода. Как раз для вашей задачи.
   maximkasuper
 
7 - 21.06.18 - 12:31
(4) Используйте условное оформление (Текст, ЦветТекста, ТолькоПросмотр, ОтметкаНезаполненного)
   Гипервизор
 
8 - 21.06.18 - 12:41
(4) Простой поиск по конфигурации показывает что так это и реализовано как в (7). Смотрите условное оформление формы.
Уж как вы так искали непонятно.
   Ru125
 
9 - 21.06.18 - 13:57
(6) (8) Как в (7) насколько я понял невозможно применить к конкретным ячейкам столбцу. Только ко всему столбцу. Видимо тоже самое с ПодсказкаВвода.

При таком обходе таблицы:

Для каждого Строка из Объект.Таблица Цикл
         Строка.Характеристика.ЦветТекста = WebЦвета.Красный;
    КонецЦикла;

не находит поле.

{ВнешняяОбработка.ЗагрузкаНакладных.Форма.Форма.Форма(283)}: Поле объекта не обнаружено (ЦветТекста)
         Строка.Характеристика.ЦветТекста = WebЦвета.Красный;
   Buster007
 
10 - 21.06.18 - 14:05
надо добавлять строки с использованием всех обработчиков, которые прописаны в конфигурации после добавления строки, тогда таких вопросов у тебя не будет возникать
 
 
   hhhh
 
11 - 21.06.18 - 14:42
(9) ЦветТекста должен быть у элмента формы, а прям в данные базы фигачите.
   Ru125
 
12 - 21.06.18 - 15:12
(11)
При обращении к таблице тоже нет такого поля.
Для каждого Строка из ТабЗнач    Цикл
        
        Строка.Характеристика.ЦветТекста = WebЦвета.Красный;
                  
    КонецЦикла;
   Ru125
 
13 - 21.06.18 - 15:16
(10) Я пытался подключить все обработчики строк на примере других документов. Добился, чтобы характеристики были только те, которые имеет конкретная номенклатура:

&НаКлиенте
Процедура ТаблицаХарактеристикаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    
    ОбработкаТабличнойЧастиТоварыКлиент.ВыбратьХарактеристикуНоменклатуры(ЭтотОбъект, Элемент, СтандартнаяОбработка, Элементы.Таблица.ТекущиеДанные);
    
    //ТекущаяСтрока = Элементы.Таблица.ТекущиеДанные;

    //СтруктураДействий = Новый Структура;

     //СтруктураДействий.Вставить("ПроверитьХарактеристикуПоВладельцу"   , ТекущаяСтрока.Характеристика);

    
    //ПроверитьКорректностьЗаполнитьХарактеристики(ТекущаяСтрока, СтруктураДействий, КэшированныеЗначения)

    
КонецПроцедуры

Те, что закомментированы, они как бы и обрабатывают на предмет остального. Но не работает так. Да и вообще хотелось бы понять - неужели нельзя изменить форматирование отдельно взятой ячейки в таблице значений. Если кто-то знает, киньте какой-либо пример.
   hhhh
 
14 - 21.06.18 - 15:21
(12) вы к данным обращаетесь. а надо к элементам формы.
   Гипервизор
 
15 - 21.06.18 - 15:26
(9) А чем не подошло условное оформление колонки? Почему нужно именно для ячейки?
   Ru125
 
16 - 21.06.18 - 15:27
(14) Сразу скажу я не профессионал, работаю исключительно на благо личной фирмы. Так что многое могу не понимать. То есть я должен каким-то образом обращаться к ячейке, а не ее содержимому? Если так, что как это сделать?
   Ru125
 
17 - 21.06.18 - 15:28
(15) Нельзя менять оформление всей колонки, так как в колонке "Характеристика" будут содержаться ячейки и с характеристиками и без. То есть не все ячейки в колонки будут одинаковые. Если я правильно понял вопрос.
   Гипервизор
 
18 - 21.06.18 - 15:34
(17) Так реализовано в Рознице. Т.е. вы считаете что в Рознице условное оформление работает ошибочно, если в одном документе есть номенклатура с характеристиками и  без?
Вы вообще понимаете что такое УСЛОВНОЕ оформление?
   Ru125
 
19 - 21.06.18 - 15:42
(18) Я как-то не обратил внимание на УСЛОВНОЕ. Но я такое не видел.
   Гипервизор
 
20 - 21.06.18 - 15:42
   Ru125
 
21 - 21.06.18 - 15:47
(20) Это из какого места вход в такое меню? Я посмотрел везде, не вижу такое!!
   Ru125
 
22 - 21.06.18 - 15:48
(20) увидел, надо было фильтр убрать. Спасибо.
   Гипервизор
 
23 - 21.06.18 - 15:51
(22) В самом названии суть - оформление по какому-то условию. На здоровье)
   Ru125
 
24 - 21.06.18 - 15:55
(23) а эта ваша картинка - форма из какого документа?
   Гипервизор
 
25 - 21.06.18 - 16:01
(24) Конкретно эта из Чека ККМ. Но условное оформление в любой форме есть, конечно, если мы про Розницу 2.2.



Список тем форума
Рекламное место пустует   Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует