Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Запрет на просмотр движений документа

v7: Запрет на просмотр движений документа
Я
   Pit0n_08
 
20.06.18 - 13:49
Если кто помнит? Есть ли возможность закрыть пользователям просмотр движений документа в общем журнале?(ПКМ на документе - Движения документа)
 
 
   Вася Теркин
 
1 - 20.06.18 - 13:52
В форме сделай запрет
   Pit0n_08
 
2 - 20.06.18 - 13:56
(1) ПриОткрытии запрет поставил, только смысл в нём, если толковый юзверь нужную информацию вытянет из движения документа - ту же фамилию и сумму з/п соседа.
   Pit0n_08
 
3 - 20.06.18 - 13:59
(+0) Речь идет о самописке на базе ТиС.
   Kigo_Kigo
 
4 - 20.06.18 - 14:04
Процедура ПриОткрытии() 
    Форма.ТолькоПросмотр(1);
КонецПроцедуры

но он там практически все блочит
   Strogg
 
5 - 20.06.18 - 14:07
(4) автор говорит о контекстном меню "просмотр движений документа" на форме списка. Это реализовано средствами платформы, имхо. И убрать оттуда прям хз как....
   Pit0n_08
 
6 - 20.06.18 - 14:09
(4) прописал круче...
Процедура ПриОткрытии() 
    Если Запрет=1 Тогда
        СтатусВозврата(0);
        Возврат;
КонецПроцедуры
   Djelf
 
7 - 20.06.18 - 14:15
(5) Как так не убрать?
Движения это Регистр. А у регистра можно снять право на просмотр.
   Kigo_Kigo
 
8 - 20.06.18 - 14:15
(5) Это в форме журнала, тогда просмотр движений блочится
   Kigo_Kigo
 
9 - 20.06.18 - 14:16
(8) + Ссори , проверил, не блокируется
   Strogg
 
10 - 20.06.18 - 14:26
(7) Это если пользователю запрещена работа с документом вообще. Там же тока чтение в семерке.
А у автора задача - закрыть движения документов в общем журнале. Это считай всё.
 
 Рекламное место пустует
   Kigo_Kigo
 
11 - 20.06.18 - 14:27
(10) Либо использовать не стандартные журналы
   NSSerg
 
12 - 20.06.18 - 14:28
(10) Регистр, ПКМ, чтение - снял галку.
   NSSerg
 
13 - 20.06.18 - 14:28
(10) При чем тут документ?
   Strogg
 
14 - 20.06.18 - 14:30
(13) если документ проводишь - чтение регистра для записи в него движений необязательно что ли? Ну, если нет, значит все норм. надо только галку чтение снять и всё заведется.
   Pit0n_08
 
15 - 20.06.18 - 14:32
(7) Это работает. Всем Спасибо!
   NSSerg
 
16 - 20.06.18 - 16:29
(14) Эта галка как раз на просмотр движений в журнале либо из документа через системное меню действия. Больше ни для чего.
   Злопчинский
 
17 - 20.06.18 - 19:18
(14) угу...
"Ошибка чтения при записи"...
   AliAksA
 
18 - 21.06.18 - 07:56
(0) Ну наверное не совсем то, но как вариант:

В глобальнике:
Перем глЗапрет Экспорт;
глЗапрет = 0;

В форме списка общего журнала:
//************************************************************************************************************

Процедура ПриОткрытии()
    
    глЗапрет = 1;
    
КонецПроцедуры// ПриОткрытии()

//************************************************************************************************************
Процедура ПриЗакрытии()
    
    глЗапрет = 0;
    
КонецПроцедуры// ПриЗакрытии()

//************************************************************************************************************

в форме списков журналов проводок и операций:
//************************************************************************************************************

Процедура ПриОткрытии()
    
    Если глЗапрет = 1 Тогда
        СтатусВозврата(0);
        Возврат;
    КонецЕсли;
    
КонецПроцедуры// ПриОткрытии()

//************************************************************************************************************

Ну и тогда пока открыт общий журнал документов - ни проводок, ни операций никто не увидит

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует