Вход | Регистрация


Добавление строк в ТЧ документа

Добавление строк в ТЧ документа
Я
   21stas
 
19.06.18 - 19:38
Добавляю строки в табличную часть "ТаблицаДокумента" документа из его формы:

&НаСервере
Процедура ЗаполнениеТЧ()
Для Каждого СтрокаМассиваАбонентов из Абоненты Цикл
  СтрочкаТЧ = Объект.ТаблицаДокумента.Добавить();
  СтрочкаТЧ.Абонент = СтрокаМассиваАбонентов;    
КонецЦикла;
ЭтаФорма.Элементы.ТаблицаДокумента.Обновить();
КонецПроцедуры

В отладчике смотрю - в цикл заходит.
Но на экране строки не прибавляются.
 
 
   Мандалай
 
1 - 19.06.18 - 19:44
У самой формы нет метода обновления данных?
   21stas
 
2 - 19.06.18 - 19:49
   catena
 
3 - 20.06.18 - 07:36
В форме должно вообще без доп.телодвижений работать. У меня работает:

&НаСервере
Процедура ДобавитьВТЧНаСервере()
    
    СтрочкаТЧ = Объект.ТабличнаяЧасть1.Добавить();
    СтрочкаТЧ.Ссылка1 = "ыва";    
    
КонецПроцедуры
   Мандалай
 
4 - 20.06.18 - 08:47
(0)У тебя на форме точно ТаблицаДокумента? Может у тебя какой-нибудь хитрый источник данных?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует