Вход | Регистрация


1С:Предприятие ::

Метки: 

Расширение конфы (своя кнопка на форме)

Я
   lirt82
 
19.06.18 - 14:28
создал свое расширение, добавил в него док РеализацияТМЗУслуг, т.е. весь объект, в расширении на форме добавил свою кнопку "Округлить" пришлось всю форму передавать на сервер. Написал простейший код
&НаКлиенте
Процедура Расш1_ОкруглитьПосле(Команда)
    Расш1_ОкруглитьПослеНаСервере();
КонецПроцедуры

&НаСервере
Процедура Расш1_ОкруглитьПослеНаСервере()
    
    Для каждого Стр Из Объект.Товары Цикл
        ОкругляемаяСтрока = Окр(Стр.СуммаНДС) 
    КонецЦикла; 
    А = Объект.Записать();
    
КонецПроцедуры

выдал ошибку 
{Тестовое Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(13)}: Метод объекта не обнаружен (Записать)
    А = Объект.Записать();

1) нужно передать только таб часть Товары, как это сделать? если возможно без всей формы
2) как изменения на сервере отобразить на клиенте? отладчик округляет а на форме старое значение
 
 
   segn
 
1 - 19.06.18 - 14:36
Весь код можно выполнить на клиенте. См. расширение формы для объектов Записать().
   lirt82
 
2 - 19.06.18 - 14:43
(1) сделал так все равно отладчик меняет а на форме старый результат
&НаКлиенте
Процедура Расш1_ОкруглитьПосле(Команда)
    
    Для каждого Стр Из Объект.Товары Цикл
        ОкругляемаяСтрока = Окр(Стр.СуммаНДС) 
    КонецЦикла; 
    
КонецПроцедуры
   FIXXXL
 
3 - 19.06.18 - 14:45
(2) ну а что ты хочешь?
ты в цикле присваиваешь значение переменной "ОкругляемаяСтрока"
   lirt82
 
4 - 19.06.18 - 14:47
(3) как изменения на сервере отобразить на клиенте? отладчик округляет а на форме старое значение
   lirt82
 
5 - 19.06.18 - 14:48
(4) 2) как изменения отобразить на форме? отладчик округляет а на форме старое значение
   Мандалай
 
6 - 19.06.18 - 14:49
А я вот не понял:
    А = Объект.Записать();
нафига тут присвоение?
Может просто:
    Объект.Записать();
?
   Мандалай
 
7 - 19.06.18 - 14:50
И глянь в отладчике что такое Объект, может это у тебя форма.
   FIXXXL
 
8 - 19.06.18 - 14:53
(4) еще раз:
ты не обновляешь данные формы

попробуй
вместо
ОкругляемаяСтрока = Окр(Стр.СуммаНДС)
написать в цикле
Стр.СуммаНДС = Окр(Стр.СуммаНДС)
   lirt82
 
9 - 19.06.18 - 14:54
(7) &НаКлиенте 
Процедура Расш1_ОкруглитьПосле(Команда)
    
    Для каждого Стр Из Объект.Товары Цикл
        ОкругляемаяСтрока = Окр(Стр.СуммаНДС) 
    КонецЦикла; 
    Объект.Записать();
    
КонецПроцедуры

{Тестовое Документ.РеализацияТоваровУслуг.Форма.ФормаДокумента.Форма(8)}: Метод объекта не обнаружен (Записать)
    Объект.Записать();

Объект ДанныеФормыСтруктура
   Мандалай
 
10 - 19.06.18 - 14:55
Ну так у данных формы структура нет метода записать.
попробуй вообще убрать слово Объект.
 
 
   Мандалай
 
11 - 19.06.18 - 14:55
Отовсюду
   lirt82
 
12 - 19.06.18 - 14:55
(8) СПАСИБО допетрил)) заработал код

&НаКлиенте 
Процедура Расш1_ОкруглитьПосле(Команда)
    
    Для каждого Стр Из Объект.Товары Цикл
        Стр.СуммаНДС = Окр(Стр.СуммаНДС); 
    КонецЦикла;
    
КонецПроцедуры
   Мандалай
 
13 - 19.06.18 - 14:55
но выполняй на сервере
   FIXXXL
 
14 - 19.06.18 - 14:56
(9) забей ты пока на Записать()
один хрен данные твоя процедура не изменяет
   FIXXXL
 
15 - 19.06.18 - 14:56
(12) :)
   FIXXXL
 
16 - 19.06.18 - 14:57
(11) +1
пиши просто Записать()
   lirt82
 
17 - 19.06.18 - 15:01
(13) (14) (15) (16) вот наконецто сохраняет измененные данные:) всем еще раз спасибо, вообще расширения тема!
&НаКлиенте
Процедура Расш1_ОкруглитьПосле(Команда)
    
    Для каждого Стр Из Объект.Товары Цикл
        Стр.СуммаНДС = Окр(Стр.СуммаНДС); 
    КонецЦикла;
    Записать();
    
КонецПроцедуры
   lirt82
 
18 - 19.06.18 - 15:03
вопрос:
в ERP добавили Рарусовское "1С:Предприятие 8. Управление Автотранспортом" все на замках и модули под защитой. Можно ли в расширении дорабатывать? Управление Автотранспортом:)
   lirt82
 
19 - 19.06.18 - 15:05
..по идее команда "Добавить в расширение..." неактивна на Управление Автотранспортом
   segn
 
20 - 19.06.18 - 15:08
(17) Мы берем вас на работу в отдел гениальных разработок. Приходите с документами по адресу Москва, ул.Селезневская, д.21.
С уважением Нуралиев Б.Г.
   lirt82
 
21 - 19.06.18 - 15:10
(20) все я понял твой намек:)
   lirt82
 
22 - 19.06.18 - 15:14
(18) Структура данных не поддерживает хранение расширений. Необходимо отключить режим совместимости.
   lirt82
 
23 - 19.06.18 - 15:15
если отключим тогда перестанет работать:)
   lirt82
 
24 - 19.06.18 - 15:19
на меня просветление снизошло))) теперь я понял что значит "Продукт "ХХХХХ" фирмы "ХХХХХ" получил сертификат "Совместимо! Система программ 1С:Предприятие"".
   Мандалай
 
25 - 19.06.18 - 15:44
(22)Необходимо отключить режим совместимости - это да, надо
Почему перестанет работать?
(21)На Сервере
(24)На нас пока нет, делись просвещением.



Список тем форума
Рекламное место пустует  
Прочитай, хотя бы, Митичкина "Разработка в системе 1С:Предприятие 8". Волшебник
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует