Вход | Регистрация

1С:Предприятие ::

Метки: 

ВыполнитьПакет() заполняем дерево значений 1С УФ

Я
   skupidom
 
19.06.18 - 11:43
Бухгалтерия предприятия, редакция 3.0 (3.0.61.47)
Выполняю пакет запроса состоящий из 2 не связанных запросов.Как результатами заполнить дерево значений ?
 
  Рекламное место пустует
   Cyberhawk
 
1 - 19.06.18 - 11:43
Нужно применить волевое усилие
   Cyberhawk
 
2 - 19.06.18 - 11:43
Предварительно почитать СП
   Cyberhawk
 
3 - 19.06.18 - 11:46
(по методу из заголовка ветки)
   skupidom
 
4 - 19.06.18 - 11:47
ВыборкаЗатрата = ЗапросОборотыЗатрат.ВыполнитьПакет();
ВыборкаНДСРаздельныйУчет = ВыборкаЗатрата[0].Выбрать();
Если ВыборкаНДСРаздельныйУчет.Следующий() Тогда
Пока ВыборкаНДСРаздельныйУчет.Следующий() Цикл    
КонецЦикла;            
КонецЕсли;
ВыборкаХозрасчетныйОстатки = ВыборкаЗатрата[0].Выбрать();
Если ВыборкаХозрасчетныйОстатки.Следующий() Тогда
Пока ВыборкаНДСРаздельныйУчет.Следующий() Цикл        
КонецЦикла;
КонецЕсли;
   Cyberhawk
 
5 - 19.06.18 - 11:48
Поспешишь - людей насмешишь
   skupidom
 
6 - 19.06.18 - 11:48
при таком варианте не получиться заполнить,тк нужные реквизиты для заполнения каждой строки находятся в обоих запросах
   Cyberhawk
 
7 - 19.06.18 - 11:50
Без мягкого знака


Список тем форума
Рекламное место пустует  
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует