Вход | Регистрация


1С:Предприятие ::

Метки: 

Продолжение, после программного заполнения ТЧ документа, надо его обновить с нов. данными

Я
   SkillUp
 
19.06.18 - 08:55
Код:

        НашОбъект = Выборка[0].ссылка.ПолучитьОбъект();
        НашОбъект.Наименование = Наимаенование;
        НашОбъект.Расписание   = Расписание;
        //Заполнение табличных частей.

        НашОбъект.ТЧ.Очистить();
        СтрокаТабличнойЧасти = НашОбъект.ТЧ.Добавить();
        Для Счетчик = 1 По 12 Цикл
             НашОбъект.ТЧ.Добавить();
        КонецЦикла;    
        НашОбъект.ТЧ.ЗагрузитьКолонку(Расписание.Месяцы,"Месяцы"); 
        НашОбъект.ТЧ.ЗагрузитьКолонку(Расписание.ДниНедели,"ДниНедели"); 
        СтрокаТабличнойЧасти.ДеньВМесяце = Расписание.ДеньВМесяце;        
        НашОбъект.Записать();

Не мой сегодня день ,увы... ((
 
 
   SkillUp
 
1 - 19.06.18 - 08:56
После программного заполнения, ТЧ со страыми данными, как обновить документ?
   _Дайвер_
 
2 - 19.06.18 - 08:59
Прочитать()
   SkillUp
 
3 - 19.06.18 - 09:02
(2) НашОбъект.Прочитать() Так?
   SkillUp
 
4 - 19.06.18 - 09:03
Или надо форму получить?
   SkillUp
 
5 - 19.06.18 - 09:03
То просто, уже столько всего перепробовал...
   alkorolev
 
6 - 19.06.18 - 09:04
ЗначениеВРеквизитФормы(ДокументОбъект, "Объект")
   alkorolev
 
7 - 19.06.18 - 09:05
Прочитать() перечитает существующий объект БД. Не учтет внесенные незаписанные изменения
   SkillUp
 
8 - 19.06.18 - 09:06
(7) Ура! хоть один человек со здр....
   SkillUp
 
9 - 19.06.18 - 09:06
мыслями...
   SkillUp
 
10 - 19.06.18 - 09:06
Прочитать() -не работает, этот метод! Как быть?
 
 
   _Дайвер_
 
11 - 19.06.18 - 09:07
(7) У него после заполнения запись идет, так что пойдет
(8) ФЙорму нужно прочитать, СП в помощь
   SkillUp
 
12 - 19.06.18 - 09:08
Есть еще варианты?
   SkillUp
 
13 - 19.06.18 - 09:08
(11) Хорошо, я стобой соглашусь, если пример напишешь и он заработает!
   SkillUp
 
14 - 19.06.18 - 09:09
(11) И я буду внимательней читать СП!
   _Дайвер_
 
15 - 19.06.18 - 09:09
(13) Можешь не соглашаться, читай СП
   alkorolev
 
16 - 19.06.18 - 09:10
(10) еще раз выше прочитай
ЗначениеВРеквизитФормы(ДокументОбъект, "Объект")
   SkillUp
 
17 - 19.06.18 - 09:11
(15)
НашОбъект.Записать();
НашОбъект.Прочитать();

ситуация не меняется!!!
   SkillUp
 
18 - 19.06.18 - 09:12
(16) Сейчас попробую...
   alkorolev
 
19 - 19.06.18 - 09:12
не записывай ты объект! у тебя расхождения в версиях тогда будут
   SkillUp
 
20 - 19.06.18 - 09:14
(19) ОК.
   hhhh
 
21 - 19.06.18 - 09:15
(18) ты не туда запись зафигачил. вот это свое
  НашОбъект = Выборка[0].ссылка.ПолучитьОбъект();

выкинь. Работай прямо на форме, заполняй табличную часть. Тогда и записывать не надо, и перечитывать тем более.
   _Дайвер_
 
22 - 19.06.18 - 09:17
(21) Он программно меняет данные, перечитать нужно будет, иначе не обновиться форма его.
(19)ЭтаФорма.Прочитать();
   SkillUp
 
23 - 19.06.18 - 09:17
(21) Я из другой формы получаю документ, заполняю ТЧ программно. Пока не могу понять, как выкинуть...
   SkillUp
 
24 - 19.06.18 - 09:22
(22) Короче надо форму обекта получить, правильно?
потом.
Форма.Прочитать();
   _Дайвер_
 
25 - 19.06.18 - 09:23
(24)Вот тебе пример:
&НаСервереБезКонтекста
Процедура ДатьСкидкуВыполнитьНаСервере(Ссылка)

    Объект = Ссылка.ПолучитьОбъект();
    НоваяСтрока = Объект.ТМЦ.Добавить();
    НоваяСтрока.Цена = 100;
    Объект.Записать();

КонецПроцедуры

&НаКлиенте
Процедура ДатьСкидкуВыполнить()
    
    ДатьСкидкуВыполнитьНаСервере(Объект.Ссылка);
    ЭтаФорма.Прочитать();

КонецПроцедуры
   SkillUp
 
26 - 19.06.18 - 09:26
(25) Заработало!!! Спасибо!
   SkillUp
 
27 - 19.06.18 - 09:29
(25) Ты мой боххххх!!!!!!! )))
   МимохожийОднако
 
28 - 19.06.18 - 09:40
(27) Твой бог СП, если чё
   SleepyHead
 
29 - 19.06.18 - 10:08
Читать в ТЗ. Потом Объект.ИмяТЧ.Загрузить(ТЗ)



Список тем форума
Рекламное место пустует  
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует