Вход | Регистрация


1С:Предприятие ::

Метки: 

мобильное приложение HTML

Ø [Asmody, 17.06.18 - 22:02]
Я
   jura80885516
 
17.06.18 - 17:53
У меня мобильное приложение
Есть реквизит Описание тип  строка
на форми Поле HTML документ на сервери ето поле Форматированного документа.
А мне хочеться в это поле что нибудь написать з телефона.
 
  Рекламное место пустует
   jura80885516
 
1 - 17.06.18 - 17:55
Пожна просто зделать реквизит "текст2" и кнопку добавить текст.
   PR
 
2 - 17.06.18 - 17:58
Так так
   jura80885516
 
3 - 17.06.18 - 18:07
Як Як ??
   PR
 
4 - 17.06.18 - 18:15
(3) Я говорю рассказывай, как сделал, мы заинтригованы
   jura80885516
 
5 - 17.06.18 - 18:17
Процедура ЗагрузкаДокументов(ТЗ,ТипДанных)
    Для Каждого Стр Из ТЗ Цикл
        Попытка
            Если Стр.Ссылка.ПолучитьОбъект() = Неопределено Тогда
                Нов = Документы[ТипДанных.Имя].СоздатьДокумент();
                Нов.УстановитьСсылкуНового(Стр.Ссылка);
                    Иначе
                Нов = Стр.Ссылка.ПолучитьОбъект();
                Нов.Записать(РежимЗаписиДокумента.ОтменаПроведения);
            КонецЕсли;    
                ЗаполнитьЗначенияСвойств(Нов,Стр,,"Ссылка");
            
            //Для Каждого Таб Из ТипДанных.ТабличныеЧасти Цикл

            //    Если ТЗ.Колонки.Найти(Таб.Имя) = Неопределено Тогда Продолжить КонецЕсли;

            //    Нов[Таб.Имя].Загрузить(Стр[Таб.Имя]);

            //КонецЦикла;

            
            Нов.Записать(?(Стр.Проведен, РежимЗаписиДокумента.Проведение,РежимЗаписиДокумента.Запись));    
        Исключение
            ЗаписьЛога(Стр.Ссылка, ОписаниеОшибки())
        КонецПопытки;
    КонецЦикла;
КонецПроцедуры
   jura80885516
 
6 - 17.06.18 - 18:23
Элементы.Описание.Документ.
Так не получиться на приложение нету доступа до Документа.
То что на компе работает на телефони отказується.
а пробував я много чого.
решив пойти простым путем.
Получить текст з HTML 

   ЧтениеHTML = Новый ЧтениеHTML;
   ЧтениеHTML.УстановитьСтроку(ТекстОтвета);
   
   ПостроительDOM = Новый ПостроительDOM;
   
   ДокумнетDOM = ПостроительDOM.Прочитать(ЧтениеHTML);
   Возврат ДокумнетDOM

ДокумнетDOM.Тело.ТекстовоеСодержимое
содержить мой текст нужно както туда текст добавить і передати обратно Поле HTML документа
   Garykom
 
7 - 17.06.18 - 18:25
Потрясающе
   jura80885516
 
8 - 17.06.18 - 18:27
????
вы издеваетесь надо мной ??
   PR
 
9 - 17.06.18 - 18:39
(7) Шедевр :))
   PR
 
10 - 17.06.18 - 18:39
(8) В смысле?
Ты разве не хвастаешься своим кодом?
 
  Рекламное место пустует
   jura80885516
 
11 - 17.06.18 - 18:40
нет я шукаю ответ на вопрос.
   zwei
 
12 - 17.06.18 - 18:48
Ямар асуулт байна вэ?
   jura80885516
 
13 - 17.06.18 - 18:50
АГА
   PR
 
14 - 17.06.18 - 18:55
(11) Так а где у тебя в (0) знак вопроса-то?
   jura80885516
 
15 - 17.06.18 - 18:58
на форми Поле HTML документ на сервери ето поле Форматированного документа.
А мне хочеться в это поле что нибудь написать з телефона.

Как в Поле HTML документ добавить/передать (для нового докуменат)
текст??
   PR
 
16 - 17.06.18 - 18:59
(15) А в чем сложность?
   jura80885516
 
17 - 17.06.18 - 19:02
во всьом )))
програмирую месяц )))
   PR
 
18 - 17.06.18 - 19:06
(17) При создании на сервере заполняй текст
А вообще с того ли ты начал, если не можешь такое загуглить?
   jura80885516
 
19 - 17.06.18 - 19:10
гуглю уже неделю
   PR
 
20 - 17.06.18 - 19:11
(19) Ёёёёё, тогда точно стоит хорошо подумать, правильно ли ты выбрал профессию
   jura80885516
 
21 - 17.06.18 - 19:14
При создании на сервере заполняй текст 
не подходить.
у меня должны сохраниться параметры форматированого документа
цвет букв размер текст.
Если при создание на сервери я ето всьо паламаю.
и верну простой текст на сервер то что поле форматированого документа не покажыт.
   jura80885516
 
22 - 17.06.18 - 19:14
Ёёёёё, тогда точно стоит хорошо подумать, правильно ли ты выбрал профессию
Позно уже догорогы обратно нету
   PR
 
23 - 17.06.18 - 19:15
Ты это, подналег бы на изучение русского что ли для начала
   jura80885516
 
24 - 17.06.18 - 19:16
я на свойом писать не умею.... )))
   PR
 
25 - 17.06.18 - 19:17
(24) Да я на свойом тоже не силен
   jura80885516
 
26 - 17.06.18 - 19:21
по моему вопросу можешь помочь ?
   jura80885516
 
27 - 17.06.18 - 19:21
ну или направ куда нужно .
   PR
 
28 - 17.06.18 - 19:22
(26) Да, в (18) помог
Причем я имел в виду не текст, а текст в формате html
   PR
 
29 - 17.06.18 - 19:23
(27) Направляю тебя в Яндекс
Ну или на hh.ru для смены профессии, тебе виднее
   PR
 
30 - 17.06.18 - 19:24
Типовые еще можешь глянуть, БСП или ДО
   jura80885516
 
31 - 17.06.18 - 19:30
то есть ты хочешь сказать что у тебе з самого початку все получалось ???
   PR
 
32 - 17.06.18 - 19:32
(31) То есть я хочу сказать, что я тебе уже сказал все, что нужно
   jura80885516
 
33 - 17.06.18 - 20:02
ок супер.
 
 
   craxx
 
34 - 17.06.18 - 20:02
(31) с какого початку? с кукурузного?
   jura80885516
 
35 - 17.06.18 - 20:06
Да
   hhhh
 
36 - 17.06.18 - 21:16
(35) ну ты же прекрасно должен понимать, что первые пять лет надо чего попроще программировать. Бухгалтерию, управление торговлей, расчет зарплаты. Когда освоишься, на шестой год уже можно переходить на мобильные устройства.
   jura80885516
 
37 - 17.06.18 - 21:46
&НаКлиенте
Процедура ТекстОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, СтандартнаяОбработка)
    Если ЗначениеЗаполнено(Объект.Описание) Тогда
        ДлинаТекстаHTML             = СтрДлина(Объект.Описание);
        ОкончаниеТекстаHTML         = Прав(Объект.Описание,15);
        КоличествоСимволовОкончание = СтрДлина(Прав(Объект.Описание,15));
        
        ДлинаМинус                  = ДлинаТекстаHTML - КоличествоСимволовОкончание;    
        НовыйТекст                  = "<p>" + Текст + "</p>";    
        ПолучитьТекстHTML           = Сред(Объект.Описание, 1,ДлинаМинус);
        Объект.Описание             = ПолучитьТекстHTML + НовыйТекст + ОкончаниеТекстаHTML;
    Иначе
        Сообщить ("Описание не заполненно");
    КонецЕсли;
КонецПроцедуры
   jura80885516
 
38 - 17.06.18 - 21:47
знаю ну и что ??? )))))
   jura80885516
 
39 - 17.06.18 - 21:48
както так....
   jura80885516
 
40 - 17.06.18 - 21:49
осталось если не пустая строка
   jura80885516
 
41 - 17.06.18 - 21:58
Если ЗначениеЗаполнено(Объект.Описание) Тогда
        ДлинаТекстаHTML             = СтрДлина(Объект.Описание);
        ОкончаниеТекстаHTML         = Прав(Объект.Описание,15);
        КоличествоСимволовОкончание = СтрДлина(Прав(Объект.Описание,15));
        
        ДлинаМинус                  = ДлинаТекстаHTML - КоличествоСимволовОкончание;    
        НовыйТекст                  = "<p>" + Текст + "</p>";    
        ПолучитьТекстHTML           = Сред(Объект.Описание, 1,ДлинаМинус);
        Объект.Описание             = ПолучитьТекстHTML + НовыйТекст + ОкончаниеТекстаHTML;
    Иначе
        НачалоТекстаHTML = Строка ("<html><body>");
        КонецТекстHTML   = Строка ("</body></html>");
        НовыйТекст       = "<p>" + Текст + "</p>";
        Объект.Описание = НачалоТекстаHTML + НовыйТекст + КонецТекстHTML;                   
      КонецЕсли;
   Asmody
 
Модератор
42 - 17.06.18 - 22:02
Язык форума - русский



Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь во втором сообщении вам дадут решение, а в двадцатом дадут правильное решение. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует