Вход | Регистрация


Удалить строку в Word

Удалить строку в Word
Я
   13Дима13
 
16.06.18 - 10:59
Доброго времени суток, коллеги.
Заполняю документ MS Word через 1с. В ворде указал параметры, в 1с через com делаю замену параметров.

        //инициализация

    СтрокаЗамены = Строка(СтрокаЗамены);
    
    Object.Select();
    Selection = Object.Application.Selection;
    
    FindObject = Selection.Find;
    FindObject.ClearFormatting();
    
    //поиск и замена

    Пока FindObject.Execute(СтрокаПоиска) Цикл
        //удалить пустые строки

        Если ПустаяСтрока(СтрокаЗамены) Тогда
            Selection.Delete();
        Иначе
            Selection.TypeText(СтрокаЗамены);
        КонецЕсли;
    КонецЦикла;
    
    Selection.Collapse();

В ворде есть параметр Pаr1, хочу чтобы если этот параметр не заполнен, чтобы в ворде удалялась строка вместе с этим параметром. Сейчас вместо Pаr1 остается пустая строка.
Подскажите, как можно это реализовать? Спасибо.
 
 
   13Дима13
 
1 - 16.06.18 - 11:20
вот так получилось

        Object.Select();
    Поиск = Object.Application.Selection.Find;
    Поиск.Text = "@#$";

    Поиск.Execute();
    Поиск.ClearFormatting();
    Пока Поиск.Found Цикл
        Selection = Поиск.Application.Selection;
        Selection.MoveUp(4);
        Selection.MoveDown(4, 1, 1);
        Selection.Delete(1);            
        Поиск.Execute()
    КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует