Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

При Назначении Цены Товара в 1с83 Розница 2.2 программно не видит Цену Товара

При Назначении Цены Товара в 1с83 Розница 2.2 программно не видит Цену Товара
Я
   VBMADD
 
15.06.18 - 22:50
Привет братьям по разуму.

Создаю программно Документ Установка Цен Номенклатуры
Документ создается и проводится, т.е. Цену вроде бы назначил,
Но затем при Заполнении Чека в РМК Выдает сообщение что Цена не назначена.
Куда копать подскажите плиз.

Спасибо огромное всем кто откликнулся.

Вот такой у меня Код

Процедура НазначениеЦеныТовара()
    Сообщить("НазначениеЦеныТовара()");
    
    МойТовар = справочники.Номенклатура.НайтиПоРеквизиту("Артикул","128747");
    Сообщить("МойТовар = " + МойТовар);
    
    ДокЦена=Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
    ДокЦена.Дата=ТекущаяДата(); 
    ДокЦена.Согласован = Истина; 
    ДокЦена.Ответственный = Пользователи.ТекущийПользователь();    
            
    НоваяСтрока=ДокЦена.товары.Добавить();
    НоваяСтрока.Номенклатура=справочники.Номенклатура.НайтиПоРеквизиту("Артикул","128747");
    
    ВидЦеныЗак = Справочники.ВидыЦен.НайтиПоНаименованию("Закупочная");
    ТабЧастьВидЦены = ДокЦена.ВидыЦен.Добавить();
    ТабЧастьВидЦены.ВидЦены=ВидЦеныЗак;
    
    НоваяСтрока.ВидЦены=ВидЦеныЗак;
    НоваяСтрока.Цена=199;
    
    НоваяСтрока=ДокЦена.товары.Добавить();
    НоваяСтрока.Номенклатура=справочники.Номенклатура.НайтиПоРеквизиту("Артикул","128747");

    ВидЦеныПрод = Справочники.ВидыЦен.НайтиПоНаименованию("Розничная");
    ТабЧастьВидЦены = ДокЦена.ВидыЦен.Добавить();
    ТабЧастьВидЦены.ВидЦены=ВидЦеныПрод;
        
    НоваяСтрока.ВидЦены=ВидЦеныПрод;
    НоваяСтрока.Цена=200;

//ДокЦена.Записать(РежимЗаписиДокумента.Запись);     

ДокЦена.Записать(РежимЗаписиДокумента.Проведение);
 
 
   VBMADD
 
1 - 15.06.18 - 23:21
В настройках указал 
Закупочная - Способ задания цены - Задавать вручную
Розничная -  Способ задания цены - Задавать вручную

Может ли это повлиять на то что Выдается сообщение, что Цена на товар не назначена
   tabarigen
 
2 - 16.06.18 - 10:49
&НаСервере
Функция СоздатьУстановкуЦенНоменклатуры(ИдентификаторКоманды, ОбъектДок, ВидЦены, Результат)
    
    ДокСсылка = ОбъектДок.Ссылка;
    
    Если ОбъектДок.Товары.Количество() > 0 Тогда
        
        Установка = Документы.УстановкаЦенНоменклатуры.СоздатьДокумент();
        Установка.Дата = ОбъектДок.Дата;
        Установка.Ответственный = Пользователи.ТекущийПользователь();
        Установка.Комментарий = "Документ создан автоматически на основании ввода остатков";
        Установка.Согласован = Истина;
        //Установка.Статус = ПредопределенноеЗначение("Перечисление.СтатусыУстановокЦенНоменклатуры.Согласован");

                                            
        НоваяСтрокаВидЦены = Установка.ВидыЦен.Добавить();
        НоваяСтрокаВидЦены.ВидЦены = ВидЦены;
        
        ТаблицаТоваров = ОбъектДок.Товары.Выгрузить();
        Для Каждого СтрокаТЧ из ТаблицаТоваров Цикл
            НоваяСтрокаУстановка = Установка.Товары.Добавить();
            НоваяСтрокаУстановка.Номенклатура = СтрокаТЧ.Номенклатура;
            НоваяСтрокаУстановка.ВидЦены = ВидЦены;
            НоваяСтрокаУстановка.Цена = СтрокаТЧ.Цена;
            НоваяСтрокаУстановка.Характеристика = СтрокаТЧ.Характеристика;
        КонецЦикла;    
            //ТаблицаТоваров.Колонки.Добавить("ВидЦены");

            //ТаблицаТоваров.Колонки.Добавить("УТР_Серия");

            //ТаблицаТоваров.ЗаполнитьЗначения(ВидЦены, "ВидЦены");

            //Установка.Товары.Загрузить(ТаблицаТоваров);        

        
        Попытка
            Установка.Записать(РежимЗаписиДокумента.Проведение);
        Исключение
            Сообщение = Новый СообщениеПользователю;
            Сообщение.Текст = ОписаниеОшибки();
            Сообщение.Сообщить();
            Установка.Записать();
        КонецПопытки; 
        Результат = ПолучитьНавигационнуюСсылку(Установка);
        
    КонецЕсли; 
            
    Возврат Результат;
    
КонецФункции
   tabarigen
 
3 - 16.06.18 - 10:49
у меня код выше прекрасно работает. недавно писал для Розницы Аптеки 2

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует