Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Вопрос по Документооборот 8 КОРП 2.1.11.5

Вопрос по Документооборот 8 КОРП 2.1.11.5
Я
   Косяк
 
15.06.18 - 10:44
В некоторых случаях требуется изменить наименование внутреннего документа. Некоторые редактируются, а некоторые - нет. У документов, которые не редактируются, справа поля "Наименование" стоит знак вопроса, при нажатии на который выдается сообщение: Наименование документа сформировано автоматически по шаблону, редактирование запрещено.

При этом шаблон - пустой.

В чем причина того, что наименование некоторых документов отредактировать не получается?
 
 
   Cyberhawk
 
1 - 15.06.18 - 10:55
В твоей лени. Ленишься открыть конфигуратор
   Косяк
 
2 - 15.06.18 - 11:39
(1) Посмотрел.
Но у меня шаблон пустой.

&НаСервере
Процедура УстановитьДоступностьПолей()
    
    УстановитьДоступностьПоСостоянию();
    УстановитьДоступностьПоЭП();
    УстановитьДоступностьПоПравам();
    УстановитьДоступностьПоЗапрету();
    
    Если НаименованиеСозданоПоШаблону Тогда 
        Элементы.Заголовок.ТолькоПросмотр = Истина;
        Элементы.Заголовок.Подсказка = НСтр("ru = 'Наименование документа сформировано автоматически по шаблону, редактирование запрещено.'");
        Элементы.Заголовок.ОтображениеПодсказки = ОтображениеПодсказки.Кнопка;
    КонецЕсли;
    
КонецПроцедуры
   Косяк
 
3 - 15.06.18 - 11:57
Такой вариант проблемы не решает:


Процедура УстановитьДоступностьПолей()
    
    УстановитьДоступностьПоСостоянию();
    УстановитьДоступностьПоЭП();
    УстановитьДоступностьПоПравам();
    УстановитьДоступностьПоЗапрету();
    
    Если НаименованиеСозданоПоШаблону Тогда 
        Элементы.Заголовок.ТолькоПросмотр = Ложь;
        //Элементы.Заголовок.Подсказка = НСтр("ru = 'Наименование документа сформировано автоматически по шаблону, редактирование запрещено.'");

        //Элементы.Заголовок.ОтображениеПодсказки = ОтображениеПодсказки.Кнопка;

    КонецЕсли;
    
КонецПроцедуры
   Cyberhawk
 
4 - 15.06.18 - 12:00
Скорее закрывай конфигуратор, а то наговнокодишь там
   Косяк
 
5 - 15.06.18 - 13:21
Кто-нибудь может помочь разобраться?
   Джинн
 
6 - 15.06.18 - 13:29
(0) Либо авто, либо вручную. И так, и сяк нет. Разделите по разным видам документов.
   vcv
 
7 - 15.06.18 - 13:35
Значит не пустое наименование на закладке "Реквизиты документа" в шаблоне. Что-то в нём что-то есть. Хотя бы пробел. Нужно сделать наименование пустым. Возможно снять галочку "Запрещать изменять реквизиты из шаблона" в настройках шаблона документа. Не помню, влияет ли эта галочка на наименование.
   Cyberhawk
 
8 - 15.06.18 - 13:42
"помочь разобраться?" // Могу отсыпать точек останова или нажатий на клавишу F9/F10
   Косяк
 
9 - 15.06.18 - 14:00
(7)наименование в шаблоне - пустое. Все галки сняты.
Кроме того, такая проблема не у всех документов данного вида (Внутренние документы), т.е. у некоторых можно редактировать наименование - и оно сохраняется, а у некоторых наименование тоже редактируется, но не сохраняются изменения, остается первоначальное значение.
   vcv
 
10 - 15.06.18 - 14:08
(9) Возникает впечатление, что требуется бэкап, ТиИ и, возможно, заупокойная молитва.
 
 Рекламное место пустует
   Косяк
 
11 - 15.06.18 - 14:18
(10)На своей локальной базе сделал ТИИ, ситуация не поменялась.
   Джинн
 
12 - 15.06.18 - 14:23
(11) Тогда отладчик.
   vcv
 
13 - 15.06.18 - 14:32
>> у некоторых наименование тоже редактируется, но не сохраняются изменения
   vcv
 
14 - 15.06.18 - 14:32
>>  у некоторых наименование тоже редактируется, но не сохраняются изменения
   vcv
 
15 - 15.06.18 - 14:33
Есть подозрения кривых лап в конфигураторе. Когда разрешили редактирование, но ДО искренне считает, что наименование генерится по шаблону и так и делает.
   Косяк
 
16 - 15.06.18 - 14:41
(15) Сами себе противоречите. Не все документы одного вида имеют такой косяк - вот в чем проблема.
   Косяк
 
17 - 15.06.18 - 14:43
Только на некоторых документе на закладке "реквизиты" напротив поля "наименование" стоит синий знак вопроса и по клику по нему выдается сообщение: Наименование документа сформировано автоматически по шаблону, редактирование запрещено

А у других точно таких же документов рядом по списку, - такого нет.
   Cyberhawk
 
18 - 15.06.18 - 14:45
Какой борзой ленивец попался )
   vcv
 
19 - 15.06.18 - 15:23
(16) Ваша проблема ничуть не противоречит возможному применению чьих-то рук к конфигурации. Проверяйте. Сравните с конфигурацией поставщика и анализируйте изменения.
   Косяк
 
20 - 15.06.18 - 15:54
(19)конфигурация на замке, т.е. типовая

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует