Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

При заполнении ТЧ, заполняет только последней строкой, пред. затирает.

При заполнении ТЧ, заполняет только последней строкой, пред. затирает.
Я
   SkillUp
 
15.06.18 - 08:00
При заполнении ТЧ, заполняет только последней строкой, пред. затирает. В результате у меня документ В ТЧ одна строка, последняя из обходарезультат запроса.

Код:
    НовДок = Документы.ИзменениеСостоянияОС.СоздатьДокумент();
    НовДок.Дата = ТекущаяДата();
    ЗаполнениеДокументов.ЗаполнитьШапкуДокумента(НовДок.ЭтотОбъект,,);
    НовДок.Организация = Справочники.Организации.НайтиПоКоду("000000001");
    ТЧ = НовДок.ОС.Добавить();
    
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаОбщийИтог = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    ВыборкаОбщийИтог.Следующий();            
    ВыборкаПодразделение = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока ВыборкаПодразделение.Следующий() Цикл
    
        ВыборкаДетальныеЗаписи = ВыборкаПодразделение.Выбрать();
    
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            //заполняем ТЧ док.

            ТЧ.ОсновноеСредство = ВыборкаДетальныеЗаписи.ОсновноеСредство;
        КонецЦикла;
        НовДок.Записать();
    КонецЦикла;
 
 
   FIXXXL
 
1 - 15.06.18 - 08:03
ТЧ = НовДок.ОС.Добавить(); 
в цикл "опусти"
   FIXXXL
 
2 - 15.06.18 - 08:03
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            //заполняем ТЧ док.

            ТЧ = НовДок.ОС.Добавить();
            ТЧ.ОсновноеСредство = ВыборкаДетальныеЗаписи.ОсновноеСредство;
        КонецЦикла;
   SkillUp
 
3 - 15.06.18 - 08:04
(1) Тю, блин, спасибо! Еще я не проснулся...
   SkillUp
 
4 - 15.06.18 - 08:04
(2) Спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует