Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

как заполнить поле таблицы цена из регистра сведений

как заполнить поле таблицы цена из регистра сведений
Я
   lolmatrix
 
14.06.18 - 09:30
Здравствуйте,  уважаемые специалисты, хочу обратиться к вам с просьбой, помогите пожалуйста заполнить поле Табличной части из регистра сведений Цена
Регистр называется Цены реквизит в нём Сумма, ТЧ СписокЗЧ,Поле в табличной Части Цена
 
 
   Lexey_
 
1 - 14.06.18 - 09:36
(0) сейчас поможем: давай, ты сможешь, у тебя получится
   lolmatrix
 
2 - 14.06.18 - 09:38
Заранее благодарен
   shadow_sw
 
3 - 14.06.18 - 10:01
на действие в строке(при началевыбора, к примеру) написать функцию:запрос к регистру цены, вернуть значение, подставить в ТЧ в соотв. колонку

500 руб на счет мисты
   shadow_sw
 
4 - 14.06.18 - 10:02
(3)+ на номенклатуру - привыборе()
   lolmatrix
 
5 - 14.06.18 - 10:03
Очень приблизительный ответ, подробней можно?
   Metman
 
6 - 14.06.18 - 10:03
)))))
   lolmatrix
 
7 - 14.06.18 - 10:04
пример
   Metman
 
8 - 14.06.18 - 10:04
Нужно обновить данные в ТЧ или при заполнении номенклатурой подставлять цену?
   Metman
 
9 - 14.06.18 - 10:05
Возьми Радченко, там это все есть
   lolmatrix
 
10 - 14.06.18 - 10:05
при запонении
 
 Рекламное место пустует
   shadow_sw
 
11 - 14.06.18 - 10:05
(5) ничего себе...я можно сказать всю работу сделал, а мне тут - приблизительно :)
   lolmatrix
 
12 - 14.06.18 - 10:06
у радченко регистр периодический у меня непериодическийф
   Metman
 
13 - 14.06.18 - 10:07
(12) Это не проблема, показывай в чем затык
   Metman
 
14 - 14.06.18 - 10:07
или не начинал еще делать?
   lolmatrix
 
15 - 14.06.18 - 10:08
Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Цены.Запчасть,
        |    Цены.Сумма
        |ИЗ
        |    РегистрСведений.Цены КАК Цены";

    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    СтрокаТЧ =Элементы.СписокЗЧ.ТекущиеДанные;
СтрокаТЧ.Цена = ВыборкаДетальныеЗаписи.Цена;
    КонецЦикла;
Текущие данные на серевере не выбратиь
   Metman
 
16 - 14.06.18 - 10:10
ВыборкаДетальныеЗаписи.Цена, а у тебя в запросе сумма
   Metman
 
17 - 14.06.18 - 10:11
а где в запросе отбор по запчасти?
   shadow_sw
 
18 - 14.06.18 - 10:13
интересный регистр цен - хранит сумму :)
параметры какие в запросе? запчасть = номенклатура?
   lolmatrix
 
19 - 14.06.18 - 10:13
Отбор сделаю вопрос в механизме
 при выпонении пишет ТЕКУЩИЕ ДАННЫЕ НЕ ДОСТУПНЫ НА СЕРВЕРЕ, как сдеать
   hhhh
 
20 - 14.06.18 - 10:16
(19)

&НаКлиенте, епт.

Типа

СтрокаТЧ =Элементы.СписокЗЧ.ТекущиеДанные;

а дальше вызываешь функцию на сервере

СтрокаТЧ.Цена = ЗаполнитьПОлеЦенаНаСервере(СтрокаТЧ.Номенклатура);
   lolmatrix
 
21 - 14.06.18 - 10:19
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    
     
 СтрокаТЧ =Элементы.СписокЗЧ.ТекущиеДанные;
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Цены.Запчасть,
        |    Цены.Сумма
        |ИЗ
        |    РегистрСведений.Цены КАК Цены
        |ГДЕ
        |    Цены.Запчасть = &Запчасть";
 Запрос.УстановитьПараметр("НачалоПериода", СтрокаТЧ.Наименование);
    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    СтрокаТЧ.Цена = ВыборкаДетальныеЗаписи.Сумма;
    КонецЦикла;
   shadow_sw
 
22 - 14.06.18 - 10:20
(21) О_О
в запросе "запчасть", в параметре "НачалоПериода"??
   lolmatrix
 
23 - 14.06.18 - 10:21
нет переиода непереиодический регистр
   lolmatrix
 
24 - 14.06.18 - 10:22
роцедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    
     
 СтрокаТЧ =Элементы.СписокЗЧ.ТекущиеДанные;
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Цены.Запчасть,
        |    Цены.Сумма
        |ИЗ
        |    РегистрСведений.Цены КАК Цены
        |ГДЕ
        |    Цены.Запчасть = &Запчасть";
 Запрос.УстановитьПараметр("Запчасть", СтрокаТЧ.Наименование);
    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    СтрокаТЧ.Цена = ВыборкаДетальныеЗаписи.Сумма;
    КонецЦикла;
   lolmatrix
 
25 - 14.06.18 - 10:22
как мне к строке обратиться
   shadow_sw
 
26 - 14.06.18 - 10:23
ливингстар?
   catena
 
27 - 14.06.18 - 10:24
В регистре "Цены" хранятся суммы, а в реквизите "Наименование" похоже хранится ссылка. Так и живем.
   hhhh
 
28 - 14.06.18 - 10:25
(24) на клиенте обращайся, блин, совсем не читаешь, чего пишут?
   shadow_sw
 
29 - 14.06.18 - 10:27
(25) ответ в(20)
   lolmatrix
 
30 - 14.06.18 - 10:28
обращаюсь на клиенте пишет {Документ.ВыдачаЗапасныхЧастей.Форма.ФормаДокумента.Форма(23,45)}: Переменная не определена (СтрокаТЧ
   lolmatrix
 
31 - 14.06.18 - 10:28
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
    
    СписокЗЧНаименованиеПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    
     
 СтрокаТЧ =Элементы.СписокЗЧ.ТекущиеДанные;
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Цены.Запчасть,
        |    Цены.Сумма
        |ИЗ
        |    РегистрСведений.Цены КАК Цены
        |ГДЕ
        |    Цены.Запчасть = &Запчасть";
 Запрос.УстановитьПараметр("Запчасть", СтрокаТЧ.Наименование);
    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    СтрокаТЧ.Цена = ВыборкаДетальныеЗаписи.Сумма;
    КонецЦикла;
   lolmatrix
 
32 - 14.06.18 - 10:29
&НаКлиенте
Процедура СписокЗЧНаименованиеПриИзменении(Элемент)
       СтрокаТЧ =Элементы.СписокЗЧ.ТекущиеДанные;
    СписокЗЧНаименованиеПриИзмененииНаСервере();
КонецПроцедуры

&НаСервере
Процедура СписокЗЧНаименованиеПриИзмененииНаСервере()
    
     

    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |    Цены.Запчасть,
        |    Цены.Сумма
        |ИЗ
        |    РегистрСведений.Цены КАК Цены
        |ГДЕ
        |    Цены.Запчасть = &Запчасть";
 Запрос.УстановитьПараметр("Запчасть", СтрокаТЧ.Наименование);
    РезультатЗапроса = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    СтрокаТЧ.Цена = ВыборкаДетальныеЗаписи.Сумма;
    КонецЦикла;
   shadow_sw
 
33 - 14.06.18 - 10:29
да ты значение передай в процедуру на сервер то
 
 
   catena
 
34 - 14.06.18 - 10:30
(32)Опять мимо. Еще раз внимательно (20) перечитай.
   lolmatrix
 
35 - 14.06.18 - 10:33
как передать значение в процедуру?
   Lexey_
 
36 - 14.06.18 - 10:35
(35) через параметр
   shadow_sw
 
37 - 14.06.18 - 10:36
(35) Значение ЯНичегоНезнаю(МОЕЗНАЧЕНИЕ)
   dezss
 
38 - 14.06.18 - 10:41
(35) у меня дежавю)
Админ решил приобщиться к "высокому"?
   lolmatrix
 
39 - 14.06.18 - 10:41
Спасибо, всем за помощь, сам буду думать, очевидных вещей наговорили, вопрос закрыт


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует