Вход | Регистрация


1С:Предприятие ::

Метки: 

Как обойти вопрос, ответив на него по умолч., не вызвав диалогового окна? Или др. метод?

Я
   SkillUp
 
13.06.18 - 15:02
Подскажтие как обойти вопрос, ответив на него по умолчанию, не вызвав диалогового окна? Или другие способы выхода из ситуации...

                
КОД:                    
                Если ВыбФормаОтчета.Модифицированность Тогда
                    Если Вопрос(СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru='Перед выгрузкой отчета требуется сохранить введенную информацию.%1Продолжить?'"), Символы.ПС), РежимДиалогаВопрос.ДаНет) <> КодВозвратаДиалога.Да ИЛИ НЕ ВыбФормаОтчета.СохранитьНаКлиенте() Тогда
                        Возврат;
                    КонецЕсли;
                КонецЕсли;
 
  Рекламное место пустует
   SkillUp
 
1 - 13.06.18 - 15:03
У меня гр. обработка документов и диалоговаое окно, не надо мне!
   SkillUp
 
2 - 13.06.18 - 15:04
Уже не заню что делать... Столько всего перепробовал...
   anatoly
 
3 - 13.06.18 - 15:06
документ самописный?

ОбменДанными.Загрузка проверяется?
   SkillUp
 
4 - 13.06.18 - 15:13
Нет типовой... Просто намудрили с ним, капец...
   SkillUp
 
5 - 13.06.18 - 15:14
пытался через ЗаписатьВФорме();    Но вылазит ошибка. Что делать, не пойму...
   SkillUp
 
6 - 13.06.18 - 15:16
Если так :

ЗаписатьВФорме();

Потом:
Если ВыбФормаОтчета.Модифицированность Тогда
                    Если Вопрос(СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru='Перед выгрузкой отчета требуется сохранить введенную информацию.%1Продолжить?'"), Символы.ПС), РежимДиалогаВопрос.ДаНет) <> КодВозвратаДиалога.Да ИЛИ НЕ ВыбФормаОтчета.СохранитьНаКлиенте() Тогда
                        Возврат;
                    КонецЕсли;
                КонецЕсли;

Ошибка на строчку ЗаписатьВФорме();
   Ненавижу 1С
 
7 - 13.06.18 - 15:17
(0) поменять условия в запросе?
   SkillUp
 
8 - 13.06.18 - 15:17
Если полный код, то так:

            ВыбФормаОтчета = ОткрытьФорму("Отчет." + ИмяОтчета + ".Форма." + мВыбраннаяФорма, ПараметрыФормы, ,Документ);
            
            ВыбФормаОтчета.ЗаполнитьИзДокументаИсточника();
            
            ВыбФормаОтчета.Модифицированность = Истина;
    
            //Доработка

            //Групповая выгрузка документов НалоговаяНакладная в XML

            
                ВыбФормаОтчета.ЗаписатьВФорме();     
                Если ВыбФормаОтчета.Модифицированность Тогда
                    Если Вопрос(СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(НСтр("ru='Перед выгрузкой отчета требуется сохранить введенную информацию.%1Продолжить?'; uk = 'Перед вивантаженням звіту вимагається зберегти введену інформацію.%1Продовжити?'"), Символы.ПС), РежимДиалогаВопрос.ДаНет) <> КодВозвратаДиалога.Да ИЛИ НЕ ВыбФормаОтчета.СохранитьНаКлиенте() Тогда
                        Возврат;
                    КонецЕсли;
                КонецЕсли;
   SkillUp
 
9 - 13.06.18 - 15:18
(7) Пож., подскажи как!
   Ненавижу 1С
 
10 - 13.06.18 - 15:18
(9) поменять местами
 
  Рекламное место пустует
   dezss
 
11 - 13.06.18 - 15:19
(8) э...а этот код вообще в какой процедуре-функции какого модуля?
   SkillUp
 
12 - 13.06.18 - 15:22
Модуль - ОбщаяКомандаВыгрузкВXML
процедура - Процедура ОбработкаКоманды
   SkillUp
 
13 - 13.06.18 - 15:23
(11) Как-то так...
   dezss
 
14 - 13.06.18 - 15:24
(12) это какой-то самопал?
вызывать какие-то формы вопросов вне контекста формы, ИМХО, бред...
   _Дайвер_
 
15 - 13.06.18 - 15:24
(0)"Как обойти вопрос, ответив на него по умолч., не вызвав диалогового окна? Или др. метод?"

Если ВыбФормаОтчета.Модифицированность Тогда
Возврат;
КонецЕсли;

наверное так!?
   SkillUp
 
16 - 13.06.18 - 15:24
Хочу "Групповая выгрузка документов НалоговаяНакладная в XML" сделать, ни как не могу обойти диалогВопрос на сохранение формы.

метод ЗаписатьВФорме(); не помогает...
   SkillUp
 
17 - 13.06.18 - 15:25
вернее ошибка на ЗаписатьВФорме()...
   dezss
 
18 - 13.06.18 - 15:25
(14) +
            ВыбФормаОтчета.Модифицированность = Истина;
это вообще ни о чем)))
   SkillUp
 
19 - 13.06.18 - 15:26
(15) Там в методе ВыбФормаОтчета.СохранитьНаКлиенте() идет сохранение данных, из-за чего этот метод нельзя пропустить!!!
   SkillUp
 
20 - 13.06.18 - 15:26
(18) Тоже самое...
   FIXXXL
 
21 - 13.06.18 - 15:27
(19) ну так твоя "групповуха" на сервере работает, по всей видимости
зачем тебе клиентские методы?
   SkillUp
 
22 - 13.06.18 - 15:28
Либо надо записать форму как-то (+ метод СохранитьНаКлиенте()) Что не получается...

Либо На вопрос, отвечать по умолчанию -"Да", без диалога. Как-то так, может опытные товарищи подскажут что-то другое...
   SkillUp
 
23 - 13.06.18 - 15:29
(21) Пробовать сервер процедуру, с записью обьекта или формы?
   SkillUp
 
24 - 13.06.18 - 15:31
(21) А как лучше на сервере через записать() или ДанныеФормыВзНачение?
   SkillUp
 
25 - 13.06.18 - 15:34
Короче понятно, что не чего не понятно...
   SkillUp
 
26 - 13.06.18 - 15:37
(18) Поробую через модифицированность = ложь... Другое не получается...
   dezss
 
27 - 13.06.18 - 15:42
(22) так сделай СохранитьНаКлиенте() без всяких условий, в чем проблема?
   SkillUp
 
28 - 13.06.18 - 15:49
(27) уже пробую, но другие ошибки лезут блин... (27) Спасибо за советы, эксперементирую... Что-то без записи формы, которую по одной может делать пользователь, все отлично! А вот как-то программно заставить записывать документ НУ НИКАК... блин...
   dezss
 
29 - 13.06.18 - 15:50
(28) смотри на контекст вызова и думай...
какие галки стоят на модуле?
   arsik
 
30 - 13.06.18 - 15:52
(0) Сделай через ДополнительныеСвойства у объекта.
Если твое свойство заполнено, тогда задавай вопрос, иначе не задавай.
   SkillUp
 
31 - 13.06.18 - 15:53
(29) Ок, уже смотрю...
   SkillUp
 
32 - 13.06.18 - 15:53
(30) Хм... идея!



Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует