Вход | Регистрация

1С:Предприятие ::

Метки: 

Книга учета приемосдаточных актов

Я
   АБАБ00
 
12.06.18 - 09:00
Бухгалтерия предприятия, редакция 3.0 (3.0.40.37). Стандартная, не изменено ничего. Но есть один момент... в документе ПоступлениеТоваровУслуг активно используется дополнительный реквизит
https://ibb.co/kGNMxo
который весьма нужен для создания отчёта Книга учёта приемосдаточных актов. Как вот оттуда его взять, ума не приложу. Кто-нибудь может подсказать?
 
  Рекламное место пустует
   PuhUfa
 
1 - 12.06.18 - 09:08
(0) Из соответствующего РС
   АБАБ00
 
2 - 12.06.18 - 09:12
Регистр Сведений. Дополнительные Сведения.
Объект - Документы Поступление 
Свойство - Номер ПСА 
Значение - число
Вы про это?
   PuhUfa
 
3 - 12.06.18 - 09:20
(2) да
   АБАБ00
 
4 - 12.06.18 - 09:31
НаборЗаписей=РегистрыСведений.ДополнительныеСведения.Выбрать(НачалоПериода,КонецПериода);
    Пока НаборЗаписей.Следующий()=1 цикл
        Сообщить(НаборЗаписей.Значение);
    КонецЦикла;

Ошибка:
{ВнешняяОбработка.Журнал.Форма.Форма.Форма(44)}: Ошибка при вызове метода контекста (Выбрать)
    НаборЗаписей=РегистрыСведений.ДополнительныеСведения.Выбрать(НачалоПериода,КонецПериода);
по причине:
Несоответствие типов (параметр номер '1')
   shuhard
 
5 - 12.06.18 - 09:34
(4)  ум приложи
   hhhh
 
6 - 12.06.18 - 10:51
(4) регистр сведений ДополнительныеСведения непериодический? Реально не знал? Или прикалываешься на праздник?
   АБАБ00
 
7 - 12.06.18 - 11:49
Так я только начинающий. У меня даже ни одного профессионала нет. Так что не прикалываюсь.
За помощь спасибо! Список значений вывел. Сейчас буду выводить остальное из Объекта Регистра, из документа. Весьма помогли, спасибо ещё раз!
   АБАБ00
 
8 - 12.06.18 - 13:42
Теперь ещё такое дело. На печать не выводит. В чём может быть дело?

&НаКлиенте
Процедура Сформировать(Команда)
    Если ДатаНеЗаполнена(НачалоПериода)=1 тогда
        НачалоПериода=НачалоГода(ТекущаяДата());
    КонецЕсли;    
    Если ДатаНеЗаполнена(КонецПериода)=1 тогда
        КонецПериода=ТекущаяДата();
    КонецЕсли;    
    Если (Отгрузки=0) и (Поступления=0) тогда
        Сообщить("Не выбран ни один вид документов!");
        Возврат;
    КонецЕсли;    
    ТабДок = Новый ТабличныйДокумент;
       Если Поступления=1 тогда
        ПоПоступлениям(ТабДок);
    КонецЕсли;
    Если Отгрузки=1 тогда
        ПоОтгрузкам(ТабДок);
    КонецЕсли;
    ТабДок.Показать();
КонецПроцедуры    

Процедура ПоПоступлениям(ТабДок)
    Макет=Объект.ПолучитьМакет("Печать");
        Область=Макет.ПолучитьОбласть("Область1");
    ТабДок.ВывестиОбласть(Область);

КонецПроцедуры     

Почему ругается: Метод объекта не обнаружен "Получить макет"
{ВнешняяОбработка.Журнал.Форма.Форма.Форма(43)}: Метод объекта не обнаружен (ПолучитьМакет)
    Макет=Объект.ПолучитьМакет("Печать");    

Почему не обнаружен? Везде ведь так сделано. В чём тут ошибка?
   hhhh
 
9 - 12.06.18 - 14:29
чего-то нигде не видел такого. Вот так везде сделано

Макет = РеквизитФормыВЗначение("Объект").ПолучитьМакет("Печать")


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует