Вход | Регистрация

1С:Предприятие ::

Метки: 

Поле картинки и как с ним бороться???

Я
   Alex_Kh_ua
 
09.06.18 - 23:32
Доброго времени суток дорогие форумчане!!! Постигла меня беда в очередной раз... И беда сея до сели не виданная, а именно работа с Полем картинка на управляемых формах.
Проблема заключается в том, что я пытаюсь вывести в поле картинки картинку из конфигурации, а именно из общих картинок, но она никак не выводится, и причины я понять не могу... http://prntscr.com/jt2g0r

Такая же задача идет из модуля формы, но тоже не получается...

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ЭтаФорма.ПодчиненныеЭлементы.СсылкаНакартинку.КартинкаЗначений = БиблиотекаКартинок.БизнесПроцесс;
    ПриОткрытииНаСервере();
КонецПроцедуры

А поле как было пустым, так и остается... http://prntscr.com/jt2h2b

Хочу вывести именно из Общих картинок, а не через ХранилищеЗначений.
Очень интересно мнение опытных программистов на этот счет.
 
 
   Alex_Kh_ua
 
1 - 12.06.18 - 16:02
АП!
   1Сергей
 
2 - 12.06.18 - 17:56
http://pics.rsh.ru/img/_e1rqpev8.png

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Реквизит1 = БиблиотекаКартинок.DirectBank64;
КонецПроцедуры
   Cyberhawk
 
3 - 12.06.18 - 18:28
Строковый АдресВХ как реквизит формы и обычное поле ввода
   Alex_Kh_ua
 
4 - 15.06.18 - 23:10
Спасибо большое за подсказку, мне как раз нужен был вариант (3), где реквизит формы Строка, а в неё как раз записываем

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    
    
    СсылкаНаКартинку = ПоместитьВоВременноеХранилище(БиблиотекаКартинок.ФонНетКартинок);
    //СсылкаНаКартинку = БиблиотекаКартинок.ФонНетКартинок;

    
КонецПроцедуры

Еще нашел интересную тему по данному поводу, может кому пригодится :) http://pro1c.org.ua/index.php?showtopic=15489


Список тем форума
Рекламное место пустует   Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует