Вход | Регистрация


1С:Предприятие ::

Метки: 

Номер документа

Я
   Евгения93
 
08.06.18 - 13:21
Привет всем! Подскажите, как сделать! У меня есть номер документа (не стандартный реквизит) , как сделать так, чтобы при изменении этого номера он записывался в новое поле Строка, например #документа 1, следовательно в строке было 1, если меняется опять номер этого документа #документа 2, то в строку бы вставало 1,2и так далее
 
 
   Евгения93
 
1 - 08.06.18 - 13:25
Я делаю так
Если не значениеЩаполнено(ПриходныйОрдерСтрока)  тогда
Перемен1=ПриходныйОрдер;
ПриходныйОрдер=Перемен1;
Иначе
Перемен2=ПризодныйОрдерСтрока;
ПризодныйОрдерСтрока = Перемен2 +",  " + Перемен1 ;
КонецЕсли
   Мандалай
 
2 - 08.06.18 - 13:45
Фотки нет, но помогу - название города похоже на мой родной город.
1. УФ или ОФ?
2. Речь про данные одного документа или мы будем писать по разным документам?
3. Вы говорите про добавление новой строки в табличной части или все заполняемые реквизиты будут лежать в шапке документа?
   Евгения93
 
3 - 08.06.18 - 13:50
1.оф
2.один документ
3.шапка документа
P.s. Фото поставлю:)
   Мандалай
 
4 - 08.06.18 - 13:52
А итераций изменения сколько? Конечное число? Или бесконечное? И куда писать если бесконечное?
   Евгения93
 
5 - 08.06.18 - 14:01
Так, ну они могут и 10 раз и 20 раз поменять этот ПриходныйОрдер
   Мандалай
 
6 - 08.06.18 - 14:02
Значит какой вывод? Писать в Табличную часть?
   Мандалай
 
7 - 08.06.18 - 14:02
По секрету скажу, что тут без фоток банят.
   Евгения93
 
8 - 08.06.18 - 14:12
Нет, в табличную часть не нужно, они могут делать как, например раз 5 изменить этот номер, а потом просто вручную удалить за ненадобностью и пойдёт заново отсчёт, но чаще всего они делают этот приход 2,3 раза
P.s фото поставила, можно спать спокойно ;)
   Мандалай
 
9 - 08.06.18 - 14:17
Так то есть у нас в шапке документа будет 5 реквизитов, которые должны быть последовательно заполнены при изменении номера (не стандартного реквизита) документа.
PS: Весь форум с облегчением вздохнул :)
   bolobol
 
10 - 08.06.18 - 14:17
Похоже, что достаточно просто дописывать в строку новый назначенный номер.

А этим:
Перемен1=ПриходныйОрдер;
ПриходныйОрдер=Перемен1;

- чего сказать хотели? Возьми и положи обратно?
 
 
   bolobol
 
11 - 08.06.18 - 14:18
Хорошо фото поставилось!
   bolobol
 
12 - 08.06.18 - 14:22
Процедура НомерНестандартныйРеквизитПриИзменении(...)
   НовоеПолеСтрока= НовоеПолеСтрока + ", " + НомерНестандартныйРеквизит;
КонецПроцедуры

Можно добавить уточнение, что номер изменился:
Если Прав(НовоеПолеСтрока, СтрДлина(НомерНестандартныйРеквизит) + 2) <> ", " + НомерНестандартныйРеквизит Тогда...
   Serg_1960
 
13 - 08.06.18 - 14:24
Процедура ПередЗаписью
   Если Номер <> Ссылка.Номер Тогда
      Комментарий = Комментарий + СокрЛП(Номер) + ", ";
   КонецЕсли;
   Мандалай
 
14 - 08.06.18 - 14:26
Идея на самом деле верная, проверяем заполненность реквизита. Если реквизит заполнен, значит проверяем следующий. Если не заполнен, пишем в этот самый реквизит.
Очередность проверки должна быть явно описанной в коде.
Причем реквизиты должны быть не просто помещены на форму, но и являться частью метаданных. То есть сначала добавляем реквизит документа, а затем помещаем его на форму.
Согласно поставленной задаче предлагаю проверить работоспособность приведенного кода.
    Если НЕ ЗначениеЗаполнено(Реквизит1) Тогда
        Реквизит1 = ВведенноеЗначение;
    ИначеЕсли НЕ ЗначениеЗаполнено(Реквизит2) Тогда
        Реквизит2 = Реквизит1 + ", " + ВведенноеЗначение;
    ИначеЕсли НЕ ЗначениеЗаполнено(Реквизит3) Тогда
        Реквизит3 = Реквизит2 + ", " + ВведенноеЗначение;
    ИначеЕсли НЕ ЗначениеЗаполнено(Реквизит4) Тогда
        Реквизит4 = Реквизит3 + ", " + ВведенноеЗначение;
    ИначеЕсли НЕ ЗначениеЗаполнено(Реквизит5) Тогда
        Реквизит5 = Реквизит4 + ", " + ВведенноеЗначение;
    КонецЕсли;
   Мандалай
 
15 - 08.06.18 - 14:28
На самом деле лепить на форме документа много однотипных реквизитов не является хорошей идеей.
Поэтому попробуй рассмотреть вариант - писать все в одну строку с дополнением.
   bolobol
 
16 - 08.06.18 - 14:34
(15) А не вернулись ли вы этим предложением к точке старта?
   Евгения93
 
17 - 08.06.18 - 14:35
Так и нужно все писать в одну лишь строчку, просто по порядку записывать эти номера приходников, 1,2,3,4
   lubitelxml
 
18 - 08.06.18 - 14:36
(17) так вы же сами ответили на свой вопрос еще в (1)
   lubitelxml
 
19 - 08.06.18 - 14:36
или так не работает?
   Мандалай
 
20 - 08.06.18 - 14:39
Тогда Ваш вариант в (13).
Таким образом Вы проверите значение реквизита на форме (объект), с тем которое записано в базу данных (ссылка).
Но в (13) предлагается менять реквизит в момент записи документа, а Вам необходимо повесить эту процедуру на событие ПриИзменении.
   Евгения93
 
21 - 08.06.18 - 14:39
Выводит вот так если меняю номер 1 на 2: 1,  
И всё а номер 2 не выводит, точнее выводит пустое значение
   Мандалай
 
22 - 08.06.18 - 14:40
Хотя вполне возможно, что как раз ПриЗаписи то, что Вас устроит. Не будут писаться лишние значения, получаемые при ошибке пользователя.
   Мандалай
 
23 - 08.06.18 - 14:41
Отладкой смотрели чему равны переменные?
   bolobol
 
24 - 08.06.18 - 14:42
(21) Что-то не дописали, опечатку допустили. Сверьтесь с предложенным текстом
   bolobol
 
25 - 08.06.18 - 14:43
Да, и после 25 поста - фотку необходимо менять!, я читал тут...
   lubitelxml
 
26 - 08.06.18 - 14:43
как называется реквизит, в котором меняют значение, и как называется реквизит, в который надо записать историю?
   lubitelxml
 
27 - 08.06.18 - 14:43
+(25) а то забанят ))
   Мандалай
 
28 - 08.06.18 - 14:45
Накинулись на девочку, хулиганы...
   lubitelxml
 
29 - 08.06.18 - 14:45
(29) перечитай свой пост (7)
   Asmody
 
30 - 08.06.18 - 14:46
(25) После 25 поста надо выкладывать пазл.
   Asmody
 
31 - 08.06.18 - 14:47
(30)+ фото из-под пазла надо предварительно занести в модераторскую для согласования
   Мандалай
 
32 - 08.06.18 - 14:48
(29)А мьсе понимает шутки юмора :)
   bolobol
 
33 - 08.06.18 - 14:50
(31) Не рановато ли для пазла? Новый год-то через полгода как-никак? Не, мы не против, но администрация фальстарт не объявит?
 
 
   Asmody
 
34 - 08.06.18 - 14:52
(0) Женя, ваш вопрос в (0) напоминает мне недавно где-то виденное: "Подскажите каким хватом правильно держать микроскоп при забивании шурупов в бетон?"

Попробуйте сформулировать исходную задачу, тогда, возможно, быстрее придём к адекватному решению.
   Asmody
 
35 - 08.06.18 - 14:53
(33) Встречать Новый год можно раз в году, а вот отмечать - хоть каждый день.
   bolobol
 
36 - 08.06.18 - 14:59
(35) Ур-ра! Евгения, а замутить паззл новогодний?! Всё-таки - пятница, пусть, не полноценная, но -календарная.
Дела - до понедельника!
   Евгения93
 
37 - 08.06.18 - 15:12
Спасибо большое (13) , всё работает =)
   Евгения93
 
38 - 08.06.18 - 15:14
(34) но ведь кто-то меня понял&#55357;&#56833;
   Мандалай
 
39 - 08.06.18 - 15:23
Вот и помогай после этого симпатишным барышням...
   Евгения93
 
40 - 08.06.18 - 15:54
(39) вам тоже большое спасибо =)
   Мандалай
 
42 - 08.06.18 - 16:20
(40)Почти хвостиком завилял)
(41)Кыш, противный, не про тебя цветем
   bolobol
 
43 - 08.06.18 - 16:21
Доктор, меня все игнорируют...
   Мандалай
 
44 - 08.06.18 - 16:23
Следующий :)



Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует