Вход | Регистрация


1С:Предприятие ::

Метки: 

Регламентное задание

Я
   makkut
 
08.06.18 - 13:14
Добрый день!
Поступила задача сделать регламентное задание на обработку договоров контрагента. Автоматически переводить в статус "Не действующие" те договора срок действия которых истек и не пролонгированы.
Сначала я сделал обработочку, протестил её, отрабатывает нормально.
Далее создал общий модуль куда вбил код процедуры
Процедура ГЭС_ДоговораКонтрагентовНеДействующие() Экспорт
        
    Выборка    =    Справочники.ДоговорыКонтрагентов.Выбрать();
    
    Пока Выборка.Следующий() Цикл
        
        Если Выборка.ГЭС_СтатусДоговора = Перечисления.ГЭС_СтатусыДоговоров.Действует    И Выборка.СрокДействия    < ТекущаяДата() И НЕ Выборка.СрокДействия =  Дата('00010101') И (Выборка.ГЭС_ВидДействияДоговора = Перечисления.ГЭС_ВидДейстивияДоговора.Бессрочный ИЛИ Выборка.ГЭС_ВидДействияДоговора = "")    Тогда
            
            ВыборкаОбъект    =    Выборка.ПолучитьОбъект();
            
            ВыборкаОбъект.ГЭС_СтатусДоговора =  Перечисления.ГЭС_СтатусыДоговоров.НеДействует;
                    
            ВыборкаОбъект.Записать();
                                    
        КонецЕсли;    
        
        
    КонецЦикла;    
        
КонецПроцедуры

далее создал рег задание привязал туда этот модуль.
установил параметры расписания. Но оно не срабатывает. В журнале регистрации пусто, что не так сделал?
 
 
   bavkyz
 
1 - 08.06.18 - 13:22
(0) какая кон-ция?
   makkut
 
2 - 08.06.18 - 13:23
(1) УПП 1.3
   lubitelxml
 
3 - 08.06.18 - 13:25
Справочники.ДоговорыКонтрагентов.Выбрать(); - вырвите мне глаза
   piter3
 
4 - 08.06.18 - 13:26
если не прошло.И это а запросом по религиозным соображениям не делается?
   DexterMorgan
 
5 - 08.06.18 - 13:26
(0) Г0вн0код потому что
   makkut
 
6 - 08.06.18 - 13:27
(3) скажите как правильно, однако обработкой этот код работает
   DexterMorgan
 
7 - 08.06.18 - 13:29
(0) фу так писать
   DexterMorgan
 
8 - 08.06.18 - 13:29
сначала выбрать все договора, а потом проверять условие на каждый
   makkut
 
9 - 08.06.18 - 13:32
(8) и так работает всё нормально, не там советуете. вопрос в другом
   piter3
 
10 - 08.06.18 - 13:34
что-то мне не нравиться еще,что сначала сравниваешь с текущей датой,а потом только с пустой
 
  Рекламное место пустует
   3achem
 
11 - 08.06.18 - 13:35
(9) Сделай запись в журнал, посмотри, что происходит. 95%, что расписание настроил не правильно.
   lubitelxml
 
12 - 08.06.18 - 13:35
попробуй вручную запустить задание, без ошибок выполнится?
   lubitelxml
 
13 - 08.06.18 - 13:36
расписание из конфигуратора убери, настрой в предприятии
   anatoly
 
14 - 08.06.18 - 13:36
(0) а в консоли заданий что?
   bavkyz
 
15 - 08.06.18 - 13:37
(2) КонсольЗаданий есть обработка? посмотрите может не создано ваше регзадание, поэтому не стартует....
   makkut
 
16 - 08.06.18 - 13:37
(10) у договора может быть не проставлена дата окончания
   makkut
 
17 - 08.06.18 - 13:39
(12) в консоле заданий пробовал и как предопределённое и как не предопределённое
   makkut
 
18 - 08.06.18 - 13:40
(15) Есть там всё.... И там расписание настраивал..
   lubitelxml
 
19 - 08.06.18 - 13:41
другие задания выполняются?
   makkut
 
20 - 08.06.18 - 13:42
(19) да, можно ли отладить регл задание?
   lubitelxml
 
21 - 08.06.18 - 13:43
да, поставь точку в общем модуле и руками запусти задание
   Mankubus
 
22 - 08.06.18 - 13:43
(18) другие регл задания работают? А то может блокировка стоит?
   makkut
 
23 - 08.06.18 - 13:47
(21) как его запустить то вручную? через консоль заданий? нет там кнопки запуска в окне регл заданий
   Мандалай
 
24 - 08.06.18 - 13:50
Должна быть - не туда смотришь.
В отладчике в настройках поставь галочку автоматически подключаться к фоновым заданиям.
   Мандалай
 
25 - 08.06.18 - 13:51
Если платформа позволяет запусти http отладку.
   3achem
 
26 - 08.06.18 - 13:52
(23) Своя обработку в одну строку запускает регламентное задание
   makkut
 
27 - 08.06.18 - 13:55
(24) походу что то с правами.... буду искать скачал с инета другую консоль один фиг правой кнопкой мыши на задании а запустить нет ...
   Necessitudo
 
28 - 09.06.18 - 06:39
Файловая базенка-то?
   Смешной 1С
 
29 - 09.06.18 - 06:51
(9) понятно, что работает. Но работает очень не оптимально. Переделай на запрос, в котором сразу отбор нужный установи. Тогда перебирать будешь только нужные тебе договоры.

Представь ситуацию из жизни: тебе нужно сварить гречневую кашу. Ты понимаешь, что для того чтобы сварить, тебе нужно сходить и купить гречки.
Но по твоему методу, ты идешь в магазин и покупаешь все крупы которые там есть, тащишь к себе домой их все, а потом стоишь дома перед кастрюлей и смотришь:
Если ЭтоГречка Тогда ПоложитьВКастрюлю; КонецЕсли;
Ты сваришь гречку, а остальные просто выкинешь. Зачем покупал? Зачем домой тащил?

И так будет при каждой варке любой каши...
   Смешной 1С
 
30 - 09.06.18 - 06:52
(27) в журнале регистрации что-нибудь может пишет? База файловая или клиент серверная?
   Сияющий в темноте
 
31 - 09.06.18 - 08:00
Во-впервых,через выбрать,это семерочный код,там он может работать быстрее запроса,в восьмерке же нужно выбирать запросом,тем более,что несколько условий.
И получать обьект только для тех элементов,которые меняем.

во-вторых,я бы разделил вопрос на два и попытался бы просто запустить регламентное задание,которое пишет в журнал строку и сразу завершается,и после того,как оно отработает,уже бы шел к нужной процедуре
   Strogg
 
32 - 09.06.18 - 08:45
1) в параметрах отладки выбрать отладку фоновых заданий.
2) В случае, если база клиент-серверная, убедиться, что в свойствах не включена блокировка выполнения регл. заданий.
3) качнуть обработку консоль заданий с выполнением.
ну а список договоров к изменению, конечно. лучше получать запросом. Разница примерно как с условием в запросе, и параметрами ВТ...



Список тем форума
Рекламное место пустует   Рекламное место пустует
Здесь можно задать вопрос "Как сделать?" и получить кучу ответов, что тебе это делать не надо. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует